Ubuntu servers should display information during boot by default

Bug #548954 reported by Thierry Carrez on 2010-03-26
136
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu CD Images
High
Colin Watson
grub-installer (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson
ubuntu-meta (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
upstart (Ubuntu)
High
Scott James Remnant (Canonical)
Lucid
High
Scott James Remnant (Canonical)

Bug Description

As of Lucid, the work done for a sleek boot for Desktop also affected Server. On beta1, the server boots without any message, displays a graphical splash screen, and exits to the login prompt.

Server users expect to have a verbose boot by default. In particular, they want to get the output of the init.d scripts (complete with "[OK]") to track what happens (like on previous releases). They don't really care about a graphical splash screen.

I understand this won't result in silent upstart scripts to suddenly become self-aware and describe what they are doing, but at least that would allow the legacy init.d scripts to appear as they always did.

Related bug: bug 542666 (init.d output suppressed even when splash and quiet have been removed from boot options)

Thierry Carrez (ttx) on 2010-03-26
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Micheal Waltz (ecliptik) wrote :

I am willing to test on a variety of hardware/VM platforms any changes made. We have a good system in place where we can rapidly update an install image and throw it on a host to see how it performs.

Thierry Carrez (ttx) on 2010-03-30
description: updated
Thierry Carrez (ttx) on 2010-03-30
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: New → Confirmed
Colin Watson (cjwatson) wrote :

This bug involves changes to a number of packages. The changes I know about are as follows:

 * plymouth: fix segfault in vga16fb renderer induced by VT activation while not actually using the renderer (this is already done in plymouth 0.8.1-3, so I shan't bother opening a bug task for it)
 * upstart: 1) add 'console output' to /etc/init/rc.conf, or make it the default for all jobs (Scott, have you decided which you want yet? I prefer the former on grounds of minimum impact); 2) add 'env INIT_VERBOSE' to /etc/init/rc.conf so that INIT_VERBOSE=yes on the kernel command line works, the way it appears to be intended to
 * ubuntu-meta: move plymouth-theme-ubuntu-logo from standard to desktop-common seed, leaving standard with only the built-in details theme, plus plymouth-theme-ubuntu-text to satisfy the Recommends field
 * grub-installer: make it possible for the server CDs to be configured such that 'splash' never ends up on the installed system's kernel command line
 * ubuntu-cdimage: configure the server CDs thus, while making sure that the alternate CDs still get 'splash'

The result of this will be that console messages, including output from init scripts, end up on tty7 during boot. After boot has finished, we'll switch to tty1, which will just have a login prompt on it, but Alt-F7 will show the init script output again. Not all init scripts will produce output, since some are guarded by VERBOSE checks; if you want to see these, boot with INIT_VERBOSE=yes. I believe the default, without VERBOSE, should show very little by default but a reasonable amount of interesting status output for any server system running a non-trivial number of daemons.

Thierry, does this sound OK to you? I'm going to get started with the straightforward bits.

Changed in ubuntu-meta (Ubuntu Lucid):
status: Confirmed → Triaged
Changed in upstart (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-10.04-beta-2
Changed in grub-installer (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
assignee: nobody → Colin Watson (cjwatson)
Changed in ubuntu-cdimage:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Actually, disregard the ubuntu-meta part. I think we should leave plymouth-theme-ubuntu-logo installed, in the knowledge that it won't be used unless we use the 'splash' boot parameter. That way, anyone using a server installation who *does* want a splash screen just has to add 'splash' to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub and run update-grub.

However, we will need to release-note this behaviour for upgraders, and possibly change update-manager to delete the 'splash' parameter on server upgrades.

Changed in ubuntu-meta (Ubuntu Lucid):
importance: High → Undecided
milestone: ubuntu-10.04-beta-2 → none
status: Triaged → Invalid
assignee: Colin Watson (cjwatson) → nobody
Thierry Carrez (ttx) wrote :

Colin, that plan sounds good to me.

On Wed, 2010-03-31 at 22:02 +0000, Colin Watson wrote:

> * upstart: 1) add 'console output' to /etc/init/rc.conf, or make it
> the default for all jobs (Scott, have you decided which you want yet?
> I prefer the former on grounds of minimum impact); 2) add 'env
> INIT_VERBOSE' to /etc/init/rc.conf so that INIT_VERBOSE=yes on the
> kernel command line works, the way it appears to be intended to
>
It's going to be the former.

I suddenly realised that changing the default this late in the cycle,
and so it's different from upstream Upstart, was a plan made entirely of
crazy.

Scott
--
Scott James Remnant
<email address hidden>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package upstart - 0.6.5-6

---------------
upstart (0.6.5-6) lucid; urgency=low

  * Merge fixes from trunk:
    - double-quoting of NIH_CFLAGS and NIH_DBUS_CFLAGS on --with-local-libnih
    - document "env KEY" behaviour
  * conf/rc.conf, conf/rc-sysinit.conf:
    - enable console output. LP: #548954.
    - pass value of INIT_VERBOSE from kernel command-line.
 -- Scott James Remnant <email address hidden> Thu, 01 Apr 2010 19:25:36 +0100

Changed in upstart (Ubuntu Lucid):
status: Triaged → Fix Released
Colin Watson (cjwatson) on 2010-04-01
Changed in upstart (Ubuntu Lucid):
assignee: Colin Watson (cjwatson) → Scott James Remnant (scott)
Colin Watson (cjwatson) on 2010-04-01
Changed in grub-installer (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.49ubuntu10

---------------
grub-installer (1.49ubuntu10) lucid; urgency=low

  * Historically, Ubuntu's default behaviour in the absence of command-line
    arguments to the installer has been to pass 'splash' to the installed
    system so that it gets a splash screen (and similarly 'quiet'). There's
    some argument that this behaviour should require passing 'splash' to the
    installer as well, but it's too late in the Lucid cycle for this change.
    Nevertheless, we need a way to configure images such that they don't get
    'splash' in the installed system, so introduce a 'nosplash' argument
    which inhibits this, for use by the server CD (LP: #548954).
 -- Colin Watson <email address hidden> Thu, 01 Apr 2010 23:44:48 +0100

Changed in grub-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1542
fixes bug(s): https://launchpad.net/bugs/548954
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Fri 2010-04-02 13:33:38 +0100
message:
  add nosplash to kernel parameters on ubuntu-server (LP: #548954)

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
Thierry Carrez (ttx) wrote :

Testing with 20100406 beta2 candidate, "splash" is still present in the boot options. That makes the splash screen show, and alt-F7 switch to an empty screen.

Maybe unrelated, but at first boot after install, the splash screen was echoing lots of "could not write bytes: broken pipe" errors (this could not be reproduced on subsequent boots).

Colin Watson (cjwatson) on 2010-04-06
Changed in grub-installer (Ubuntu Lucid):
status: Fix Released → In Progress
Changed in ubuntu-cdimage:
status: Fix Released → Triaged
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.49ubuntu11

---------------
grub-installer (1.49ubuntu11) lucid; urgency=low

  * 'nosplash' doesn't work because it isn't passed through by user-params.
    Use debian-installer/splash=false for this behaviour instead
    (LP: #548954).
 -- Colin Watson <email address hidden> Tue, 06 Apr 2010 13:26:16 +0100

Changed in grub-installer (Ubuntu Lucid):
status: In Progress → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1546
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Tue 2010-04-06 14:13:38 +0100
message:
  preseed debian-installer/splash=false on server images rather than putting nosplash on the kernel command line (LP: #548954)

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
Alvin (alvind) wrote :

Is it possible that this (very good) decision makes it impossible to see actual errors and suggestions?

For example, if you can't mount a filesystem, nothing on the screen will say so, and you don't see the suggestions. (like pressing S or M) while these keys do work.

Thierry Carrez (ttx) wrote :

@Alvin: I think the mountall missing prompt for S/M is the exception, not the rule. Filed bug 563916 to track that.

Steve Langasek (vorlon) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers