NetworkManager VPN plugins should be installed by default in ubuntu

Bug #278153 reported by Shaun Crampton on 2008-10-04
118
This bug affects 16 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Wishlist
Unassigned
Nominated for Lucid by jhfhlkjlj

Bug Description

Binary package hint: network-manager-gnome

Just upgraded to Intrepid and noticed a VPN tab at nm-applet menu > Edit Connections.... Unfortunately, the whole tab is greyed out so I can't add a VPN. There's no clue as to why it's greyed out (I have connectivity).

$ apt-cache policy network-manager-gnome
network-manager-gnome:
  Installed: 0.7~~svn20080927t101113-0ubuntu1
  Candidate: 0.7~~svn20080927t101113-0ubuntu1
  Version table:
 *** 0.7~~svn20080927t101113-0ubuntu1 0
        500 http://ubuntu.virginmedia.com intrepid/main Packages
        100 /var/lib/dpkg/status

Either, there's a bug/missing feature preventing it from working or the tab should explain why it's greyed out and how to enable it.

Shaun Crampton (fasaxc) wrote :

I have the same problem on my Ubuntu 8.10 beta/64 Bit. What I find particularly strange is that I do have some VPN connections setup manually in the /etc/ppp folder and these are working fine when I start them with pon or poff.

Lex Ross (lross) wrote :

Same problem in network-connections-editor affects me on Ubuntu 8.10 RC/64 Bit. Not to mention that I had to manually install pptp-linux package to no avail. Too bad as my ISP like most ISPs in Russia requires VPN to access Internet. And I need support for both PPTP and L2TP to be available out of the box.

Hi!

I had the same problem here, but I installed network-manager-vpnc and it works fine now. You can do that in Synaptic or typing "sudo apt-get install network-manager-vpnc" in terminal.I think network-manager-vpnc should be installed by default, as in listed as dependency for network-manager. VPN configuration two clicks away is great!

--
Tor Arne Pedersen
torarne at hitthebutton.org

Shaun Crampton (fasaxc) wrote :

Marking confirmed since Tor has got to the root of the problem.

Changed in network-manager-applet:
status: New → Confirmed
Alexander Sack (asac) wrote :

its not a bug if you dont have vpn support when no vpn plugin is installed at all.

Changed in network-manager-applet:
status: Confirmed → Invalid

It wouldn't be a bug if "configure vpn" was not an option without vpn plugin.

As is now, it looks like vpn is built-in to Ubuntu, but it's not, so its confusing for users. Many would think this is a bug, and when you have an option you can choose on the menu, but its not working, what is it then?

Options to solve this issue (if its not a bug, its at least an issue!)
a) VPN-connections and Configure VPN should not be visible by default
b) network-manager-vpnc should be installed by default
c) Selecting Configure VPN should (give an option to) install network-manager-vpnc

I vote for option b, since built-in vpn is something every OS should have.

--
Tor Arne Pedersen
http://hitthebutton.org

This is an valid bug/issue. At this moment you can select "VPN connections" and "configure vpn" and it does not work. It should work, be an extra button to make it work, or not be there at all. See full comment.

Changed in network-manager-applet:
status: Invalid → Confirmed
Alexander Sack (asac) wrote :

please dont bounce bugs thanks. feel free to raise your concerns. i will reopen when its appropriate.

Changed in network-manager-applet:
status: Confirmed → Triaged
Changed in network-manager-openvpn:
importance: Undecided → Wishlist
status: New → Triaged
Changed in network-manager-pptp:
importance: Undecided → Wishlist
status: New → Triaged
Changed in network-manager-vpnc:
importance: Undecided → Wishlist
Alexander Sack (asac) wrote :

targetting for beta jaunty

Changed in network-manager-openvpn:
milestone: none → ubuntu-9.04-beta
Changed in network-manager-pptp:
milestone: none → ubuntu-9.04-beta
Changed in network-manager-vpnc:
milestone: none → ubuntu-9.04-beta
Diver (diver) wrote :

Tor is right. I vote for b, but at least c would be needed.

I apologize for the bounce. I must say I do not understand why this cannot be fixed for Intrepid. Its an easy fix, just one line in the package, and it would be so much clearer for the users. I myself found the solution quite fast, but I see that many other users didn't. If it can be done simpler. Why not?

--
Tor Arne

Diver (diver) wrote :

+1

Shaun Crampton (fasaxc) wrote :

I think this should be considered a minor bug rather than a wishlist item. I think it's a bug because there is no information for the user to use to make the leap from "VPN Add button is greyed out" to "I should install network-manager-vpnc". Making that leap requires the user to
 - guess that there's a missing package (rather than it being greyed out due to some other reason like config mismatch) -- I think you've lost 80% of users here
 - know how to install a package -- loses another 40% of the remaining users
 - take an inspired guess at the package name that is required or find this bug report -- loses 90% of users
 - install the package.

As a comparison, when I go to the network share dialog, I get prompted in a friendly way (that doesn't go into scary technical detail) to install SAMBA. Imagine if you went into the share dialog as a non technical user and it was just greyed out with no warning. Haw would you make the leap to installing SAMBA?

Hi again!

Is there a way to get this issue pushed out to Intrepid what so ever? Who can decide that this is important enough to fix? The job itself is quite easy, so I guess it's just a matter of will and/or ability to see this from a users point of view.

Actually, I guess it's just about as much work to fix this once, for all users world wide, as for each user to fix it herself. So fixing this once for all would save thousands of clicks, google searches, and Synaptic startups. All this energy combined could probably save a tree, or at least a small (it might be tiny) bush!

If it can't be fixed the option to select VPN-connections should just go away. Having non-working options makes the operating system look unfinished. If I was just a user testing Ubuntu for the first time, I would leave Ubuntu and go back to Windows and Cisco VPN client. over an issue like that. Regular users don't use Synaptic or apt-get.

I see Shaun here compares this with SAMBA, which I think is an valid comparishment. You can compare it to anything.. What if GIMP was in the menu, but greyed out, because it was not installed. In my opinion; if it's not installed, it shouldn't be in the menu.

--
Tor Arne Pedersen
torarne @ http://hitthebutton.org

Alexander Sack (asac) wrote :

it cant happen in intrepid anymore. simple reason: adding something to CD after release is technically impossible ;) ... also its not possible from a policy perspective. I cant imagine any issue that could trigger something like that ;).

I know adding software to a physically shipped CD is quite impossible, and that its politically hard/impossible to add something to the iso (but not technically impossible). As a last solution updates can be released, as several of those is - for every release, But to make that happen it has to qualify as a bug, which I think it does. Now I do not have any powers here what so ever, except I can nag and comment till my fingers bleed. :) I guess it's a lost case, but for next Ubuntu I will start testing isos and comment what I believe is bugs earlier.

Now lets say someone agreed with me that this is a bug, then who could decide to put out the update? Maybe its politically easier to make the VPN-Connections choice go away (as an update, not for the CD, since that's "harder")?

I'm sorry for making all this fuzz, but I had a plan about recommending Ubuntu for my users with Intrepid, with the argument that it just works. Now I will not, because it does not just work :(

I guess I could remaster an iso for my users, or they could just stick with Windows.

Diver (diver) wrote :

Is there is any tutorial on how one can remaster such iso?

Alexander Sack (asac) wrote :

Tor, this bug is set to what status? Does that status indicate to you that this bug is not accepted as a bug?

And no ... no option that changes UI is acceptable as a stable release update. Thanks for helping earlier in next cycle. Input is more than welcome and we love to hear ideas for better polishing ;).

err, looks like the status is "shut up you annoying Norwegian, we'll fix it in about 6 months time" :)

I was just trying to convince you to change the status :) Maybe if I take a bunch of cute kittens as hostage...

Diver:
Check http://www.remastersys.klikit-linux.com, here is what I did (not tested the iso yet):
clean install (I did it in virtualbox, but that's optional)
added "deb http://www.remastersys.klikit-linux.com/repository remastersys/" to my /etc/apt/sources.list
apt-get update
apt-get install remastersys
apt-get install network-manager-vpnc
apt-get clean
remastersys dist
done!

Tor Arne Pedersen at hitthebutton.org

Xamusk (ronanpaixao) wrote :

Actually, this bug has been reported since Hardy or before (I have seen it somewhere, but can't find now where) and obviously the Ubuntu team also forgot about it.
It's specially important to ship VPN plugins not only because of the option that is there in the UI, but also because in many places one won't get internet access without a VPN, including many universities. That would of course prevent the plugin installation in the first place and would force one to seek another computer to download the packages, which is non-trivial for non-power-users.

Tux (peter-hoogkamer) wrote :

Why can't this be solved like with ntp? Don't grey out the "Add" button. When this button is clicked all three vpn plugins are installed and you can configure you're vpn.
In the current case users are displayed with a greyed out Add button which means VPN cannot be configured. When the Add button is not greyed out VPN can be configured. I am thinking from the users point of view, if it is there it should work in an easy way.

Xamusk wrote:
> Actually, this bug has been reported since Hardy or before (I have seen it somewhere, but can't find now where) and obviously the Ubuntu team also forgot about it.
> It's specially important to ship VPN plugins not only because of the option that is there in the UI, but also because in many places one won't get internet access without a VPN, including many universities. That would of course prevent the plugin installation in the first place and would force one to seek another computer to download the packages, which is non-trivial for non-power-users.
>
>
we are looking into this for jaunty.

Steve Langasek (vorlon) on 2009-01-29
Changed in network-manager-openvpn:
assignee: nobody → asac
Changed in network-manager-pptp:
assignee: nobody → asac
Changed in network-manager-vpnc:
assignee: nobody → asac
Tux (peter-hoogkamer) wrote :

Xamusk has a point here. What's the problem of installing the three vpn packages by default? This will give you vpn configuration at all times.

On Sat, Jan 31, 2009 at 12:57:01PM -0000, Tux wrote:
> Xamusk has a point here. What's the problem of installing the three vpn
> packages by default? This will give you vpn configuration at all times.
>

This has to be fixed upstream by making the vpn plugins first tier
products. in the past they lacked behind (as you might have noticed).

 - Alexander

Shaun Crampton (fasaxc) wrote :

Surely if the VPN packages were added as dependencies to the ubuntu-desktop package (or network manager) then this would just work? Since Ubuntu own the above packages, why does it need upstream?

Alexander Sack (asac) wrote :

On Mon, Feb 09, 2009 at 06:47:57PM -0000, Shaun Crampton wrote:
> Surely if the VPN packages were added as dependencies to the ubuntu-
> desktop package (or network manager) then this would just work? Since
> Ubuntu own the above packages, why does it need upstream?
>

if upstream doesnt treat it equally important as netowrk-manager it
can happen that we cannot move NM forward because plugins arent fixed
yet. only upstream can fix that.

 - Alexander

Matthew East (mdke) wrote :

Just a quick note: I agree that this bug should be fixed or if not, the dialogue fixed so that it's not totally confusing about why it's greyed out, but if this is changed before Jaunty release it will require a change to documentation.

The bug is currently targetted to beta: if that's to be done, then it should be done sooner rather than later so that we can amend the documentation.

Steve Langasek (vorlon) wrote :

dropping the milestone here; these packages have yet to go through an MIR process, they appear to be some distance from being installed by default, and this isn't a blocker for jaunty.

Changed in network-manager-vpnc:
milestone: ubuntu-9.04-beta → none
status: Triaged → Won't Fix
Changed in network-manager-pptp:
milestone: ubuntu-9.04-beta → none
status: Triaged → Won't Fix
Changed in network-manager-openvpn:
milestone: ubuntu-9.04-beta → none
status: Triaged → Won't Fix
Alexander Gabriel (einalex) wrote :

epic fail

Franziskus Domig (fdomig) wrote :

Agree with Alexander Gabriel. This is really bad ...

Alexander Sack said above that getting these into main and then default could
be difficult because they are not as actively developed as Network Manager
itself, so we could end up stuck with an old NM because of the plugins not
being caught up.

The alternative would be if someone could step up to maintain the plugins
packages and possibly hack them into shape so they work with new versions of
Network Manager more readily...that could be quite helpful in moving things
along. I don't have the skills to work on networking software, but if any of
you...?

I *think* it should be easier to get the command line VPN software moved to
main and installed by default in the short term, so it'll at least be *easier*
to get these plugins if you need to be connected to a VPN to apt-get the
plugins to get on the VPN to apt-get the plugins to get on the....yay
recursion!

Alexander Sack (asac) wrote :

the theory is good, but in practice its not easy to hack those plugins together unless you did a certain amount of network-manager upstream development. The right way to move forward would be to get involved upstream with development of plugins and then once we see that we have all the know-how in ubuntu that allows us to do eventual fixes, we can consider to "main" those packages even though upstream has not committed to support them.

That said, I think we should talk to upstream about making plugins top-level products. I will do that once the release dust has settled a bit. Feel free to remind me.

adx (adxgrave) wrote :
Download full text (4.7 KiB)

i register myself the first time just for this rant. I'm fuc*** disappointed with nm openvpn plugin. Have been tried to use it in 3 release since gutsy. IT NEVER WORK UNTIL NOW!!. Using windows openvpn-gui works perfectly everytime since xp to vista. What the hell?? There're tons of openvpn option cannot be configure which led to massive epic fail like pull redirect gateway?? Which is i just guess because i will never know what the hell is nm want due to whatever syslog or error that so clever only the god zeus could decipher. COME ON. So, u don't want to fix it?? OK no problem. But PLEASE PLEASE PLEASE make it able to import .ovpn file.. or at least tell the user how to convert it so nm can read it. 3 fucking releases just for this and i can't believe it. So u think i don't google? Yeah right...

https://bugs.launchpad.net/ubuntu/jaunty/+source/network-manager-openvpn/+bug/278153

https://lists.ubuntu.com/archives/jaunty-changes/2009-April/009252.html

http://ubuntuforums.org/tags.php?tag=jaunty+openvpn+dbus

http://ubuntuforums.org/forumdisplay.php?f=336&order=desc&page=2

http://ubuntuforums.org/showthread.php?t=1139433

http://ubuntuforums.org/forumdisplay.php?f=336

http://ubuntuforums.org/forumdisplay.php?f=327

http://ubuntuforums.org/showthread.php?p=6175119

http://ubuntuforums.org/showthread.php?t=1021592

http://ubuntuforums.org/showthread.php?t=979085&page=2

http://home.gna.org/kvpnc/en/index.html

https://bugzilla.redhat.com/show_bug.cgi?id=446335

http://www.google.com.my/search?hl=en&q=nm-openvpn+script+failed%3A+external+program+exited+with+error+status%3A+1&btnG=Search&meta=

http://www.google.com.my/search?hl=en&q=nm-openvpn%5B19345%5D%3A+script+failed%3A+external+program+exited+with+error+status%3A+1&btnG=Google+Search&meta=&aq=f&oq=

http://www.google.com.my/search?hl=en&q=network+manager+openvpn+not+working+.ovpn+what+the+hell&btnG=Search&meta=

http://www.google.com.my/search?hl=en&q=network+manager+openvpn+not+working+.ovpn+what+the+helllllllllll&btnG=Search&meta=

http://blogs.gnome.org/dcbw/category/networkmanager/

http://www.google.com.my/search?hl=en&q=network+manager+openvpn+shit&btnG=Search&meta=

http://www.google.com.my/search?hl=en&q=network+manager+openvpn+import+damn+it&btnG=Search&meta=

http://www.google.com.my/search?hl=en&q=fuck+network+manager+openvpn+import&btnG=Search&meta=

https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/287603

https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/91615

https://bugs.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/295333

https://bugs.launchpad.net/ubuntu/gutsy/+source/network-manager-openvpn/+bug/153294

http://linux.derkeiler.com/Mailing-Lists/Ubuntu/2008-11/msg00958.html

https://bugzilla.redhat.com/show_bug.cgi?id=428362

http://www.google.com.my/search?hl=en&q=network+manager+openvpn+import&btnG=Google+Search&meta=&aq=f&oq=

http://www.strongvpn.com/forum/viewtopic.php?id=169

https://forum.perfect-privacy.com/showthread.php?t=298

https://lists.ubuntu.com/archives/ubuntu-users/2008-November/164955.html

https://lists.ubuntu.com/archives/ubuntu-users/2008-November/164898.html

http://www.google.com.my/search?hl...

Read more...

Mackenzie Morgan (maco.m) wrote :

Take your rant elsewhere. We're not upstream for this plugin. If you think
there are improvements to be made, I'm sure the upstream developers will
welcome your patches when you've had time to prepare them.

However, you did just show a reason for this plugin to NOT be included by
default by pointing out its poor quality. Thank you.

Martin Pool (mbp) wrote :

I filed bug 370210 for the specific (hopefully small) GUI change of just explaining in the dialog *why* the controls are greyed out, as requested by https://bugs.edge.launchpad.net/ubuntu/+source/network-manager-vpnc/+bug/278153/comments/28 and others.

Lex Ross (lross) wrote :

It is still not trivial to configure L2TP connection in 9.04 with users reporting that 8.04 scripts stopped working with new release. Just reinforces the idea that things do get broken from one release to another. We really need to do something about this as more and more ISPs move to L2TP Internet connection.

I already did contribute some changes and fixes upstream, and I try to help out on the bugs on network-manager when I have a chance... That said, I'll bring up the issue on the upstream mailing list (if it isn't there already) and see what needs to be done to put the VPN plugins into workable shape for inclusion in the default install.

Alexander Sack (asac) wrote :

On Mon, Jun 22, 2009 at 08:09:15AM -0000, Lex Ross wrote:
> It is still not trivial to configure L2TP connection in 9.04 with users
> reporting that 8.04 scripts stopped working with new release. Just

Is this bug really about l2tp support? I would suggest to make a
separate bug out of it. If possible also create a bug in
bugzilla.gnome.org.

 - Alexander

Shaun Crampton (fasaxc) on 2009-06-23
tags: added: papercut
Mackenzie Morgan (maco.m) wrote :

Given that what prevents this being fixed is the need for a set of developers
willing to "own" these package and their bugs...I'm not sure how much of a
papercut that is.

This requires, at a minimum to follow the bug description, to let the users know that additional packages are required. I see inclusion by default more like a second phase.

Ansus (neptunia) on 2009-10-10
Changed in network-manager-openvpn (Ubuntu):
status: Triaged → Invalid
Changed in network-manager-vpnc (Ubuntu):
status: Triaged → Invalid
Changed in network-manager-openvpn (Ubuntu):
status: Invalid → Confirmed
Changed in network-manager-vpnc (Ubuntu):
status: Invalid → Confirmed
Alexander Sack (asac) wrote :

the pptp part is special and is treated in bug 107738 on its own. invalidating here.

Changed in network-manager-pptp (Ubuntu):
status: Triaged → Invalid
Alexander Sack (asac) wrote :

that said, i am not convinced that we should install all vpn plugins that exist by default. pptp is a exception as some users seem to need that to get online for their provider. so its a bootstrapping thing there. the others could just be installed on-demand using somewizard or something if you go to "add new vpn".

Changed in network-manager-openvpn (Ubuntu):
status: Confirmed → Triaged
Changed in network-manager-vpnc (Ubuntu):
status: Confirmed → Triaged
Mackenzie Morgan (maco.m) wrote :

In some environments the others are bootstrapping things as well. I can't
imagine my school is the only one that requires vpnc to get online. I usually
would sneakernet the debs from a Windows computer in the library to get up and
running when I lived on campus.

Xamusk (ronanpaixao) wrote :

Actually my college requires openvpn to connect. Otherwise one has to dual-boot to Windows or ask a friend to download the packages.

Alexander Sack (asac) wrote :

On Mon, Oct 12, 2009 at 09:41:43PM -0000, Xamusk wrote:
> Actually my college requires openvpn to connect. Otherwise one has to
> dual-boot to Windows or ask a friend to download the packages.
>

OK. thanks for the info.

 - Alexander

abloylas (abloylas) wrote :

This seems to be a duplicate of bug 277496.

Could we get this included for Lucid...?

Chauncellor,

Please refer to bug 107738 about the -pptp plugin being installed by default.

As for the other VPN plugins like -vpnc and -openvpn (and others, -openconnect, maybe more coming up?), I don't think it would be likely that all VPN plugins would be installed by default. Seeing as pptp is a special requirement (needs to be there for some DSL users), this is treated differently, but in other cases it's usually possible to go elsewhere to have Internet access without VPN, or to use another method to get the packages and then be able to use the VPN to connect to a secured network.

As for as the -vpnc, -openvpn, etc. plugins are concerned, I expect interfacing with PackageKit through nm-applet to interactively install new plugins (as per https://bugs.edge.launchpad.net/ubuntu/+source/network-manager-openvpn/+bug/278153/comments/43) is probably far more likely to happen (through I couldn't say "for lucid" for sure).

Martin Pitt (pitti) on 2011-01-07
Changed in network-manager-openvpn (Ubuntu):
assignee: Alexander Sack (asac) → nobody
Changed in network-manager-pptp (Ubuntu):
assignee: Alexander Sack (asac) → nobody
Changed in network-manager-pptp (Ubuntu Jaunty):
assignee: Alexander Sack (asac) → nobody
Changed in network-manager-openvpn (Ubuntu Jaunty):
assignee: Alexander Sack (asac) → nobody
Changed in network-manager-vpnc (Ubuntu Jaunty):
assignee: Alexander Sack (asac) → nobody
Changed in network-manager-vpnc (Ubuntu):
assignee: Alexander Sack (asac) → nobody
no longer affects: network-manager-pptp (Ubuntu)
no longer affects: network-manager-pptp (Ubuntu Jaunty)
no longer affects: network-manager-openvpn (Ubuntu)
no longer affects: network-manager-openvpn (Ubuntu Jaunty)
no longer affects: network-manager-vpnc (Ubuntu)
no longer affects: network-manager-vpnc (Ubuntu Jaunty)
no longer affects: ubuntu-meta (Ubuntu)
tags: removed: papercut
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Wishlist
Mathew Hodson (mathew-hodson) wrote :

network-manager-openvpn is going to be included in main in bug #1574576

After that, it might be reasonable to add it to desktop-recommends.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.