ubuntu-server depends on open-iscsi and runs iscsid

Bug #1630946 reported by Brian Candler on 2016-10-06
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

ubuntu-server has a hard dependency on open-iscsi, which means there is a daemon running (iscsid), and the package cannot be removed. All unnecessary daemons are a cause of concern when auditing a system.

Propose moving this to "Recommends" instead, which currently has:

Recommends: lxd, snapd

Related bugs:
 * bug 1755858: iscsid autostarts on all servers when it has nothing to do

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-server 1.361
ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
Uname: Linux 4.4.0-38-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Thu Oct 6 10:43:04 2016
Ec2AMI: ami-c06b1eb3
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-west-1a
Ec2InstanceType: t2.medium
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
ProcEnviron:
 TERM=xterm-256color
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
SourcePackage: ubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Brian Candler (b-candler) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Medium
Wido den Hollander (wido) wrote :

Noticed this as well. I saw the iscsid daemon running on my systems, but found out that these were installed by default.

root@sat01:~# apt remove open-iscsi
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic linux-headers-4.4.0-63 linux-headers-4.4.0-63-generic linux-headers-4.4.0-64
  linux-headers-4.4.0-64-generic linux-headers-4.4.0-66 linux-headers-4.4.0-66-generic linux-headers-4.4.0-70 linux-headers-4.4.0-70-generic
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  open-iscsi ubuntu-server

This should be modified that open-iscsi is not installed by default

clickwir (clickwir) wrote :

Would like to have the ability to cleanly remove iscsi related processes from systems that don't need it.

Sitting there, it's not hard on resources, but I'm trying to shave off anything I can.

Brian Candler (b-candler) wrote :

Workaround:

systemctl stop iscsid
systemctl disable iscsid

... but I still object to not being able to remove it without also removing ubuntu-server.

This is currently spread across different seeds, we have:

ubuntu.<release>/server
  * open-iscsi
# This is Needed by MAAS images to deploy via iscsi

ubuntu.<release>/server-ship
  * open-iscsi
  * open-iscsi-udeb
# This is for the installer on/through iscsi (server images)

ubuntu.<release>/ship
  * open-iscsi
  * open-iscsi-udeb
# This is for the installer on/through iscsi (non server images)

I think it would be enough to change the first of these, we don't need to even touch the -ship seeds. We want this on the CD Images for convenience and the installer as needed.

So we only talk about ubuntu.<release>/server here and have to requests in one:
a - some want to be able to remove it without removing ubuntu-server (easy, by drop to recommends)
b - some want it not installed by default at all, for that we would need to find a different solution for MAAS images and check if there are others relying on this.

I thought I'd make a merge proposal for Cosmic for (a) and solve it soon.
But then I realized (b) is very different, due to the unification of images I'm not so sure we can fix (b) easily without harmstring various use-cases.
I'll send a few mails to clarify and then come back here with either a (a) fix or an (a+b) fix if there is a way to do so.

I'm wondering if taking it out of ubuntu-server but adding it to cloud-image seed would fix it for most people without breaking major use cases.

The mentioned mail is sent to ensure I'm not missing other use-cases.

Scott Moser (smoser) wrote :

@Christian,

Well, the intended goal is that ubuntu-server == cloud-image.

we did fairly significant work to get as close as we are.
Currently cloud-image [1] differs from ubuntu-server [2] only by
presense of cloud-init and openssh-server.
The goal was to ultimately drop those also, and cloud-init is actually
in a place where we *could* put it into ubuntu-server by default.
openssh-server mentions bug 1576351 as its reason for being left out.

I don't think we should lose ground on the goal.

[1] https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.bionic/view/head:/cloud-image
[2] https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/ubuntu.bionic/view/head:/server

@Scott, I agree and I'm already on a much better fix by bug 1755858
After this there is not much reason left to remove it anywhere (there is but not as much as now).

On top - going forward we can make is a recommends instead of a Depends which help those that want to remove it later.

TL;DR:
- "why is this daemon running" will be addressed by 1755858
- I wan't to be able to remove open-iscsid is this bug
- no need to un-unify images for this anymore

So for this bug we need:
1. make it a recommends
2. ubuntu-meta update for cosmic

For #1 I opened [1] and #2 can only follow after that is merged.

And this can be done independent to bug 1755858 - so no matter if we succeed/fail there one can at least later remove open-iscsid if he wants without taking out the ubuntu-server meta.

[1]: https://code.launchpad.net/~paelzer/ubuntu-seeds/+git/ubuntu/+merge/346948

Brian Candler (b-candler) wrote :

> no matter if we succeed/fail there one can at least later remove open-iscsid if he wants without taking out the ubuntu-server meta.

That's perfect - thank you!

Scott Moser (smoser) on 2018-05-29
description: updated

Seed changes accepted and merged in VCS.
Related ubuntu-meta update uploaded as https://launchpad.net/ubuntu/+source/ubuntu-meta/1.421

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-meta - 1.421

---------------
ubuntu-meta (1.421) cosmic; urgency=medium

  * Refreshed dependencies
  * Moved open-iscsi to server-recommends (LP: #1630946)

 -- root <root@c.lxd> Wed, 30 May 2018 07:01:29 +0000

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released

Other than the mistake to not update to my name on the upload this is resolved.

From now on you can remove it:

# apt remvoe open-iscsi
E: Invalid operation remvoe
root@c:~# apt remove open-iscsi
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  open-iscsi
0 upgraded, 0 newly installed, 1 to remove and 51 not upgraded.
After this operation, 1412 kB disk space will be freed.
Do you want to continue? [Y/n]

As it is just a recommends.

Brian Candler (b-candler) wrote :

Awesome, thanks again!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers