Firefox doesn't display download progress bars

Bug #1630224 reported by Jan Payman Ameli on 2016-10-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-mate-artwork (Ubuntu)
Medium
Unassigned

Bug Description

[ Impact ]

In Firefox I cannot see a download progress bar in the download overviews when downloading a file.

[Test Case]

Download a file with Firefox. Click the download progress icon to the right of the Search entry box. The current download will not show a download progress bar. Clicking show all downloads will display all downloads, but again, progress bars are absent.

After installing the patched package download progress bars will not be displayed via the ongoing download progress summary and Show All Downloads.

[Regression Potential]

None.

Martin Wimpress (flexiondotorg) wrote :

I'm not sure what you're describing in 1. Can you attach an annotated screenshot please?

So, we can't do anything about 2. That is a consequence of moving to GTK3+, the Slider notification theme was "hacked" in GTK2+ to make it appear dark. That trick is not possible in GTK3+. But the Coco notification theme is dark, so you might prefer it.

Yeah, looks like MATE-Faenza-Dark needs a lighter icon.

Changed in ubuntu-mate:
status: New → Incomplete
Changed in mate-icon-theme-faenza (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Jan Payman Ameli (p-ameli) wrote :

Hi Martin, I attached you a screenshot for the first issue mentioned (Firefox). You can see a active download but no progress bar. Normally there should be a progress bar visible.

Jan Payman Ameli (p-ameli) wrote :

Also I attached you another color issue. Please check the fonts of virtual box toolbar. They are very hard to read. I guess the theme just needs some color optimizations for some parts.

Best regards! :)

Jan

Martin Wimpress (flexiondotorg) wrote :

Please don't post new bugs for different packages in an existing bug report, I can't action bugs affecting different packages. I'm going to change this bug to just track the Firefox Download Progress bar issue, it seems the most important.

Please raise new bugs for each of the other issues :-)

Changed in ubuntu-mate:
status: Incomplete → Triaged
no longer affects: mate-icon-theme-faenza (Ubuntu)
summary: - Theme color issues of Ubuntu Mate 16.10
+ Firefox doesn't display download progress bars
Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Triaged
description: updated
Changed in ubuntu-mate-artwork (Ubuntu):
importance: Undecided → Medium
no longer affects: ubuntu-mate
Jan Payman Ameli (p-ameli) wrote :

Thanks I will do that.

Changed in ubuntu-mate-artwork (Ubuntu):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 16.10.9

---------------
ubuntu-mate-artwork (16.10.9) yakkety; urgency=medium

  * Fix Firefox download progress bars. (LP: #1630224)
  * Fix Unlock button for Time and Date Settings. (LP: #1630910)
  * Fix Back/Forward navigation buttons in Yelp. (LP: #1624574)
  * Fix Firefox Search/Location entry box borders. (LP: #1624738)
  * Fix Firefox menu items.

 -- Martin Wimpress <email address hidden> Sun, 09 Oct 2016 20:42:40 +0100

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers