Ambiant-MATE could have improved LibreOffice theming

Bug #1550990 reported by Yousuf 'Jay' Philips on 2016-02-28
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-mate-artwork (Ubuntu)
Undecided
Martin Wimpress

Bug Description

Ubuntu Mate 16.04 Beta 1 & 15.10

LibreOffice pulls a particular color reference from the desktop theme and uses it in various places and it seems the particular color it pulls from the default Ambiant-MATE likely isnt set, as LibreOffice is using black in those areas. This doesnt happen with other bundled themes like Blue-Submarine, High Contrast, Menta, Radiant-MATE, TraditionalGreen, and Yuyo. The only other bundled theme where this issue arises is in GreenLaguna.

The attached screenshot has red square around the areas that are affected by this selected color.

Etamuk (trmfach) wrote :

I can confirm it the black elements.
But here on my computer there also are some artefacts with checkboxes (checked and unchecked).
The only themes without this problems are Green-submarine, Blue-submarine and the two contrast-themes.

Please see my screenshot.
Using Ubuntu MATE 15.10, 64 bit and LibreOffice Version: 5.0.5.2

summary: - Ambiant-MATE theme has problems with LibreOffice
+ Ambiant-MATE could have improved LibreOffice theming
Changed in ubuntu-mate:
importance: Undecided → Low
Etamuk (trmfach) wrote :

What about this bug? I installed MATE 1.14 since a couple of days and i thought this problem would be solved.
Ambiant-MATE is my default theme. But this problem is also present with Blue-Submarine.

When i switch on" OpenGL Rendering" in LibreOffice Settings the problem seems to be solved. But LibreOffice lags a little after switch on this setting.

Using Ubuntu MATE 16.04 with MATE 1.14.1 and LibreOffice 5.1.3.2
CPU Intel Syklake i5 6500 with onboard GPU.

nmaxx (a33ypool3kbhd) wrote :

I can confirm this with Ubuntu MATE 16.04, Mate 1.14.1, LibreOffice 5.1.4.2, GeForce 750Ti (driver version 361.42).
However in my case the OpenGL workaround does not work because it causes the application to crash (fortunately it reverts back to normal rendering on the next restart).

Martin Wimpress (flexiondotorg) wrote :

This is impossible to fix until LibreOffice fully supports GTK3. Basically LibreOffice is using the menu background colour from the GTK2 theme to colour those elements, and it shouldn't.

If all GTK2 menus are made light then LibreOffice looks correct but then all GTK2 applications look incorrectly themed.

Changed in ubuntu-mate:
status: New → Opinion
importance: Low → Wishlist

This issue has been submitted to the libreoffice team - https://bugs.documentfoundation.org/show_bug.cgi?id=101671

Martin Wimpress (flexiondotorg) wrote :

Ubuntu 16.10 ships LibreOffice that use GTK3+ by default and also carries a vendor patch to theme it. It is therefore now possible to address this issue, and we have :-)

no longer affects: ubuntu-mate
Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Fix Committed
assignee: nobody → Martin Wimpress (flexiondotorg)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 16.10.8

---------------
ubuntu-mate-artwork (16.10.8) yakkety; urgency=medium

  * Fix Advanced Menu themes to use flat elements. (LP: #1630366, #1624755)
  * Fix OSD colors. (LP: #1630538)
  * Fix LibreOffice toolbars and theme. (LP: #1624571, #1550990)
  * Fix symbolic icons for GtkExpander.
  * Fix Transmission progress bars. (LP: #1624565)
  * Fix Indicator Applet on transparent panels. (LP: #1598159)

 -- Martin Wimpress <email address hidden> Thu, 06 Oct 2016 23:35:00 +0100

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.