booting with nvidia drivers via nvidia-prime results in no display in 14.04.5

Bug #1610476 reported by Doug McMahon on 2016-08-05
70
This bug affects 21 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
High
Alberto Milone

Bug Description

Pretty simple & not unknown.
Test case:
Optimus laptop
14.04.5 install or 14.04.x upgraded to lts-xenial HWE stack
Install nvidia drivers, reboot
Upon reboot the greeter screen will be blank though the bell will be heard.
Wait 300+ sec. for idle time out, then wake machine up
At that point the display is enabled & will be such for the life of the login session.

Solutions:
1. patch ubuntu-drivers-common to use modesetting for intel (very poor choice I'd think
2. reduce the idle time out in unity-greeter.gschema.xml to 3-4 secs. ( another poor choice but could inadvertently help out, particularly with #4
3. fix this issue ( likely not possible
4. pre-warn users/upgraders in a 14.04.5 release/upgrade note
5. provide a patched lts ubuntu-drivers-common only for 14.04.5 HWE

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-drivers-common 1:0.2.91.11
ProcVersionSignature: Ubuntu 4.4.0-31.50~14.04.1-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Aug 5 19:04:35 2016
InstallationDate: Installed on 2016-08-05 (0 days ago)
InstallationMedia: Ubuntu 14.04.5 LTS "Trusty Tahr" - Release amd64 (20160803)
SourcePackage: ubuntu-drivers-common
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
summary: - booting with nvidia drivers via nvidia-prime results in no display
+ booting with nvidia drivers via nvidia-prime results in no display in
+ 14.04.5
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-prime (Ubuntu):
status: New → Confirmed
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) on 2016-08-05
description: updated
tags: added: lts-xenial
tags: removed: amd64
tags: added: hwe
Doug McMahon (mc3man) on 2016-08-05
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1610476

tags: added: package-qa-testing
Dmitry (grayscale) wrote :

I live with this bug since Ubuntu 15.10 :)
On my laptop modesetting brings much more tearing than intel driver.

That bug is ill-described but yeah, this is why what's happening with
14.04.5 HWE is not unexpected, apparently it's inevitable
re-occurrence was of no big concern.

(- 14.04 HWE is/was also affected but that's a dead dog now.

On 08/06/2016 01:51 PM, Dmitry wrote:
> The same issue I suppose:
> https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1507676
>

Alberto Milone (albertomilone) wrote :

Can you confirm that booting with the "gpumanager_modesetting" kernel parameter solves the problem? The modesetting driver is what we use in 16.04, by the way.

Changed in ubuntu-drivers-common (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Alberto Milone (albertomilone) wrote :

As for the tearing problem, that will be fixed in the near future.

Kurt Felix (verhambruch) on 2017-02-14
Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers