Nvidia-Prime not switching from intel to nvidia leading to a black screen

Bug #1507676 reported by Dave Morley on 2015-10-19
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
nvidia-prime (Ubuntu)
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Critical
Alberto Milone

Bug Description

STEPS:
1. Install 15.10 on a laptop that supports optimus nvidia/intel hybrid graphics
2. Install nvidia and nvidia-prime
3. Open nvidia settings
4. Switch to nvidia
5. Log out
6. Hear the login drums

EXPECTED:
I expect to see the lightdm login page

ACTUAL:
You are presented with a black page

TEMP WORKAROUND:
1. Tap ctrl-alt-f1
2. login
3. run sudo prime-select intel
4. run sudo service lightdm restart
5. System is back running on the intel stack alone.

Dave Morley (davmor2) on 2015-10-19
tags: added: qa-manual-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1507676

tags: added: iso-testing
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Alberto Milone (albertomilone)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.4.11

---------------
ubuntu-drivers-common (1:0.4.11) wily; urgency=medium

  * gpu-manager.c:
    - Rely on /var/log/syslog to get information about unloaded modules.
      This should minimise the current slowdown on boot (LP: #1307069).
    - Switch from intel to modesetting as the default driver on hybrid
      intel/nvidia systems because of a regression in the intel driver
      (LP: #1507676).

 -- Alberto Milone <email address hidden> Mon, 19 Oct 2015 17:35:12 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → Fix Released
Doug McMahon (mc3man) wrote :

A "regression in the intel driver" doesn't seem to explain why this was not an issue in a gnome session, nor to the fact that -
xset dpms force off
xset dpms force on
returned display both in greeter & session
(and nvidia driver loaded & worked fine, with or without a visible display.

you 'fixed' the issue but maybe not for the correct reason

On 20-10-15 22:34:49, Doug McMahon wrote:
> A "regression in the intel driver" doesn't seem to explain why this was not an issue in a gnome session, nor to the fact that -
> xset dpms force off
> xset dpms force on
> returned display both in greeter & session
> (and nvidia driver loaded & worked fine, with or without a visible display.
>
> you 'fixed' the issue but maybe not for the correct reason

I didn't "fix" the issue, I only switched to the modesetting driver as a
workaround. You can still use intel with sna or uxa if you prefer (by
passing either "gpumanager_sna" or "gpumanager_sna" on boot).

I am not sure about the gnome session.

Doug McMahon (mc3man) wrote :

Well then hopefully you can get it so this change to modesetting can be reverted & one isn't forced to get screen to sleep then awake.
My whole point was that this report is claiming that the switch from Intel to Nvidia fails which is not true is any respect.
It's purely a matter of no visible display until the display is put to sleep, the awakened

If the bug reporter had walked away from machine for 300 sec.'s, then pressed a key or moved a mouse they'd have gotten a visible working session under nvidia.

examples, ect. where in prior reports -
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1501041
https://bugs.launchpad.net/ubuntu/+source/nvidia-prime/+bug/1492864

Ben Echols (benpechols) wrote :

I have a system with intel graphics and nvidia k2100m. I was running nvidia-358 and nvidia-prime.

I updated to the newest intel drivers yesterday and now on boot I get an error about my xorg.conf being incorrect.

If I uninstall nvidia entirely everything boots just fine (i can use nouveau and intel still).

I tracked that down to https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1419507 which apparently people thought the issue was related to gpu-manager but Alberto Milone says is related to xserver-xorg-video-intel which led me to this bug.

I am not sure if my bug is exactly the same cause or not but I am willing to do anything to help figure this out... It is very frusterating being unable to use my nvidia drivers.

Ben Echols (benpechols) wrote :

Just a quick update -- disabling gpu-manager in grub (using nogpumanager option) lets me get to login screen. However actually logging in the screen flickers black, and then I hear the login drums again and am back to login. (just like the description of this bug)

Piotr (piotr-tarnowski-u) wrote :

I have similar issue Ubuntu 14.04 LTS (14.04.4 kernel 4.2.0-30-generic) Nvidia geforce 940M
Tried different driver version (331,346,352,355,361) from different sources.

PPA: xorg-edgers - black screen
PPA: graphics-drivers - infinite login loop
http://www.nvidia.pl/download/driverResults.aspx/98425/pl - black screen
and 352 driver from Ubuntu 14.04.4 CD... - this pretends to work on kernel 4.2.0-27-generic, but when you want to switch to performance mode you will get:

Error: alternatives are not set up properly
Error: nvidia mode can't be enabled

And moreover any tool/application using 3D gl graphics is not using nvidia gpu :-(

https://devtalk.nvidia.com/default/topic/921922/linux/nvidia-getforce-gtx-950m-gddr3-black-screen-or-login-loop-when-install-nvidia-driver/?offset=2#4828839

Doug McMahon (mc3man) wrote :

I would think this mis-reported issue will also be going on with 14.04.4 lts which will not include the so-called ubuntu-drivers-common 'fix'
If interested on what really is occurring on optimus laptop & nvidia-prime see here -
https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1501041

14.04.4 lts users can solve with a start up script(s) that put the display to asleep & then wake up or they can adjust the greeter time to sleep to 2 - 4 sec's. Once sleep > awakened on the greeter then the logged in session will be fine.

Piotr (piotr-tarnowski-u) wrote :

The above comments doesn't work. To be honest applying those modification make things even worse. Now I even can't use ctrl+alt+F2 to switch to text mode...

This happened on my Dell M3800 with the Optimus Nvidia GPU and nvidia-prime when updating to the 14.04.5 LTS HWE.

The workaround I used was to force the modesetting driver in xorg.config for the Intel GPU, and not allow changes to xorg.config (see https://vxlabs.com/2015/02/05/solving-the-ubuntu-14-04-nvidia-346-nvidia-prime-black-screen-issue/).

An updated ubuntu-drivers-common to make gpu-manager use the modesetting driver will be most helpful.

Fix needs to be released to 14.04.05 LTS HWE as well

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Vassil Peytchev (vassil-peytchev)
assignee: Vassil Peytchev (vassil-peytchev) → nobody
Doug McMahon (mc3man) wrote :

That seems a poor choice as modesetting would prevent users from setting
Intel to use a tearfree option to eliminate tearing when using the Nvidia
drivers

On Sep 29, 2016 4:55 PM, "Vassil Peytchev" <email address hidden>
wrote:

> This happened on my Dell M3800 with the Optimus Nvidia GPU and nvidia-
> prime when updating to the 14.04.5 LTS HWE.
>
> The workaround I used was to force the modesetting driver in xorg.config
> for the Intel GPU, and not allow changes to xorg.config (see
> https://vxlabs.com/2015/02/05/solving-the-ubuntu-14-04-nvidia-346
> -nvidia-prime-black-screen-issue/).
>
> An updated ubuntu-drivers-common to make gpu-manager use the modesetting
> driver will be most helpful.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1507676
>
> Title:
> Nvidia-Prime not switching from intel to nvidia leading to a black
> screen
>
> Status in ubuntu-drivers-common package in Ubuntu:
> Fix Released
> Status in xserver-xorg-video-intel package in Ubuntu:
> In Progress
>
> Bug description:
> STEPS:
> 1. Install 15.10 on a laptop that supports optimus nvidia/intel hybrid
> graphics
> 2. Install nvidia and nvidia-prime
> 3. Open nvidia settings
> 4. Switch to nvidia
> 5. Log out
> 6. Hear the login drums
>
> EXPECTED:
> I expect to see the lightdm login page
>
> ACTUAL:
> You are presented with a black page
>
> TEMP WORKAROUND:
> 1. Tap ctrl-alt-f1
> 2. login
> 3. run sudo prime-select intel
> 4. run sudo service lightdm restart
> 5. System is back running on the intel stack alone.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-
> common/+bug/1507676/+subscriptions
>

nicholas5 (nick-fellows) wrote :

This bug is also present on 17.10 :(

Frank Earl (linusti) wrote :

What I find _**DEEPLY**_ disturbing is that this bug has been lurking for roughly two plus years with absolutely _**NO**_ resolution whatsoever.

Guys...you're a business and even if it's the "community" working on it, that business is bankrolling the resources you lot are using. If you hadn't figured it out...this rates one of Linus' trademarked vitriolic profanity laced rants. I'd do it, but I'm going to behave and try to figure out how to FIX this instead of "fix" it like you'd fix a dog or cat.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers