[AMD Richland + Topaz XT ] gpu-manager generated xorg.conf is not compatible with switchable graphics

Bug #1410801 reported by Yung Shen on 2015-01-14
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
Medium
Alberto Milone
fglrx-installer (Ubuntu)
Medium
Alberto Milone
Trusty
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Medium
Alberto Milone
Trusty
Medium
Alberto Milone

Bug Description

SRU Request:

[Impact]
Hybrid graphics systems with the AMD+AMD combination will not have an option to switch between power saving mode and performance mode.

[Test case]
1. Install 14.04 and the fglrx driver on a hybrid (laptop) system with two AMD GPUs
2. Reboot the system
3. Launch amdcccle and see if there is an option to switch between power profiles

Expected result:
* There should be an option to switch between power profiles

[Regression potential]
Low, as the change in gpu-manager only affects the codepath that deals with the above mentioned hardware combination.

----------------------

This is a trusty system with two GPUs:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8610G] [1002:990f]
01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260] [1002:6900]

After installing fglrx driver, still not able to swtich in between graphics.

Steps to reproduce:

1. install system with trusty
2. install fglrx
3. sudo amdcccle

Expected result:

Able to see the optoin of switchable graphics

Actual result:

There is no such option.

Verification:

1. Adding "nogpumanager" to kernel parameter
2. Recreate the xorg.conf with "amdconfig --initial".
3. Reboot
4. Open amdcccle
You will able to see the option of switchable graphics

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-drivers-common 1:0.2.91.5
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Jan 14 21:11:29 2015
InstallationDate: Installed on 2015-01-14 (0 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
SourcePackage: ubuntu-drivers-common
UpgradeStatus: No upgrade log present (probably fresh install)

Yung Shen (kaxing) wrote :
Yung Shen (kaxing) wrote :
Yung Shen (kaxing) wrote :
Yung Shen (kaxing) on 2015-01-14
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Daniel Manrique (roadmr) on 2015-01-15
Changed in ubuntu-drivers-common (Ubuntu):
importance: Undecided → Medium
Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
importance: Undecided → Medium
Yung Shen (kaxing) on 2015-01-19
Changed in hwe-next:
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Please also attach the /var/log/Xorg.0.log with gpu-manager enabled and disabled, so that I can compare the two logs.

Changed in hwe-next:
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
Yung Shen (kaxing) wrote :
Alberto Milone (albertomilone) wrote :

Comparing the logs, I don't see anything particularly relevant.

Alberto Milone (albertomilone) wrote :

If calling "amdconfig --initial" instead of creating a xorg.conf from scratch is desirable, I can make that change in gpu-manager. I'll need testers though, as I don't own a unit with AMD+AMD.

Yung Shen (kaxing) wrote :

@Alberto, please feel free to let us know what you need in testing.

Alberto Milone (albertomilone) wrote :

Please follow these steps and report the results:

1) Boot using the "nogpumanager" parameter from the GRUB menu (this will make sure that the xorg.conf is not overwritten)
2) Copy the attached to /etc/X11/xorg.conf
3) Log out and log back in
4) See if it solves the problem

Yung Shen (kaxing) wrote :

Following steps in comment #12 , system boots with VGA controller and able to switch to 3D controller in Catalyst Control Center.

It can also switch back to VGA controller from 3D controller afterward. But then I cannot see the switchable option in Catalyst Control Center.

xorg.conf remains the same as in comment #12.

This can be reproduce by performing Verification steps then steps in comment #12.

Alberto Milone (albertomilone) wrote :

what happens if you follow the verification steps (using "amdconfig --initial" this time, instead of my xorg.conf) and switch between the two GPUs multiple times? Can you always see the switchable option in the Catalyst Control Center?

Yung Shen (kaxing) wrote :

No, I cannot reproduce this problem with xorg.conf generated by amdconfig.

Steps that I did:

1. sudo amdconfig --initial
2. sudo reboot
3. sudo amdcccle # switch it to performance mode(3d controller)
4. logout then login
5. check current graphic controller by glxinfo
6. sudo amdcccle # switch it to powersaving mode(integrated graphic)
7. # repeat couple times

Alberto Milone (albertomilone) wrote :

Ok, thanks, I'll make the relevant changes in gpu-manager.

Changed in ubuntu-drivers-common (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
summary: [AMD Richland + Topaz XT ] gpu-manager generated xorg.conf is not
- compatiable with switchable graphics
+ compatible with switchable graphics
description: updated
Alberto Milone (albertomilone) wrote :

Please accept ubuntu-drivers-common 0.2.91.10 in trusty-proposed.

A note to testers, you will have to remove your /etc/X11/xorg.conf and reboot after installing the update.

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Invalid
Changed in fglrx-installer (Ubuntu Trusty):
status: New → Invalid
Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.4.6

---------------
ubuntu-drivers-common (1:0.4.6) wily; urgency=medium

  * gpu-manager.c, gpu-manager.py:
    - Use the amdconfig tool to configure multi-amd PXpress. This
      fixes a problem where the AMD control panel won't show an
      option to switch between power saving mode and performance
      mode on AMD+AMD hybrid systems (LP: #1410801).
    - The tests now reflect a more relaxed approach so that we
      do not overwrite configurations that are not supported (such
      as multiple xscreens set in the xorg.conf).

 -- Alberto Milone <email address hidden> Fri, 08 May 2015 16:42:32 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: Fix Committed → Fix Released
Alberto Milone (albertomilone) wrote :

Please accept ubuntu-drivers-common (1:0.2.91.10) in trusty-proposed

Hello Yung, or anyone else affected,

Accepted ubuntu-drivers-common into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.91.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Yung Shen (kaxing) wrote :

verified on the original hardware, with ubuntu-drivers-common 1:0.2.91.10
switchable graphics option now appear in Catalyst Control Center and works fine in between two graphics.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.91.10

---------------
ubuntu-drivers-common (1:0.2.91.10) trusty-proposed; urgency=medium

  * gpu-manager.c, gpu-manager.py:
    - Use the amdconfig tool to configure multi-amd PXpress. This
      fixes a problem where the AMD control panel won't show an
      option to switch between power saving mode and performance
      mode on AMD+AMD hybrid systems (LP: #1410801).
    - The tests now reflect a more relaxed approach so that we
      do not overwrite configurations that are not supported (such
      as multiple xscreens set in the xorg.conf).

 -- Alberto Milone <email address hidden> Fri, 08 May 2015 12:48:37 +0200

Changed in ubuntu-drivers-common (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-drivers-common has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in hwe-next:
status: Confirmed → Fix Committed
Changed in hwe-next:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers