ubuntu-docs: Translations are not automatically imported from Gnome-user-docs

Bug #970890 reported by Nicolas Delvaux on 2012-04-01
58
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
ubuntu-docs (Ubuntu)
High
Unassigned

Bug Description

Ubuntu-docs is a Gnome-user-docs fork but both projects still share most of their strings.
Launchpad should automatically import relevant translations, as it does with other Ubuntu packages.

As a temporary workaround, translators can do manual imports, but this raises an ethical problem: by doing so, Gnome translators are not credited for the huge amount of work they provided. Indeed, the "translator-credits" string is handled automatically by Launchpad, so we cannot add upstream credits manually.

According to IRC, this a known issue. But I wanted to report this bug so that it is not forgotten.

description: updated
Matthew East (mdke) wrote :

Launchpad imports translations from upstream packages, but gnome-user-docs is not an upstream package of ubuntu-docs, so that is why translations don't get imported automatically.

Since we began using gnome-user-docs strings, we have always encouraged translators to upload upstream translations manually. Some additional infrastructure would be needed for us to sync gnome-user-docs translations with ubuntu-docs translations, but I agree that it is a good idea. I look forward to suggestions as to how that could be achieved.

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Gabor Kelemen (kelemeng) on 2012-04-08
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
margaret yeager (1shult) on 2012-05-27
Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

Margaret, why are you changing bug statuses without an explanation?

Changed in ubuntu-docs (Ubuntu):
status: Fix Released → Confirmed
Pierre Slamich (pierre-slamich) wrote :

Furthermore, it isn't synced with https://translations.launchpad.net/ubuntu-docs/

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-translations:
status: Triaged → Fix Committed
alessia (posta-grazy) on 2012-12-31
Changed in ubuntu-translations:
assignee: nobody → alessia (posta-grazy)
status: Fix Committed → Opinion
Gabor Kelemen (kelemeng) wrote :

Fix Committed? Opinion? How? Where?
Please folks, don't set statuses without explanation.

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Confirmed
Changed in ubuntu-translations:
status: Opinion → Triaged
Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-translations:
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

(Undoing vandalism by ~arturbryczek.)

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Confirmed
Changed in ubuntu-translations:
status: Fix Committed → Triaged
Pierre Slamich (pierre-slamich) wrote :

Having a quick look at the account, changing the status was to gain karma ?

A solution to the problem would be to create a gnome-docs project with translations, but completely locked (to avoid people translating it on Launchpad), and thus, the translations from Gnome would show up as suggestions in the Ubuntu template. Translators would pick them, and proper attribution would ensue ?

Changed in ubuntu-translations:
assignee: alessia (posta-grazy) → nobody
Changed in ubuntu-translations:
assignee: nobody → marcellemaitre (marcel-lemaitre)
alessia (posta-grazy) wrote :

aiuto| non capisco niente d'inglese|

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → alessia (posta-grazy)
Hendrik Knackstedt (hennekn) wrote :

(Reverted vandalism)

Changed in ubuntu-docs (Ubuntu):
assignee: alessia (posta-grazy) → nobody
Changed in ubuntu-translations:
assignee: marcellemaitre (marcel-lemaitre) → nobody
summary: - Translations are not automatically imported from Gnome-user-docs
+ ubuntu-docs: Translations are not automatically imported from Gnome-
+ user-docs

Alessia per piacere puoi spiegare il motivo del cambiamento? se non capisci l'inglese chiedi aiuto, anche privatamente a me, ma per piacere non cambiare lo stato del bug o assegnarlo a te stessa a meno che tu non intenda risolverlo da sola.
grazie.

(Just talked with alessia, explaining what is going on there)

scusate ma non capisco l'inglese. ho capito che nel mio computer non avviene l'aggiornamento della lingua in automatico ma quando clicco sul vostro link azzurro mi spuntano tante scritte in inglese provo a cliccare su qualcosa ma non funziona niente. io con ubuntu non sono una principiante.

> Date: Thu, 23 May 2013 20:36:05 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 970890] Re: ubuntu-docs: Translations are not automatically imported from Gnome-user-docs
>
> Alessia per piacere puoi spiegare il motivo del cambiamento? se non capisci l'inglese chiedi aiuto, anche privatamente a me, ma per piacere non cambiare lo stato del bug o assegnarlo a te stessa a meno che tu non intenda risolverlo da sola.
> grazie.
>
> (Just talked with alessia, explaining what is going on there)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/970890
>
> Title:
> ubuntu-docs: Translations are not automatically imported from Gnome-
> user-docs
>
> Status in Ubuntu Translations:
> Triaged
> Status in “ubuntu-docs” package in Ubuntu:
> Confirmed
>
> Bug description:
> Ubuntu-docs is a Gnome-user-docs fork but both projects still share most of their strings.
> Launchpad should automatically import relevant translations, as it does with other Ubuntu packages.
>
> As a temporary workaround, translators can do manual imports, but this
> raises an ethical problem: by doing so, Gnome translators are not
> credited for the huge amount of work they provided. Indeed, the
> "translator-credits" string is handled automatically by Launchpad, so
> we cannot add upstream credits manually.
>
> According to IRC, this a known issue. But I wanted to report this bug
> so that it is not forgotten.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/970890/+subscriptions

scusate ma non capisco l'inglese , ho capito che nel mio ubuntu non si
aggiorna il linguaggio in automatico .ho provato a cliccare nel link che
 mi avete mandato ma non succede niente perchè poi non so proseguire
.non ci sono traduzioni delle istruzioni in italiano? scusate i problemi
 che vi ho causato ma è semplicemente che non capisco il testo scritto
in inglese.

> Date: Thu, 23 May 2013 10:39:39 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 970890] Re: Translations are not automatically imported from Gnome-user-docs
>
> (Reverted vandalism)
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Assignee: alessia (posta-grazy) => (unassigned)
>
> ** Changed in: ubuntu-translations
> Assignee: marcellemaitre (marcel-lemaitre) => (unassigned)
>
> ** Summary changed:
>
> - Translations are not automatically imported from Gnome-user-docs
> + ubuntu-docs: Translations are not automatically imported from Gnome-user-docs
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/970890
>
> Title:
> ubuntu-docs: Translations are not automatically imported from Gnome-
> user-docs
>
> Status in Ubuntu Translations:
> Triaged
> Status in “ubuntu-docs” package in Ubuntu:
> Confirmed
>
> Bug description:
> Ubuntu-docs is a Gnome-user-docs fork but both projects still share most of their strings.
> Launchpad should automatically import relevant translations, as it does with other Ubuntu packages.
>
> As a temporary workaround, translators can do manual imports, but this
> raises an ethical problem: by doing so, Gnome translators are not
> credited for the huge amount of work they provided. Indeed, the
> "translator-credits" string is handled automatically by Launchpad, so
> we cannot add upstream credits manually.
>
> According to IRC, this a known issue. But I wanted to report this bug
> so that it is not forgotten.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/970890/+subscriptions

Ok, tieni http://www.point-to-point.it/linux/ubuntu-12-04/ubuntu-12-04-come-cambiare-la-lingua/

comunque questo bug parla di tutt'altra cosa, il tuo problema è dovuto alla mancata installazione dei pacchetti di lingua in italiano.

Nick (nickelderm2008) on 2014-05-28
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Nick (nickelderm2008)
Changed in ubuntu-docs (Ubuntu):
assignee: Nick (nickelderm2008) → nobody
Tobias Scholz (scholzt7) on 2015-08-02
Changed in ubuntu-translations:
assignee: nobody → Tobias Scholz (scholzt7)
Changed in ubuntu-translations:
assignee: Tobias Scholz (scholzt7) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers