Ubuntu Software Center & Language Selector Manuals aren't available online

Bug #931325 reported by Shanmuga prathap S P on 2012-02-13
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
High
Doug Smythies

Bug Description

Repro Steps:
1. Go to https://help.ubuntu.com/12.10/ubuntu-help/session-language.html
2. Scroll to 'Language Support Help' link
3. Click it.

Expected: Go to Language Support Help.
Actual: 'Launch Application' window pops up, with no applications to choose from.

The problem: Ubuntu Software Center and Language Selector manuals are not available online. Therefore hyperlinking to those manuals is impossible.

Robert Roth (evfool) on 2012-02-13
Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

Well on my computer, that links opens the local copy of the Software Center help. Of course, if a computer isn't running Ubuntu, that link won't work and it's a bit weird to be reading the help on the web and click on a link and get local help instead of another webpage.

So this is not a bug? I believe it is not a prerequisite to read the help
only in a computer running Ubuntu.

Thanks,

On Mon, Apr 30, 2012 at 9:42 AM, Jeremy Bicha <email address hidden> wrote:

> Well on my computer, that links opens the local copy of the Software
> Center help. Of course, if a computer isn't running Ubuntu, that link
> won't work and it's a bit weird to be reading the help on the web and
> click on a link and get local help instead of another webpage.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/931325
>
> Title:
> Ubuntu Software Center Manual is not hyperlinked right
>
> Status in “ubuntu-docs” package in Ubuntu:
> Confirmed
>
> Bug description:
> Repro Steps:
> 1. In the link https://help.ubuntu.com/11.10/ubuntu-help/addremove.html, click on "Install additional software" / "Remove an application".
> 2. Click on Ubuntu Software Center Manual link.
> 3. Note that the page opened is 404 Not found.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-docs/+bug/931325/+subscriptions
>

It is a bug that the manuals for Software Center and Language Selector are not available online so there isn't anywhere for us to link help.ubuntu.com to.

https://help.ubuntu.com/12.10/ubuntu-help/session-language.html (the Language Support link at the bottom of the page)

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Triaged
summary: - Ubuntu Software Center Manual is not hyperlinked right
+ Ubuntu Software Center & Language Selector Manuals aren't available
+ online
Changed in ubuntu-docs (Ubuntu):
status: Triaged → Fix Committed
Matthew Paul Thomas (mpt) wrote :

(Undoing vandalism by ~arturbryczek.)

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Triaged
John Kim (kotux) on 2013-06-10
tags: added: doc
removed: center hyperlink manual software ubuntu
John Kim (kotux) wrote :

The link is broken. It's now https://help.ubuntu.com/12.10/ubuntu-help/shell-overview.html#addremove, neither of which has "Install additional software" / "Remove an application" options. But the issue raised by Jeremy still holds in Saucy. It brings up a choose application window, with no applications available to choose from.

The report will be updated to reflect this.

tags: added: saucy
John Kim (kotux) on 2013-06-10
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

For the record as regards Language Support Help:

The text in the Language Support Help document was originally proposed to be included in (the equivalent to) the desktop guide. However, it was considered too detailed for the desktop guide, which is the reason why it's instead shipped as a help document within the language-selector package.

The discussion was held on https://launchpad.net/bugs/742857

Doug Smythies (dsmythies) wrote :

The issue is much bigger. There are 18 occurrences of <link href="apt:bla-bla-bla"> in the documents. They should all be eliminated because they do not work on the html version and the failure is inconsistent, depending on if you are running an ubuntu (gives you as John Kim described) computer or not (give you "Address was Not Understood").

(Yelp-check href also fails.)

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Doug Smythies (dsmythies)
importance: Low → High
status: Triaged → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

Doug,
"Eliminated" sounds a little brutal. Shouldn't they rather be converted to something that works, possibly only in the HTML version of the desktop guide.

Doug Smythies (dsmythies) wrote :

After compiling the html the Makefile calls the script fix-urls.sed, which fixes some but not all of the resulting bad links in the html. I'll see about expanding that script, or adding another one or whatever, to fix the remaining problems.

Doug Smythies (dsmythies) wrote :

The attached script is what I am proposing to fix most of the bad links in the html (note: there are a few corresponding edits in the .page files and the htmk Makefile.).

The one remaining issue is the language-selector help one. I have not been able to find anywhere else to point that one to. I have read the bug report that Gunnar pointed to, and I disagree, it should be in the desktop docs. If not, then it needs to be somewhere in html form on-line so that we can point to it.

Gunnar Hjalmarsson (gunnarhj) wrote :

Doug,
Even if I wrote and have been maintaining the language-selector help document, I propose that you add some code the the script that simply deletes the entire note about Language Support Help. In 14.04 we add a page about installing languages, and there are also other reasons why Language Support Help is no longer so important. After all, there are links to the document both from Ubuntu Help on the disk and from the Language Support UI.

Doug Smythies (dsmythies) wrote :

A branch will be committed and linked dealing with this bug report.

The remaining issue (at least the only issue I am aware of) is with with the Italian HTML compile, where a "ghelp:synaptic" still gets through to the final HTML. This happens in the language specific .page compile phase and is caused by an incorrect translation of string number 1729. I am overriding the translation. This should be checked again after the next POT / PO cycle.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 14.04.2

---------------
ubuntu-docs (14.04.2) trusty; urgency=low

  * media.page:
    - Confusing link removed.
  * shell-guest-session.page:
    - Prevent shell commands from showing up in translation template.
  * unity-launcher-change-autohide.page:
    - Description changed (LP: #1246022).
  * files-browse.page, backup-restore.page, backup-thinkabout.page:
    - Minor fixes (LP: #1225840, LP: #1221461, LP: #1221463).
  * update-translations.sh:
    - Script for renaming exported PO files. Thanks Kevin Godby!
    - A couple of adjustments to get the desired behavior.
  * unity-menubar-intro.page:
    - Description of new app menu option (LP: #1284221).
    - Input source added to list of status menus.
  * keyboard-layouts.page:
    - Notes about IM engine install and preferences button
      (LP: #1282364). Thanks to John Kim for valuable input!
  * whats-new.page:
    - News highlights between 12.04 and 14.04 (LP: #1271492).
  * Updated ubuntu-help.pot.
  * The latest translations exported from Launchpad.

  [ John Kim ]
  * Grammar fixes in power-lowpower.page (LP: #1189282).

  [ Doug Smythies ]
  * Typo fixes in three accounts-*.page pages.
  * ubuntu-help/C/check_validation.sh:
    - Script corrected and significantly improved.
  * ubuntu-mascot-creature.jpg:
    - Give mascot file a generic name (LP: #1287978).
    - Update content and back to JPG from PNG (LP: #1287978).
  * Fix nonexistent link destinations (LP: #1270318, LP: #1231612).
  * Fix "no way to navigate" yelp-check errors (LP: #1270314).
  * Fix or reassign or delete invalid internal links in the compiled
    html (LP: #931325).
  * html/fix-urls.sed:
    - Change gnome help redirects for html to revision neutral stable.
  * Screenshots updated (LP: #1249806).
  * Outdated UI terms updated with correct ones on a bunch of pages.
  * Incorrect sentence removed from nautilus-display.page.

  [ Nigel Hall ]
  * Spelling fix in unity-launcher-menu.page.

  [ goneaway ]
  * Grammar fix in unity-introduction.page.

  [ Kevin Godby ]
  * Spell-checked the *.page files and corrected detected errors.
  * Tweaked the language on whats-new.page.
 -- Gunnar Hjalmarsson <email address hidden> Thu, 20 Mar 2014 20:37:00 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers