"Repeat the search online" does not work

Bug #388750 reported by Caleb on 2009-06-18
26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Website - OBSOLETE
Undecided
Unassigned
Yelp
Invalid
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Low
Unassigned
yelp (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: yelp

This seems to be a perennial problem, which is why I'm reporting it again -- when clicking the "Repeat the search online at the Ubuntu Help Pages" link at the bottom of Yelp's search results, it opens a browser window with the url:
http://search.ubuntu.com/help?os=ubuntu&ver=8.04&q=query
First off, while there is a server running at search.ubuntu.com, it returns a 404 for /help. Second of all, even if the server were working, the version in the URL is 8.04, however I'm running 9.04.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/yelp
NonfreeKernelModules: nvidia
Package: yelp 2.25.1-0ubuntu5
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: yelp
Uname: Linux 2.6.28-11-generic x86_64

Related branches

Caleb (caleb-marcus) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report confirming, but that's it's a ubuntu-docs issue it needs to update the version. (at least for the docs issue) you might want to open a new task for the server side one.

affects: yelp (Ubuntu) → ubuntu-docs (Ubuntu)
Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

This string isn't from ubuntu-docs its in the Yelp source in yelp-search-parser.c

Still looking into it.

Dean Sas (dsas) wrote :

As far as I can tell the version string is disregarded in the current online search, so we can drop that bit of the yelp patch.

Dean Sas (dsas) wrote :

It looks as though the URL needed is http://search.ubuntu.com/results2.html?cx=009650792990864903260%3A-lsdjshi1tu&cof=FORID%3A11&q=SEARCHQUERY

Assuming the cx and cof url params are something to identify our google custom search to google.

The change to the online search will have broken every single supported version of Ubuntu, do we wish to do a server side redirect for them?

Not to split hairs but it's the ubuntu-website that has changed and yelp which has the search patch.

Yes I agree, lets do it server side. I went through yelps source last night and am unclear which XSL gives the string in question (from the comments in yelp-search-parser.c) - I certainly couldn't find it. Perhaps it would be worth bringing yelp back in first, as it might be more obvious than I read it, especially as my C is rusty.

Dougie Richardson wrote:
> Yes I agree, lets do it server side. I went through yelps source last
> night and am unclear which XSL gives the string in question (from the
> comments in yelp-search-parser.c)

Looking at jaunty it's ONLINE_URL in yelp-search-parser.c line 300 or
so, that constant is patched in 06_ubuntu_online_url.patch

Oh right I see it now. We need the website team to sort out the URL though before patching.

Matthew Nuzum (newz) wrote :

The URL for the search should be:

http://search.ubuntu.com/results2.html?cx=009650792990864903260%3A-lsdjshi1tu&cof=FORID%3A11&ie=UTF-8&q=query

I expect this URL to persist for some time so it is safe to use.

Matthew Nuzum (newz) wrote :

I've created an RT (#35121) to have a rewrite rule created. However I've not tried to rewrite based on query strings before. I know this isn't correct but it's close... anyone have a suggestion for the right syntax?

RewriteBase /
RewriteCond %{QUERY_STRING} q=([^&]*)
RewriteRule ^help$
/results2.html?cx=009650792990864903260%3A-lsdjshi1tu&cof=FORID%3A11&ie=UTF-8&q=%1

Goal is turn a url like this:

    http://search.ubuntu.com/help?os=ubuntu&ver=8.04&q=query

into

    http://search.ubuntu.com/results2.html?cx=009650792990864903260%3A-lsdjshi1tu&cof=FORID%3A11&ie=UTF-8&q=query

Dean Sas (dsas) wrote :

It's a ubuntu patch to yelp and a ubuntu website fix that needs making, not upstream yelp.

Changed in yelp:
status: New → Invalid
Changed in yelp (Ubuntu):
importance: Undecided → Low
Dean Sas (dsas) wrote :
Changed in ubuntu-website:
status: New → Fix Released
Dean Sas (dsas) wrote :

Marking the ubuntu-docs task as invalid. ubuntu-website now has a redirect so that this will work. I've proposed a merge to correct the url in yelp so the redirect isn't relied upon forever.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Invalid
Justin White (justin10ec) wrote :

STOP EMAILING ME NOTIFICATIONS.

On Mon, Oct 12, 2009 at 8:58 PM, Dean Sas <email address hidden> wrote:

> Marking the ubuntu-docs task as invalid. ubuntu-website now has a
> redirect so that this will work. I've proposed a merge to correct the
> url in yelp so the redirect isn't relied upon forever.
>
> ** Changed in: ubuntu-docs (Ubuntu)
> Status: Confirmed => Invalid
>
> --
> "Repeat the search online" does not work
> https://bugs.launchpad.net/bugs/388750
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
>
> Status in Ubuntu Website Product: Fix Released
> Status in The Yelp Help Browser for Gnome: Invalid
> Status in “ubuntu-docs” package in Ubuntu: Invalid
> Status in “yelp” package in Ubuntu: New
>
> Bug description:
> Binary package hint: yelp
>
> This seems to be a perennial problem, which is why I'm reporting it again
> -- when clicking the "Repeat the search online at the Ubuntu Help Pages"
> link at the bottom of Yelp's search results, it opens a browser window with
> the url:
> http://search.ubuntu.com/help?os=ubuntu&ver=8.04&q=query
> First off, while there is a server running at search.ubuntu.com, it
> returns a 404 for /help. Second of all, even if the server were working, the
> version in the URL is 8.04, however I'm running 9.04.
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/yelp
> NonfreeKernelModules: nvidia
> Package: yelp 2.25.1-0ubuntu5
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: yelp
> Uname: Linux 2.6.28-11-generic x86_64
>

Dean Sas (dsas) wrote :

Justin White wrote:
> STOP EMAILING ME NOTIFICATIONS.

>> You received this bug notification because you are a member of Ubuntu
>> Documentation Project Team, which is a direct subscriber.

You're getting emails because you have joined the Ubuntu Documentation
Contributors team on launchpad. That team gets emails as it is part of
the Ubuntu Documentation Team which has an interest in this issue (I
think :))

You can remove yourself from the team by visiting
http://launchpad.net/~ubuntu-doc-contributors.

Thanks,
Dean

Justin White (justin10ec) wrote :

Thank you,

I must have unsubscribed at the wrong place

On Mon, Oct 12, 2009 at 9:21 PM, Dean Sas <email address hidden> wrote:

> Justin White wrote:
> > STOP EMAILING ME NOTIFICATIONS.
>
> >> You received this bug notification because you are a member of Ubuntu
> >> Documentation Project Team, which is a direct subscriber.
>
> You're getting emails because you have joined the Ubuntu Documentation
> Contributors team on launchpad. That team gets emails as it is part of
> the Ubuntu Documentation Team which has an interest in this issue (I
> think :))
>
> You can remove yourself from the team by visiting
> http://launchpad.net/~ubuntu-doc-contributors<http://launchpad.net/%7Eubuntu-doc-contributors>
> .
>
> Thanks,
> Dean
>
> --
> "Repeat the search online" does not work
> https://bugs.launchpad.net/bugs/388750
> You received this bug notification because you are a member of Ubuntu
> Documentation Project Team, which is a direct subscriber.
>
> Status in Ubuntu Website Product: Fix Released
> Status in The Yelp Help Browser for Gnome: Invalid
> Status in “ubuntu-docs” package in Ubuntu: Invalid
> Status in “yelp” package in Ubuntu: New
>
> Bug description:
> Binary package hint: yelp
>
> This seems to be a perennial problem, which is why I'm reporting it again
> -- when clicking the "Repeat the search online at the Ubuntu Help Pages"
> link at the bottom of Yelp's search results, it opens a browser window with
> the url:
> http://search.ubuntu.com/help?os=ubuntu&ver=8.04&q=query
> First off, while there is a server running at search.ubuntu.com, it
> returns a 404 for /help. Second of all, even if the server were working, the
> version in the URL is 8.04, however I'm running 9.04.
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> ExecutablePath: /usr/bin/yelp
> NonfreeKernelModules: nvidia
> Package: yelp 2.25.1-0ubuntu5
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: yelp
> Uname: Linux 2.6.28-11-generic x86_64
>

Thank you for posting this bug.

Does this still happen in Lucid?

Changed in yelp (Ubuntu):
status: New → Incomplete
Caleb (caleb-marcus) wrote :

Nope, it works now.

On Mon, Sep 13, 2010 at 4:46 PM, rusivi1 <email address hidden> wrote:

> Thank you for posting this bug.
>
> Does this still happen in Lucid?
>
> ** Changed in: yelp (Ubuntu)
> Status: New => Incomplete
>
> --
> "Repeat the search online" does not work
> https://bugs.launchpad.net/bugs/388750
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Nitesh Mistry (mistrynitesh) wrote :

Bug reporter confirms that it is working now

Changed in yelp (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints