Firefox Non-English Start pages not localized properly

Bug #153124 reported by Amit Bhutani on 2007-10-16
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Low
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Firefox stores it various locale specific start pages under /usr/share/ubuntu-artwork/home/locales/

The purpose of these start pages is to provide useful locale specific links to the Ubuntu Community Forums, Wiki, IRC Chat Channel info etc.

Examining some of the pages that are of interest to Dell, I found that several of these need some fixing. Here is the comprehensive report:

1) SPANISH:

Files: index-es.html, index-es_AR.html and index-es_ES.html

a. The "philosophy" link is not translated
b. The "Wiki" link is not localized
c. The "Community Forums" link is not localized
d. The "Mailing List" link is not localized
e. The respective country main web pages (http://www.ubuntu-es.org/, http://www.ubuntu-ar.com.ar/) are not listed
f. The IRC channel and website info are not listed

Basically, all the info from http://www.ubuntu.com/support/local#head-a72e9b087996cb3a9a064a068f64e66b3c106d24 needs to be incorporated into the respective spanish start pages and they currently are not.

2) FRENCH:

Files: index-fr.html, index-fr_FR.html and index-fr_CA.html

a. The main website ("ubuntu-fr.org") is not listed (Reference: http://www.ubuntu.com/support/local#head-9eeb7d8cfc324eabe05e480dbc39698d8cc74801)

Basically with the exception of the one line item listed above, the french start page is near perfect and a perfect template for how the other non-english pages should be.

3) GERMAN:

Files: index-de.html and index-de_DE.html

a. The "philosophy" link is not translated
b. The "Wiki" link is not localized
c. The "Mailing List" link is not localized
d. The IRC channel and website info are not listed

Basically, all the info from http://www.ubuntu.com/support/local#head-1e9e6e670316872f012c6718fc1ba5837e684338 needs to be incorporated into the respective spanish start pages and they currently are not.

4) PORTUGUESE:

Files: index-pt.html and index-pt_BR.html

a. The "philosophy" link is not translated
b. The "Wiki" link is not localized
c. The "Mailing List" link is not localized
d. The IRC channel and website info are not listed

Basically, all the info from http://www.ubuntu.com/support/local#head-159b068c63a1f74d57603fe9a20b3329f192a1dd needs to be incorporated into the respective spanish start pages and they currently are not.

5) SIMPLIFIED CHINESE:

Files: index-zh_CN.html and index-ZH_TW.html

a. The "philosophy" link is not translated
b. The "Wiki" link is not localized
c. The "Community Forums" link is not localized
d. The "Mailing List" link is not localized
e. The respective country main web page (ubuntu.org.cn) is not listed

Overall, the lack of this proper localization creates a very poor customer experience of Gutsy for someone who is relying on one of these non-english languages and the browser start pages to help him get started on Gutsy.

Changed in dell:
importance: Undecided → High
status: New → Confirmed
Matthew East (mdke) wrote :

Local teams are encouraged to localise links as well in translations - i.e. to point links to pages on the relevant local language websites (e.g. www.ubuntu-fr.org and so on). The best way to resolve this bug is to approach the relevant translation teams to find out what the appropriate pages are.

I don't think it's really appropriate to describe this bug as creating a "very poor" customer experience, after all the local page is just a landing page and these are second level pages which users are likely to visit quite rarely. Equally, the bug is not present in every language. However, it's a valid bug so confirming.

Changed in ubuntu-docs:
importance: Undecided → Low
status: New → Confirmed
Matthew East (mdke) wrote :

We can't really progress this bug any further until the affected translation teams are contacted about this - Amit have you taken this forward?

Matthew East (mdke) wrote :

Nothing seems to be happening about this bug, so I wrote to the translators mailing list.

https://lists.ubuntu.com/archives/ubuntu-translators/2008-March/001438.html

BobMauchin (zebob.m) wrote :

Looking at the french page, all links point to the french website. You want us to add a link to the main page at http://www.ubuntu-fr.org ?
Thanks.
(you should suscribe ubuntu-translators group)

Matthew East (mdke) wrote :

I don't think French can be criticised for not linking to the main page - the English version doesn't even do it. But we should fix that by making the logo link to the main page (bug 108083).

I think that the link in the French page is correct. Anyway, I found a few mistakes in the French page, so here's an uptade version.

Sorry, this is the good one...

Gabor Kelemen (kelemeng) wrote :

Here is an updated version of Hungarian translation, with small wording changes and added links to localized documentation/forum/howtohelpus-page.

David Planella (dpm) wrote :

Please find attached the localised page for the Catalan language. It has been updated and reviewed by the Ubuntu Catalan translation team.

Daniel Nylander (yeager) wrote :

Something must have been done wrong here.

The startpage is now http://start.ubuntu.com/8.04 when testing with Swedish Firefox.

Any other localization teams noticed the same?

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-docs:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Fixed in intrepid according to Matthew.

Changed in ubuntu-docs:
status: Confirmed → Fix Released
David Planella (dpm) wrote :

I can confirm that this is fixed in Hardy (and Intrepid) as well. However, we've got two different browser start pages now, since the online version did not get updated:

* Offline version (ca_ES.UTF-8 locale) -> file:///usr/share/ubuntu-artwork/home/locales/index-ca.html (chrome://ubufox/content/startpage.html). This is the correct version, released as part of ubuntu-docs (8.06.1) hardy-proposed.

* Online version (ca_ES.UTF-8 locale) -> http://start.ubuntu.com/8.04. This still is the old page, without the corrections attached to this bug report and released in the package.

When this lands to hardy-updates, would it be possible to update the online pages with those from ubuntu-docs (8.06.1) hardy-proposed? The pages from the package contain several style and grammar mistakes and contain the correct links to the localized resources (forums, locos, etc).

Changed in dell:
status: Confirmed → Fix Released
Henrik Nilsen Omma (henrik) wrote :

Thanks for confirming the Hardy fix. I don't think we would update the web page as the intrepid page has now changed to a much simpler one. Changing tag to verification-done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 8.06.1

---------------
ubuntu-docs (8.06.1) hardy-proposed; urgency=low

  * Updates to Firefox homepage for Catalan, Korean (LP: #153124, LP: #220889)
  * Text and link fixes from Phil Bull (LP: #222987, LP: #231367)
  * SRU bug: (LP: #243823)

 -- Matthew East <email address hidden> Sun, 22 Jun 2008 11:10:57 +0100

Changed in ubuntu-docs:
status: Fix Committed → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305767

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers