help.ubuntu.com/contributors.html should be removed.

Bug #1219951 reported by Doug Smythies on 2013-09-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-docs (Ubuntu)
Undecided
Doug Smythies

Bug Description

contributors.html is not an accurate nor exhaustive list of who has actually contributed to the Ubuntu official documentation. In my opinion, it is virtually impossible for it to be accurate, or, if it were possible, to be kept accurate.

It should be deleted.

Kevin Godby (godbyk) wrote :

+1. I agree that it should be deleted due to maintenance difficulties.

We should, however, maintain a list of sources for any CC-BY material that we're reusing (e.g., GNOME docs?).

Doug Smythies (dsmythies) wrote :

@Kevin: I do not understand the correlation between this bug report and some list of sources for any CC-BY material. Could you elaborate?

Changed in ubuntu-docs (Ubuntu):
status: New → In Progress
assignee: nobody → Doug Smythies (dsmythies)
Kevin Godby (godbyk) wrote :

While skimming through the existing list of contributors, I noticed "Contributors to the Ubuntu Documentation Wiki" and "Authors of the Official Ubuntu Book". That prompted me to think about what material we may be using that didn't originate with us but may be licensed such that we need to provide attribution.

Whether the attribution is provided on this contributors page or elsewhere is a separate issue/bug, I suppose.

All in all, I'm for deleting the existing contributors page.

Doug Smythies (dsmythies) wrote :

We will leave the actual file present, but remove all individual names and add links for various launchpad teams names and a new link to the GNOME documentation project. Thus satisfying Kevin's CC-BY worries.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Benjamin Kerensa (bkerensa) wrote :

Removing individual names in the case of "The following people have contributed to this documentation:" will remove attribution for historical contributors.

Kevin Godby (godbyk) wrote :

Ben, what do you propose we do?

Benjamin Kerensa (bkerensa) wrote :

Kevin,

Maintain it? It was just updated last cycle.

Doug Smythies (dsmythies) wrote :

Both the ubuntu documentation contributors and ubuntu documentation committers team lists have a former members section.

Doug Smythies (dsmythies) wrote :

As to post #7 from Ben above, referring to revision 97 of help.ubuntu.com. It did not end up as an accurate, nor exhaustive list of contributors, hence this bug report. That same revision also added many names from xubuntu docs, which is not posted on help.ubuntu.com.

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
Matthew East (mdke) wrote :

Benjamin asked me to take a look at bug 1383576, which is marked a duplicate of this one. I think that the licence does require attribution of contributors (see paragraph 4(c) of the licence) but agree that properly maintaining the file is difficult or impossible.

I don't think linking to the Launchpad group (whether or not it points to former members) is necessarily the answer: that would not attribute contributors who were never members of the team. Could it be better perhaps to link to the revision history of the relevant branch(es) which would contain reference to all authors?

Matt

Doug Smythies (dsmythies) wrote :

Hi Matt and thanks very much for chiming in.

Our objective with some of these changes is to eliminate busy non-productive work in an environment where the amount of work to do exceeds the number of people doing it by an enormous amount (I know you are plenty familiar with the scenario).

Since it would require no ongoing maintenance, we will have a look at adding links to the master files revision history for the desktop help guide and the serverguide. Myself, I am not in a hurry to make this change, because I am busy with other things.

Changed in ubuntu-docs (Ubuntu):
status: Fix Released → In Progress
Doug Smythies (dsmythies) wrote :

Actually, I have not been able to figure out a maintenance free way of adding links to the master bzr branch revision histories. There always seems to be a series name involved. For example:
http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/utopic/changes
http://bazaar.launchpad.net/~ubuntu-core-doc/serverguide/trusty/changes

Doug Smythies (dsmythies) wrote :

See:

http://bazaar.launchpad.net/~ubuntu-core-doc/serverguide/trusty/revision/34
By Matt on 2012.02.05, which results in the Credits and License page (page 2) of the compiled PDF serverguide.

I'm going to add the master bzr branch references to the html the same way.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2014-10-23 17:44, Doug Smythies wrote:
> Actually, I have not been able to figure out a maintenance free way
> of adding links to the master bzr branch revision histories. There
> always seems to be a series name involved. For example:
> http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/utopic/changes
> http://bazaar.launchpad.net/~ubuntu-core-doc/serverguide/trusty/changes

It would be easy to change the way we name the branches. Instead of calling a branch for next cycle "vivid" we could call it "trunk", which it actually is anyway since it contains all the revisions. Then, after the release of 15.04 we could copy it to a "vivid" branch and keep using "trunk" during the W cycle etc.

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers