FFe: Please sync ubuntu-dev-tools 0.103 (universe) from Debian experimental (main)

Bug #643691 reported by Benjamin Drung on 2010-09-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-dev-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntu-dev-tools

Please sync ubuntu-dev-tools 0.103 (universe) from Debian experimental (main).

Explanation of FeatureFreeze exception:
The new package fixes a bunch of bug (including four bugs reported on Launchpad). The only new features are the four new scripts:
* errno
* lp-list-bugs
* sponsor-patch
* wrap-and-sort

Changelog entries since current maverick version 0.101:

ubuntu-dev-tools (0.103) experimental; urgency=low

  [ Benjamin Drung ]
  * sponsor-patch:
    - Fix NameError: global name 'debdiff_filename' is not defined.
    - Add --workdir parameter to set the working directory.
  * ubuntutools/update_maintainer.py: Fix failure if debian/control.in is a
    directory.

  [ Luca Falavigna ]
  * debian/control:
    - Add Benjamin Drung to Uploaders.
    - Add DM-Upload-Allowed field, this way Benjamin can upload new
      versions on his own.
  * ubuntutools/misc.py:
    - Use output of dpkg --print-architecture command to correctly display
      platform architecture (Closes: #594424).

  [ Siegfried-Angel Gevatter Pujals ]
  * pbuilder-dist:
     - Do not show a warning when "experimental" is used; there is no
       debootstrap file for it but it should just work anyway.
     - Wrap any extra (user) arguments appended to the pbuilder command with
       quotation marks, when needed (LP: #398989).
  * bash_completion/pbuilder-dist:
     - Enable auto-completion for "pbuilder-experimental".
  * doc/pbuilder-dist.1:
     - Move the documentation for --main-only (previously "mainonly") and
       --debug-echo to a new Options section.

  [ Stefano Rivera ]
  * Add manpages for sponsor-patch and import-bug-from-debian.
  * hugdaylist, manage-credentials, massfile, merge-changelog,
    ubuntutools/requestsync/common.py: Some pyflakes-induced cleanup.
  * ubuntutools/lp/libsupport.py: Support production API URLs in
    translate_web_api.

 -- Luca Falavigna <email address hidden> Wed, 22 Sep 2010 18:13:27 +0200

ubuntu-dev-tools (0.102) experimental; urgency=low

  [ Dustin Kirkland ]
  * errno, doc/errno.1, debian/control, debian/copyright, setup.py:
    - add an errno utility, LP: #612267

  [ Kees Cook ]
  * mk-sbuild: update examples to include "-A".

  [ Benjamin Drung ]
  * suspicious-source: whitelist font source formats. Thanks to Nicolas
    Spalinger for the patch (LP: #365147).
  * Update the man page of suspicious-source to match the rewrite.
  * syncpackage:
    - Don't upload orig tarball if not needed.
    - Print error message if the download fails (LP: #639899).
    - Check if the specified Debian component is valid (LP: #639896).
  * update-maintainer: Don't change the Maintainer field if the email is set
    to a @lists.ubuntu.com address.
  * sponsor-patch: New script to download a patch from a Launchpad bug, patch
    the source package, build, check and uploads it (to Ubuntu or a PPA).
  * wrap-and-sort: New script to wrap long lines and sort items in packaging
    files.

  [ Stefano Rivera ]
  * update-maintainer: Correctly update the Maintainer field to the new Ubuntu
    Developers address (instead of the calling user) when the package is not
    in Debian.

  [ Iain Lane ]
  * all: Use production API rather than edge by default. Should be more
    reliable and was advised by lifeless (LP team).

  [ Michael Bienia ]
  * Add 'natty' to recognized names and make it the default.

  [ Colin Watson ]
  * Fix NAME section of lp-set-dup(1).
  * lp-list-bugs: New tool.

 -- Luca Falavigna <email address hidden> Mon, 20 Sep 2010 11:10:04 +0200

Benjamin Drung (bdrung) wrote :

I have tested errno and lp-list-bugs. They work as expected.

Benjamin Drung (bdrung) wrote :

These scripts needs to be tested if they work with the production Launchpad API:

get-branches
grab-attachments
hugdaylist
import-bug-from-debian
lp-project-upload
lp-set-dup
massfile
requestsync
ubuntu-build

Iain Lane (laney) wrote :

I have used requestsync and ubuntu-build since I made this change. They work.

Stefano Rivera (stefanor) wrote :

Tested: get-branches, grab-attachments, requestsync, hugdaylist

hugdaylist doesn't seem to work (against edge or production)

But there is a production-related bug: translate_web_api seems to require "staging" or "web" in the URL.

Needs testing: import-bug-from-debian, lp-set-dup, massfile

Stefano Rivera (stefanor) wrote :

Fixed hugdaylist

Benjamin Drung (bdrung) on 2010-09-22
description: updated
Benjamin Drung (bdrung) wrote :

ubuntu-dev-tools 0.103 was released to Debian experimental.

description: updated
Scott Kitterman (kitterman) wrote :

Ack. FFe approved.

Changed in ubuntu-dev-tools (Ubuntu):
status: New → Confirmed
Jamie Strandboge (jdstrand) wrote :

[Updating] ubuntu-dev-tools (0.101 [Ubuntu] < 0.103 [Debian])
 * Trying to add ubuntu-dev-tools...
2010-09-24 16:01:03 INFO - <ubuntu-dev-tools_0.103.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-09-24 16:01:03 INFO - <ubuntu-dev-tools_0.103.dsc: downloading from http://ftp.debian.org/debian/>
I: ubuntu-dev-tools [universe] -> ubuntu-dev-tools_0.101 [universe].

Changed in ubuntu-dev-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers