migration-assistant causes an install failure when encountering another OS with multiple users

Bug #980676 reported by 73 on 2012-04-13
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

From another bug report it appears that you must have multiple users on the system the data is being migrated from:

Steps to reproduce:
1. Install some Ubuntu (ex. 10.04) on partition and add several users on them. Each of them should have own firefox configuration.
2. Run Ubuntu 12.04 Precise installation and run installation on new partition. It will hangs, because it was unable to unmount the partition with two users

Acer Aspire 5750g

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: ubiquity 2.10.4
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CasperVersion: 1.312
Date: Fri Apr 13 12:18:35 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120328)
ProcEnviron:
 TERM=unknown
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bashSourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

73 (annevillre65) wrote :

Exception during installation:
Apr 13 10:18:30 ubuntu plugininstall.py: Traceback (most recent call last):
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1720, in <module>
Apr 13 10:18:30 ubuntu plugininstall.py: install.run()
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
Apr 13 10:18:30 ubuntu plugininstall.py: func(self)
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 166, in run
Apr 13 10:18:30 ubuntu plugininstall.py: self.configure_face()
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 284, in configure_face
Apr 13 10:18:30 ubuntu plugininstall.py: shutil.copy2(PHOTO_PATH, targetpath)
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/lib/python2.7/shutil.py", line 128, in copy2
Apr 13 10:18:30 ubuntu plugininstall.py: copyfile(src, dst)
Apr 13 10:18:30 ubuntu plugininstall.py: File "/usr/lib/python2.7/shutil.py", line 83, in copyfile
Apr 13 10:18:30 ubuntu plugininstall.py: with open(dst, 'wb') as fdst:
Apr 13 10:18:30 ubuntu plugininstall.py: IOError: [Errno 2] No such file or directory: '/target/home/jo/.face'
Apr 13 10:18:30 ubuntu plugininstall.py:

tags: added: installer-crash

Apr 13 10:17:32 ubuntu ubiquity: umount: cannot unmount /dev/sda5 -- /dev/sda9 is mounted over it on the same point
Apr 13 10:18:12 ubiquity: last message repeated 2 times
Apr 13 10:18:28 ubiquity: last message repeated 4 times
Apr 13 10:18:28 ubuntu ubiquity[6934]: Reverting lockdown of the desktop environment.
Apr 13 10:18:28 ubuntu activate-dmraid: No Serial ATA RAID disks detected
Apr 13 10:18:29 ubuntu ubiquity: umount: /target: device is busy.
Apr 13 10:18:29 ubuntu ubiquity: (In some cases useful info about processes that use
Apr 13 10:18:29 ubuntu ubiquity: the device is found by lsof(8) or fuser(1))
Apr 13 10:18:29 ubuntu ubiquity[6934]: debconffilter_done: ubi-partman (current: ubi-partman)
Apr 13 10:18:29 ubuntu ubiquity[6934]: Reverting lockdown of the desktop environment.
Apr 13 10:18:30 ubuntu ubiquity: umount: /target/cdrom ist nicht eingehängt
Apr 13 10:18:30 ubuntu plugininstall.py: log-output -t ubiquity umount /target/cdrom

Brian Murray (brian-murray) wrote :

It looks like it is migration-assistant mounting /dev/sda9:

Apr 13 10:13:44 ubuntu migration-assistant: info: setting ostype from: '/dev/sda9:Ubuntu 11.10 (11.10):Ubuntu1:linux'
Apr 13 10:13:44 ubuntu migration-assistant: info: got ostype of: 'linux', mountpoint is: '/ target'
Apr 13 10:13:45 ubuntu kernel: [ 812.201775] EXT4-fs (sda9): mounted filesystem with ordered data mode. Opts: (null)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
description: updated
summary: - during installation a not involved partition was mounted and could not
- be unmounted. Installation was cut down.
+ migration-assistant causes an install failure when encountering another
+ OS with multiple users
Evan (ev) wrote :

I'm interested in what's causing this:
Apr 13 10:13:44 ubuntu ubiquity: /usr/lib/ubiquity/migration-assistant/ma-ask: 140: [: missing ]

Can you please boot into the "Try Ubuntu" option, then stick 'set -x' just below the 'set -e' in /usr/lib/ubiquity/migration-assistant/ma-ask. Run the install until it crashes and then run 'sudo apport-collect 980676'.

Thanks!

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Colin Watson (cjwatson) wrote :

ma-script-utils has this line, which I'm guessing is the culprit for that. I haven't looked at whether it would actually cause this bug.

                    if [ -z "$uuid"]; then

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers