User home not created after install

Bug #978181 reported by Bulat Nigmatullin on 2012-04-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy ubiquity
ubiquity:
  Installed: (none)
  Candidate: 2.10.8
  Version table:
     2.10.8 0
        500 http://ru.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

3) During install I've entered user name 'Bulat Nigmatullin', login 'bulat' , and selected Encrypted home checkbox. After successful install I should be able login to system.

4) I can't login system as bulat from GUI. But can login from console (Ctrl+Alt+F1) and as guest user.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Tue Apr 10 20:43:41 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120410)
ProcEnviron:
 TERM=linux
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Bulat Nigmatullin (bulatka) wrote :
Fabio Marconi (fabiomarconi) wrote :

The user directory is created as bulat

Apr 10 16:07:08 ubuntu user-setup: Adding user `bulat' ...
Apr 10 16:07:08 ubuntu user-setup: Adding new group `bulat' (1000) ...
Apr 10 16:07:08 ubuntu user-setup: Adding new user `bulat' (1000) with group `bulat' ...
Apr 10 16:07:09 ubuntu user-setup: Creating home directory `/home/bulat' ...
Apr 10 16:07:09 ubuntu user-setup: Setting up encryption ...
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Bulat Nigmatullin (bulatka) wrote :

Output from console

guest-Psb472@bcomp2:~$ whoami
guest-Psb472
guest-Psb472@bcomp2:~$ pwd
/tmp/guest-Psb472
guest-Psb472@bcomp2:~$ ls /home/
guest-Psb472@bcomp2:~$

As you can see, actually /home/bulat directory wasn't created.

Brian Murray (brian-murray) wrote :

I've tried recreating this bug using an Ubuntu desktop amd64 iso from 201204010 and was unsuccessful.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Bulat Nigmatullin (bulatka) wrote :

I found it!

My fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=c5097404-05ab-4c35-81d9-f4d599edb8d5 / btrfs defaults,subvol=@ 0 1
# /boot was on /dev/sda1 during installation
UUID=73aed331-c8bd-4e36-adb5-4760ef148044 /boot ext2 defaults 0 2
# /data2 was on /dev/sdb1 during installation
UUID=d29f3499-25d3-4c99-8d8f-c62fae13eb3e /data2 btrfs defaults 0 2
# /home was on /dev/sda7 during installation
UUID=9ff8bd80-d435-48af-9043-34258054c4da /home btrfs defaults,subvol=@home 0 2
# swap was on /dev/sda5 during installation
#UUID=16b5d9d0-6b6b-41b6-9ed3-e1a56cecc285 none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

I've loaded with live cd and browsed created partitions. Root partition with UUID=c5097404-05ab-4c35-81d9-f4d599edb8d5 have the directory @ and all files located in it. Home partition with UUID=9ff8bd80-d435-48af-9043-34258054c4da have dirs bulat and @home . According to fstab @home mounted. That is why bulat directory not available.

Brian Murray (brian-murray) wrote :

I tried again to recreate this choosing btrfs for as the filesystem for my / partition and using an encrypted home and was unsuccessful.

Brian Murray (brian-murray) wrote :

bug 974402 may be related but they did *not* use an encrypted home.

Steve Langasek (vorlon) wrote :

Bulat, is there any chance that this was done using a pre-existing btrfs filesystem?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Bulat Nigmatullin (bulatka) wrote :

Try with my disk layout:
/dev/sda1 /boot ext2
/dev/sda2 swap
/dev/sda3 / btrfs
/dev/sda4 /home btrfs

I think the problem occur when distinct home partition created.
Partitions created using on cd GParted.

I will try it without encrypted home

Bulat Nigmatullin (bulatka) wrote :

With latest iso image this bug reproduced using encrypted home, but without encrypted home everything is ok.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers