Ubuntu

oem-config detecting camera where no camera exists

Reported by Tobin Davis on 2012-01-31
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-ti-omap4 (Ubuntu)
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

SRU:

BUG:

while panda boards have a camera interface, there's no camera (in the optical sense) attached to it

IMPACT:

software (like our installer) detecting the presence of a webcam presented the user with a black screen

FIX:

turn off camera interface support in Ubuntu-3.2.0-1412.15

---

On omap4, the camera module is built into the kernel for development purposes, and creates a /dev/video0 device, but there is no actual camera.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: oem-config 2.9.15
ProcVersionSignature: User Name 3.2.0-1405.7-omap4 3.2.1
Uname: Linux 3.2.0-1405-omap4 armv7l
ApportVersion: 1.91-0ubuntu1
Architecture: armel
Date: Tue Jan 31 10:00:22 2012
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11

CVE References

Tobin Davis (gruemaster) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/924419

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: ubi-webcam
Ricardo Salveti (rsalveti) wrote :

I wonder if we should fix this bug by disabling the camera at the kernel side, but I believe the proper fix here is for ubiquity to check if the camera is valid before trying to use it.

Ricardo Salveti (rsalveti) wrote :
Changed in ubiquity (Ubuntu):
importance: Low → Medium
Ricardo Salveti (rsalveti) wrote :

Changing this to medium because it affects the user experience while installing the image, giving the impression something else is broken.

Stéphane Graber (stgraber) wrote :

Ubiquity actually checks if the webcam is valid using:
gboolean
ubiquity_webcam_available (void) {
 GUdevEnumerator *enumerator;
 GUdevClient *client;
 GList *devices;
 guint length;
   const gchar *const subsystems[] = {NULL};
   client = g_udev_client_new (subsystems);
 enumerator = g_udev_enumerator_new (client);
 g_udev_enumerator_add_match_property (enumerator, "ID_V4L_CAPABILITIES", ":capture:");
 devices = g_udev_enumerator_execute (enumerator);
 length = g_list_length (devices);
 g_list_free_full (devices, g_object_unref);
 return length > 0;
}

As you can see, this doesn't actually try to use it, it just checks for a v4l capture device.
How would one differentiate one of your broken capture devices from a working one?

I'm really not sure we should have that logic in ubiquity, it sounds like a bug to me to expose a /dev/videoX device that has the v4l capture flag set and doesn't actually work like a capture device...

Changed in ubiquity (Ubuntu):
status: Triaged → Incomplete
Ricardo Salveti (rsalveti) wrote :

Checking for a v4l device in this case is not enough, you'd need to try to use it before knowing that it's broken.

While I agree that something can be done at the kernel side, I believe having a better error checking code at ubiquity for devices that fail when accessing it might be something good to have.

Oliver Grawert (ogra) wrote :

well, teh code not only checks for the device availability but if it exposes a capture feature. imho the driver should not expose this unless there is actually a camera attached (it surely doesnt on my uvcvideo devices on all other platforms)

Changed in linux-ti-omap4 (Ubuntu):
importance: Undecided → Medium
Paolo Pisati (p-pisati) on 2012-04-11
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Gema Gomez (gema) wrote :

Why is this bug marked as incomplete for Ubiquity? if it is not in ubiquity then it is invalid, isn't it?

Launchpad Janitor (janitor) wrote :
Download full text (13.5 KiB)

This bug was fixed in the package linux-ti-omap4 - 3.2.0-1412.15

---------------
linux-ti-omap4 (3.2.0-1412.15) precise-proposed; urgency=low

  [ Paolo Pisati ]

  * [Config] Sync fs with master (AUFS, CODA, EXT2, LOGFS and NFS)
  * [Config] Sync core subsys with master (ATA and HID)
  * [Config] sync ata drivers with master
  * [Config] sync input drivers with master
  * [Config] Sync HID drivers with master
  * [Config] Sync sensors wrt master
  * [Config] Sync crypto wrt master
  * [Config] Sync dangerous options wrt master
  * [Config] Sync Industrial IO wrt master
  * [Config] Sync backlight drivers wrt master
  * [Config] Sync charger drivers wrt master
  * [Config] Sync dvb drivers wrt master
  * [Config] Sync pcmcia net drivers wrt master
  * [Config] updateconfigs following rebase
  * blend upstream hdmi detection code and TI bits
    - LP: #963512
  * [Config] disable omap4 camera interface
    - LP: #924419
  * rebased on 3.2.0-23.36

  [ Upstream Kernel Changes ]

  * coda: compilation fix

  [ Ubuntu: 3.2.0-23.36 ]

  * tools/hv: add basic Makefile
    - LP: #977246
  * tools/hv: add basic manual pages
    - LP: #977246
  * Hyper-V KVP daemon -- add to the tools package
    - LP: #977246
  * SAUCE: (drop after 3.3) ALSA: HDA: Remove quirk for Gigabyte
    GA-H61M-S2PV
    - LP: #948360
  * d-i: Add dm-mirror and dm-raid to md-modules
    - LP: #919281
  * [Config] Fix invalid linux-headers link
    - LP: #974403
  * Remove headers asm symlink entirely
    - LP: #974403
  * Revert "x86/ioapic: Add register level checks to detect bogus io-apic
    entries"
    - LP: #974982
  * ALSA: HDA: Realtek: Take vmaster dac from multiout dac list
    - LP: #974090
  * kexec: remove KMSG_DUMP_KEXEC
    - LP: #944772
  * kmsg_dump: don't run on non-error paths by default
    - LP: #944772
  * pstore: Introduce get_reason_str() to pstore
    - LP: #944772

  [ Ubuntu: 3.2.0-22.35 ]

  * Revert "SAUCE: hotkey quirks for various Zeptro Znote and Fujitsu Amilo
    laptops"
  * SAUCE: (no-up) elide some ioctl warnings which are known benign
    - LP: #972355
  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (drop after 3.4) Quirk for enabling backlight hotkeys on Samsung
    N150P
    - LP: #875893
  * SAUCE: PCI: Allow pcie_aspm=force to work even when FADT indicates it
    is unsupported
    - LP: #962038
  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939
  * SAUCE: SECCOMP: audit: always report seccomp violations
  * SAUCE: SECCOMP: adjust prctl constant
  * [Config] Enable CONFIG_USBIP_CORE=m
    - LP: #900384
  * Rebase to v3.2.14
  * [Config] Updateconfigs after rebase to v3.2.14
  * d-i: Fix module name for dm-raid45
    - LP: #969248
  * SAUCE: remove __initdata from vesafb_fix
    - LP: #969309
  * Revert "sched: tg->se->load should be initialised to tg->shares"
  * toshiba_acpi: make one-bit bitfields unsigned
    - LP: #810015
  * ACPI: EC: Add ec_get_handle()
    - LP: #810015
  * toshiba_acpi: Support alternate hotkey interfaces
    - LP: #810015
  * toshiba_acpi: Support additional hotkey scancod...

Changed in linux-ti-omap4 (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.13.17

---------------
ubiquity (2.13.17) raring; urgency=low

  * Remove webcam step (LP: #1118589):
    - User testing showed people are not expecting to be photographed and
      raise privacy concerns as to where the picture will be uploaded to.
    - Provides limited benefit, as avatar only ever shown on multi-login
      systems in the switch user indicator / pkexec.
    - Crashes the installer or doesn't work with certain webcams.
    - Miss detects camera presence, when it's just a sensor.
    - The recommendation is to move webcam test to checkbox / hw testing,
      as video conferencing is very popular these days and should work
      reliably out of the box.
    - LP: #924419 , LP: #981644 , LP: #987392, LP: #1152254, LP: #843354,
      LP: #1008204, LP: #1021449, LP: #1082458, LP: #1103780, LP: #1142751
  * Do not count optional pages, when updating the progress dots. This
    fixes "Porgress dots, well don't progress after partman step"
    LP: #1152746
  * Do not mark explanatory text on "Installation Type" screen
    insensitive, as otherwise it's ineligible (LP: #1074386)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 19 Mar 2013 15:17:51 +0000

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers