ubiquity hangs while jockey-text at 100% CPU

Bug #855042 reported by Chad A. Davis on 2011-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Unassigned
ubiquity (Ubuntu)
High
Ubuntu Installer Team

Bug Description

Expected: Installer to complete "installing base system".
Actual: Ubiquity hangs toward the end of the install.

'top' shows jockey-text at 100% CPU usage. Tailing the logs doesn't provide any insight. Will try this again with ubiquity in debug mode ...

This is ubuntu-oneiric-desktop-amd64+mac.iso on a MacBookPro6,2

The installer is running in German, but that may not be relevant.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: ubiquity 2.7.31
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CasperVersion: 1.284
Date: Tue Sep 20 22:17:56 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110920)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :

Running
  sudo killall jockey-text
allows the installation to continue to completion. The system is bootable and usable after that.

Chad A. Davis (chadadavis) wrote :

Looking at the syslog it may be relevant, that this is a German installation.
I see:

Sep 20 23:07:17 ubuntu ubiquity: Bitte 'j' oder 'n' eingeben und Enter drücken
Sep 20 21:07:18 ubiquity: last message repeated 78 times

Maybe someone somewhere is passing a non-localized 'y' for 'yes' and someone else is expecting a localized 'j' (Ja for yes). Attaching syslog and debug log from ubiquity. This should have more info that the previous logs.

Chad A. Davis (chadadavis) wrote :
Chad A. Davis (chadadavis) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Colin Watson (cjwatson) wrote :

    def check_composite(self):
        '''Check for a composite-enabling X.org driver.

        If one is available and not installed, offer to install it and return
        True if installation succeeded. Otherwise return False.
        '''

        h_id = self.backend().check_composite()

        if h_id:
            self.set_handler_enable(h_id, 'enable', True)
            return bool(self.backend().handler_info(h_id)['enabled'])

        self.error_msg(self._('There is no available graphics driver for your system which supports the composite extension, or the current one already supports it.'))
        return False

Looks like this always asks for confirmation regardless?

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Evan (ev) wrote :

I've proposed the following patch to jockey to fix the prompting issue:
https://code.launchpad.net/~ev/jockey/855042/+merge/77497

Martin Pitt (pitti) wrote :

Jockey fix uploaded to unapproved. Thanks Evan!

Changed in jockey (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.4-0ubuntu9

---------------
jockey (0.9.4-0ubuntu9) oneiric; urgency=low

  * Only ask for confirmation in check_composite if --confirm has been set.
    Thanks to Evan Dandrea! Patch cherrypicked from trunk r740.
    (LP: #855042)
 -- Martin Pitt <email address hidden> Thu, 29 Sep 2011 17:22:09 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Evan (ev) wrote :

Marking the ubiquity task as Invalid. This was a bug in jockey.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers