PowerPC Natty Beta LiveCD Hangs Bad Mirror

Bug #756719 reported by pauljwells on 2011-04-10
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
choose-mirror (Ubuntu)
High
Colin Watson
Natty
Medium
Colin Watson
Oneiric
High
Colin Watson
ubiquity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Trying to install Natty PowerPC from the beta live cd hangs and reports that it cannot find the mirror for packages.
This happens even if no updates are requested and no internet available

Evan (ev) on 2011-04-11
Changed in ubiquity (Ubuntu):
status: New → Invalid
pauljwells (pauljwells) wrote :

The alternate install CD works, but you have to manually specify ports.ubuntu.com for the mirror. The default is just 'Mirror'

Luke Yelavich (themuso) wrote :

Confirming, syslog from a successful alternate install attached where I changed the mirror used.

Changed in choose-mirror (Ubuntu):
status: New → Confirmed
tags: added: iso-testing
Kate Stewart (kate.stewart) wrote :

Be nice to get this default cleaned up if possible.

Changed in choose-mirror (Ubuntu Natty):
milestone: none → ubuntu-11.04
importance: Undecided → Medium
Colin Watson (cjwatson) on 2011-04-14
Changed in choose-mirror (Ubuntu Natty):
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → Triaged
Colin Watson (cjwatson) on 2011-04-14
Changed in choose-mirror (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package choose-mirror - 2.37ubuntu2

---------------
choose-mirror (2.37ubuntu2) natty; urgency=low

  * Record a dummy "GB" entry in templates files for non-country-specific
    mirrors (i.e. ports.ubuntu.com) so that ports installations have more
    choices than just "enter information manually" (LP: #756719).
 -- Colin Watson <email address hidden> Thu, 14 Apr 2011 15:06:37 +0100

Changed in choose-mirror (Ubuntu Natty):
status: Fix Committed → Fix Released
Luke Yelavich (themuso) wrote :

Seems this bug still exists. Will get syslog with next iso test. Altnerates can get around this fine, but desktop images will fail. Too late to be fixed for natty I am sure.

Changed in choose-mirror (Ubuntu Natty):
status: Fix Released → Confirmed
Colin Watson (cjwatson) on 2011-04-28
Changed in choose-mirror (Ubuntu Oneiric):
status: New → Confirmed
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
milestone: none → oneiric-alpha-1
Changed in choose-mirror (Ubuntu Natty):
status: Confirmed → Won't Fix
Changed in ubiquity (Ubuntu Oneiric):
status: New → Invalid
Changed in choose-mirror (Ubuntu):
importance: Medium → High
milestone: ubuntu-11.04 → oneiric-alpha-1
Colin Watson (cjwatson) wrote :

I finally managed to get a qemu setup going for powerpc. For the record:

  qemu-system-ppc -monitor stdio -m 512 -cpu G4 -M mac99 -bios /usr/share/openbios/openbios-ppc -cdrom oneiric-mini-powerpc.iso -hda powerpc-t.img -boot order=d

(You need the openbios-ppc package from Debian.)

Unfortunately, I haven't yet got the network working; bug 789054.

Colin Watson (cjwatson) wrote :

'-net nic,model=e1000 -net user' works.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package choose-mirror - 2.38ubuntu2

---------------
choose-mirror (2.38ubuntu2) oneiric; urgency=low

  * Only default mirror/country to the value of debian-installer/country if
    the latter has any mirrors; otherwise, fall through to defaulting to GB
    (LP: #756719).
 -- Colin Watson <email address hidden> Fri, 27 May 2011 11:50:47 +0100

Changed in choose-mirror (Ubuntu Oneiric):
status: Confirmed → Fix Released
Walter Lapchynski (wxl) wrote :

Trying to install Lubuntu 11.10 on an Apple PowerBook G4 (PPC), I continue to have this problem.

Unlike the problem I had with pygobject, I couldn't simply apt-get install choose-mirror to get around it. apt-get can't seem to find choose-mirror or any related package.

As an alternative, I tried using the alternate installer but had problems with detecting the cdrom. In fact, neither my cdrom or hd seemed to be anywhere in sight in /dev, syslog, dmesg, nothing relevant in /proc, etc.

So I guess I'm kind of stuck.

Is there a way to manually edit a config file (like sources.list) for choose-mirror?

Walter Lapchynski (wxl) wrote :

Might add that I had the same problem with Ubuntu 11.10 on the same machine, though the issue with pygobject was lacking.

Tried running the install without the network; no effect.

Didn't check into the alternate installer.

To further add insult to injury I loaded up a Lubuntu 11.10 VM on my Windoze machine at work. No such problems. That being said, I'm thinking that this problem is specifically plaguing the PPC version of 11.10.

ikke (ikke-iki) wrote :

I'm trying to re-install my hosed g4 mac ubuntu. I grabbed the liveCD from daily builds yesterday, and I still hit this bug:

Dec 12 19:25:53 ubuntu apt-setup: Writing new source list
Dec 12 19:25:53 ubuntu apt-setup: Source list entries for this disc are:
Dec 12 19:25:53 ubuntu apt-setup: deb cdrom:[Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha powerpc (20111211)]/ precise main
Dec 12 19:25:53 ubuntu apt-setup: Repeat this process for the rest of the CDs in your set.
Dec 12 19:25:53 ubuntu apt-setup: W: Skipping nonexistent file /cdrom/dists/precise/main/binary-powerpc/Packages
Dec 12 19:25:55 ubuntu in-target: Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha powerpc (20111211) precise InRelease
Dec 12 19:25:55 ubuntu in-target: Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha powerpc (20111211) precise/main TranslationIndex
Dec 12 19:25:55 ubuntu in-target: Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha powerpc (20111211) precise/main Translation-en_US
Dec 12 19:25:55 ubuntu in-target: Ign cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Alpha powerpc (20111211) precise/main Translation-en
Dec 12 19:25:55 ubuntu in-target: Reading package lists...
Dec 12 19:25:56 ubuntu in-target:
Dec 12 19:25:57 ubuntu choose-mirror[11843]: DEBUG: command: wget -q http://mirror/ubuntu-ports//dists/precise/Release -O - | grep -E '^(Suite|Codename):'
Dec 12 19:25:58 ubuntu choose-mirror[11843]: WARNING **: mirror does not support the specified release (precise)
ubuntu@ubuntu:~$

ikke (ikke-iki) wrote :

to be more precise, I do have internet connection on, but I did not click on any options for internet updates. And I was not asked to select any mirror, and I'm located in Finland. Normally closest mirror would be funet.fi.

Walter Lapchynski (wxl) wrote :

i guess i forgot to mention how to fix this. it's lame, but it works. before the install, edit /etc/apt/sources.list and there should be (if i remember correctly) urls pointing to "mirror" -- replace this with your preferred mirror and you should be good to go.

ikke (ikke-iki) wrote :

it isn't just that. That was the first thing I checked and the /etc/apt/sources.list file was correct on CD. I can even run update&upgrade on livecd. So it must use some different file for sources.list during installing the target fs.

Since this comes at the very end of install, I tried copying sources.list from cd to target fs. Then I did couple of bind mounts and chrooted to target fs. I was able to do update&upgrade there too. I didn't yet find which sources.list it uses during gui installer. Definitely not the /etc/apt/sources.list on the liveCD.

I think this bug is two fold:

 1. It uses corrupt sources.list
 2. It does update from internet even not told to do so by installer settings

The latter bug reveals the first bug.

ojordan (ojordan12345) wrote :

I suspect I'm a bit late with this, but the workaround that used to work was to edit your /etc/hosts file. You add the line

91.189.92.175 ports.ubuntu.com mirror

See the PowerPC Known Issues page for more details: https://wiki.ubuntu.com/PowerPCKnownIssues

Walter Lapchynski (wxl) wrote :

still a problem with precise. to be more precise:
Lubuntu 12.04 _Precise Pangolin_ - Alpha powerpc (20120203) daily-live
ports.ubuntu.com is properly specified (not "mirror") in /etc/apt/sources.list
choose-mirror is not installed (!)
using comment #15 there was no problem, but this is clearly a workaround and not a fix.

Walter Lapchynski (wxl) on 2012-02-05
Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
ojordan (ojordan12345) wrote :

@wxl, Ubiquity includes the choose-mirror code so in a way you do have choose-mirror installed. A fix should now be available to test with the live CDs. See https://bugs.launchpad.net/ubuntu/+source/choose-mirror/+bug/919356 .

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

Well, as of tomorrow, anyway. There was a problem getting ubiquity built, which I sorted out over the weekend.

ojordan (ojordan12345) wrote :

Ah, thanks Colin! I just saw it had been built for powerpc and that there was a ubiquity deb with the right version listed for the live CD. On closer inspection it was an _all.deb file - I always overlook something! Thanks you saved me a download!

@ojordan 20120216 worked fine so assuming no more regressions we should
be good.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers