GrubInstaller failed

Bug #68541 reported by boyAfraid on 2006-10-27
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 166, in ?
    main()
  File "/usr/bin/ubiquity", line 161, in main
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 57, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 305, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 856, in process_step
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 628, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s\n%s" %
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 1404, in ?
    install.run()
  File "/usr/share/ubiquity/install.py", line 385, in run
    self.configure_bootloader()
  File "/usr/share/ubiquity/install.py", line 1163, in configure_bootloader
    raise InstallStepError(
InstallStepError: GrubInstaller failed with code 1

Paul Dufresne (paulduf) wrote :

Just extracting some interesting info from syslog:
Oct 26 22:56:41 ubuntu grub-installer: info: Running chroot /target /sbin/grub-install --no-floppy "(hd0,1)"
Oct 26 22:56:42 ubuntu dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Oct 26 22:56:42 ubuntu grub-installer: Probing devices to guess BIOS drives. This may take a long time.
Oct 26 22:56:42 ubuntu grub-installer: sed: can't read /boot/grub/device.map: Input/output error
Oct 26 22:56:42 ubuntu grub-installer: grep:
Oct 26 22:56:42 ubuntu grub-installer: /boot/grub/device.map
Oct 26 22:56:42 ubuntu grub-installer: : Input/output error
Oct 26 22:56:42 ubuntu grub-installer:
Oct 26 22:56:42 ubuntu grub-installer: /dev/hda2 does not have any corresponding BIOS drive.
Oct 26 22:56:42 ubuntu grub-installer: error: Running 'grub-install --no-floppy "(hd0,1)"' failed.

interesting...

i had no network connection throughout the install so i'm not sure why eth0 is showing up.

also, /dev/hda2 should definitely have existed. however, inspecting the partition table after the failed install, i found the table to be corrupt. i'm not sure if that happened before the grub install failed or not. if so, that might explain the failure.

for the record, i manually edited the partition table at time of install. /dev/hda2 was not touched during the partitioning, though, i did choose to have it reformatted. also, /dev/hda2 was mounted as /boot rather than /. i don't see why that would've affected anything as that is the same setup i had with breezy and dapper.

This bug seems to still exist in feisty. See bug 110923. setting status to confirmed based on duplication.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Id2ndR (id2ndr) wrote :

This bug hasn't been touch for years. I'm marking it as incomplete because it needs to be confirm again if it is still present in latest Ubuntu release (karmic and/or lucid).

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Charlie Kravetz (charlie-tca) wrote :

Are you sure it is the same bug with the changes to grub2 now? I would attach new logs here at the very least, to allow the developers to resolve the issue.

Charlie Kravetz (charlie-tca) wrote :

Hardware test; 400 MHz P2; 256MB RAM; NVidia/SGS Thomsom Riva 128 w/4MB memory

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Lucid Lynx. It won't be fixed in previous versions of Ubuntu because the package doesn't fit the requirements for backporting. See https://help.ubuntu.com/community/UbuntuBackports for more information.

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers