Ubiquity doesn't recognize existing partitions

Bug #559110 reported by Bruno Fernando on 2010-04-09
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

When I try to install Ubuntu 10.04 Beta 2 in my hard drive, it fails to recognize my hard disk partitions. It only shows my primary disk has if there weren't any partitions on it, offering me the possibility to install using the entire disk or manual partitioning.
Choosing manual partitioning, it shows no partition table available (creating a new one is not really what I need)!
I've replicated several times on this beta 2, but also with Ubuntu 10.04 beta 1 and Lubuntu 10.04 beta 1. This always happens, even going strait to the installer after boot.

I'm using the USB flash drive I always use for live cd's, thus the installation media shouldn't be a problem. My usb flash drive has 3 partitions and, usually, the 2 ones not related to the LiveCD appear as optional partitions to use for installation. Now they don't! I suppose this leads to think the problem shouldn't be related directly with the disk itself but by the way Ubiquity finds the available partitions on my system.

Trowing "sudo fdisk -l" report's my correct partitions!

Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001dc02

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 1020 8193118+ 83 Linux
/dev/sda2 1021 1151 1052257+ 82 Linux swap / Solaris
/dev/sda3 1152 7296 49359712+ f W95 Ext'd (LBA)
/dev/sda4 2276 7034 38226636 83 Linux
/dev/sda5 1152 2275 9028467 83 Linux
/dev/sda6 7035 7296 2104483+ 83 Linux

Disk /dev/sdb: 8254 MB, 8254390272 bytes
255 heads, 63 sectors/track, 1003 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000df272

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 132 1060258+ 83 Linux
/dev/sdb2 133 525 3156772+ 83 Linux
/dev/sdb3 526 1003 3839535 83 Linux

Nautilus also shows them correctly in "Places" but fails to mount the primary disk ones (it does mount the ones from the usb disk)!

I can mount and use these partitions from the standard terminal. Tried to install after mounting the partitions I wanted but that has no effect on the installer behavior. Unmounting usb drive partitions also has visible no effect!

Ubiquity version is:

apt-cache policy ubiquity
ubiquity:
  Installed: 2.2.15
  Candidate: 2.2.15
  Version table:
 *** 2.2.15 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Computer is a Acer TravelMate 4000.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.15 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Fri Apr 9 10:40:05 2010
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Not sure how to classify this bug!
After reporting this Ubiquity strange behaviour, my partitions disapeared (one week later, not related)!!! After recovering them with fdisk and parted, Ubiquity was able to recognize my partitions! Not sure why this happened and why didn't Ubiquity recognize my partitions when inside the same liveCD I was able to mount and use as normal. Not an urgent issue, but it would be nice to use this information somehow;
1. enable Ubiquity to "see" partitions like fdisk.
2. use this blindness to predict potential partition corruption/problem?!

kingair_six (kingair6) wrote :

having the same troubles with 10.04 official release. wondering if something's wrong with my partition table?

Hi Kingair,

Maybe, I found a lot of people with this issue also.

If you can, delete all your partitions and make a new partition. This
might solve it. If you can't delete your partitions, there are other
tools but with a lot more work, time and risk of still losing data (I
had to take this one and went just fine).

My disk is still working, but this kind of event (corruption of the
partition table) is usually associated to some kind of iminent problem
with it.

Com os melhores cumprimentos,

*Bruno Fernando* (Eng.º)

/Telemóvel: 964140353/

On 03-05-2010 17:07, kingair_six wrote:
> having the same troubles with 10.04 official release. wondering if
> something's wrong with my partition table?
>
>

Evan (ev) wrote :

Please run the installer from the final Ubuntu 10.04 CD in debug mode. You can do this by pressing "Try Ubuntu" at the first screen, then hitting alt-F2 when the desktop finishes loading. Type `ubiquity -d` in the box that appears. Run the installer until you get to the manual partitioning page, then hit alt-F2 again and type `apport-collect 559110`.

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
nitrogen (i-am-nitrogen) wrote :

Possible cause (this affects me too, with the release version of 10.04 LTS):

The Windows 7 installer sometimes creates two partitions, a 100MB boot partition and the rest as the main OS partition (a.k.a. the C drive). The problem seems to stem from the fact that the first partition is *exactly* 100MB, and thus doesn't end on a cylinder boundary. This makes the second partition start on a non-cylinder-boundary sector. Running parted gives the following error:

   # parted
   (parted) print
   Error: Unable to satisfy all constraints on the partition.
   (parted)

Here's some sample output from fdisk -u -l:

   # fdisk -u -l /dev/sda

   Disk /dev/sda: 500.1 GB, 500107862016 bytes
   255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
   Units = sectors of 1 * 512 = 512 bytes
   Sector size (logical/physical): 512 bytes / 512 bytes
   I/O size (minimum/optimal): 512 bytes / 512 bytes
   Disk identifier: 0x76692ca8

      Device Boot Start End Blocks Id System
   /dev/sda1 2048 206847 102400 7 HPFS/NTFS
   Partition 1 does not end on cylinder boundary.
   /dev/sda2 206848 174563327 87178240 7 HPFS/NTFS
   /dev/sda3 * 174578355 254421404 39921525 7 HPFS/NTFS
   /dev/sda4 254421405 976768064 361173330 f W95 Ext'd (LBA)
   /dev/sda5 254421468 258341264 1959898+ 82 Linux swap / Solaris
   /dev/sda6 258341328 315870029 28764351 83 Linux
   /dev/sda7 315870030 976768064 330449017+ 7 HPFS/NTFS

The correct behavior would be for partman/parted to warn about the odd partition layout and continue normally, rather than try to apply constraints on newly-created partitions to the data already on the disk. As I recall, this was the behavior in 9.04, as I used gparted on a 9.04 live CD to add new partitions to the drive in the first place.

nitrogen (i-am-nitrogen) wrote :

I must correct my previous post. The actual cause was possibly-overlapping partitions in the extended partition. Fdisk's numbers all look good, but cfdisk reported the following (very helpful) error:

   FATAL ERROR: Bad logical partition 6: enlarged logical partitions overlap

I deleted /dev/sda5 and /dev/sda6, and now parted and cfdisk work. I imagine that changing the end sector of /dev/sda6 would have worked too. It would be very helpful if parted, ubiquity, and partman could report this kind of error in more detail, instead of just showing an empty disk. This error appeared after using gparted (from 9.10) to move /dev/sda7 (NTFS) right by 15GB to make more room for /dev/sda6 (ext4).

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/559110

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers