[Lucid Xubuntu] Manual partitioning using Desktop image can not be done

Bug #506585 reported by Charlie Kravetz on 2010-01-12
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Lucid
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Release: Lucid Lynx
CD/DVD Variant: 32bit Xubuntu desktop
ISO Build: 2010-01-12.1
Symptoms: When installing from the live environment, choose manual partition, no partition can be deleted. I can change size of existing partitions, or choose to use one of the existing partitions.
Steps To Produce:
1. Start the desktop cd, choose "Try xubuntu without modifying the system"
2. When the live desktop comes up, click "Install Xubuntu 10.04" icon
3. Proceed to the partition screen.
4. Select Manual Partition
5. attempt to delete existing partition

ProblemType: Bug
Architecture: i386
Date: Tue Jan 12 12:33:50 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Xubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100112)
Package: ubiquity 2.1.9
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SourcePackage: ubiquity
Tags: lucid
Uname: Linux 2.6.32-10-generic i686

Charlie Kravetz (charlie-tca) wrote :
Dave Morley (davmor2) wrote :

Also affects Ubuntu installs

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2010-01-14
Changed in ubiquity (Ubuntu Lucid):
milestone: none → lucid-alpha-3
Evan (ev) wrote :

This was caused by r3643.

Changed in ubiquity (Ubuntu Lucid):
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2010-01-16
Changed in ubiquity (Ubuntu Lucid):
assignee: nobody → Colin Watson (cjwatson)
status: In Progress → Fix Committed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.11

---------------
ubiquity (2.1.11) lucid; urgency=low

  [ Evan Dandrea ]
  * Remove ubiquity on successful completion of oem-config (LP: #210779).

  [ Didier Roche ]
  * Rebuild needed to take 1.28ubuntu2 user-setup-apply version (LP: #507121)

  [ Colin Watson ]
  * Log calls to partman's freeze_choices and thaw_choices.
  * Revert frozen choices change from 2.1.8. Instead, arrange to thaw
    choices for partman/choose_partition immediately *before* going back to
    it at the end of building the cache, rather than just after it's
    displayed when thawing choices has no immediate effect (LP: #506585).
  * Automatic update of included source packages: partman-base 135ubuntu4,
    user-setup 1.28ubuntu2.
 -- Colin Watson <email address hidden> Sat, 16 Jan 2010 00:31:16 +0000

Changed in ubiquity (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers