wrong keyboard layout when reconfiguring xserver-xorg

Bug #46046 reported by Xavier Claessens on 2006-05-22
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: xserver-xorg

Hi,

I've installed ubuntu dapper Beta1 with ubiquity. My keyboard layout was configured to "be" and keyboard model "pc105" which is good.

Now I ran « sudo dpkg-reconfigure -phigh xserver-xorg » and my keyboard falls to "pc104" and layout "us". Shouldn't it remember my preferences from the first installation ?

Thanks.

Colin Watson (cjwatson) wrote :

This still exists with console-setup in Edgy. Looks like we need to preseed X harder.

Changed in ubiquity:
status: Unconfirmed → Confirmed
importance: Medium → High
Nick Demou (ndemou) wrote :

do you thing bug 63178 is related?
   https://launchpad.net/distros/ubuntu/+source/ubiquity/+bug/63178

from that bug's report:
 > After installing Kubuntu Edgy Beta and selecting Greek language and Greek
 > keyboard layout, no xkb group switching option is set in xorg.conf.

Colin Watson (cjwatson) wrote :

I doubt it.

Andrew Henry (adhenry) wrote :

this bug is still present in Feisty beta!

Anders Hall (kallebolle) wrote :

Please also see Bug #150894 which is related. This is a major problem with all Ubuntu distros, releases/upgrades and development procedures.

I've had many versions of similar problems. Overall this is a major development problem since it happens frequently and in many ways. The impact varies greatly and in some cases, as in mentioned bug, affect security issues.

mabovo (mabovo) wrote :

This bug is still present in Gutsy so

mabovo (mabovo) wrote :

Brazilian abnt2 keyboard variant looses its configuration in Hardy 8.04.
In System > Preferences > Keyboard > Layouts there is not possible to fix brazilian abnt2 as default permanently.
After a new reboot, keyboard configuration return to english generic 105 keys Intl. PC.

Anders Hall (kallebolle) wrote :

Related: Bug #23475

Taygeto (taygeto) wrote :

Having the same problem as mabovo with Hardy beta. I chose the Belgian keyboard layout, but ubuntu keeps switching back to the English layout on reboot.

Menda (bymenda) wrote :

Same problem in Hardy Beta (8.04).
I choose Spanish keyboard layout and after rebooting it goes back to the English one.

Menda (bymenda) wrote :

OK, I fixed it configuring /etc/X11/xorg.conf:
in Section "InputDevice" I added:
  Option "XkbModel" "pc105"
  Option "XkbLayout" "es"

Markus Johansson (majohans) wrote :

Have the same problem (ubuntu hardy 8.04). I think it first appeared when i reconfigured xserver-xorg.

If you look at the attachment it showing, In System > Preferences > Keyboard > Layouts, it doesn't matter which language i have chosen(with the radio button), it only matters which one that is one the top. The topmost one is the one being used in the test typing field.

grauscho (grauscho) wrote :

I'm using a laptop with hardy and had problems with the resolution of an external monitor.

So i ran dpkg-reconfigure -phigh xserver-xorg.

Afterwards, keyboard layout was changed in xorg.conf from "de" to "us".
This had the effect that I could not login under X because my password contained special characters.

I knew how to fix this, but this could be a source of frustration for a newbie.

Anders Hall (kallebolle) wrote :

> Thomas

I described that problem in: Bug #150894 . Several bugs, with different symptoms, all relate to broken support for international languages. The truth is, regardless of what the official site say, that Ubuntu do not (fully) support International languages.

> All

I find it remarkable that this was not a first priority in the release of the latest long-term support edition. Several other, quite specific (and minor) problems, took precedence in the blueprint process.

Especially, if you consider I have just experienced, as I have in all previous releases counting back to v5, all those problems described in the super old Bug #23475 , this bug, the password/language bug (+ several other minor bugs related to language/keyboard/charset).

Note: in Bug #150894 I mention a few things that has improved - and a few things that has not yet been improved (that bug is getting old too). I've described the login process in more detail (since it is broken too).

Krzysztof Foltman (kfoltman) wrote :

Similar (or the same?) problem is also present on my Ubuntu Studio 8.04 machine. The set of symptoms:

- default keyboard layout is Polish and no other layout is selected in keyboard panel
- after system restart (and autologin), US keyboard layout is in effect, while the keyboard indicator shows "Pol" (short for Polish); "Show current layout" shows an empty window
- there's a trick to make it work for the lifetime of a session (at least until system restart): go to keyboard applet, select layout options and select/unselect something
- after doing this, the Polish keyboard is activated and "Show current layout" works properly

Quite surprising, too, because a relatively common operation (setting non-US keyboard layout) requires manual modification of X11 config file (with no guarantee that further update will keep the setting intact) or workarounds like the one described above. Might be quite scary for non-technical users.

r12056 (r12056) on 2010-02-08
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
pererik87 (pererik87) wrote :

i got a US keyboard after install but chose norwegian in the installer using "guess"

haggi (jpicht85) wrote :

Same problem here. But it didn't start with a manual reconfiguring of xserver-xorg but with some updates yesterday (or the day before yesterday).

Please fix this.

Frantique (undernetangel) wrote :

Confirmed.

hoppus2a (hoppus2a) wrote :

same problem like @haggi the bug came after an update couple day ago.

Dmitry Tantsur (divius) wrote :

The same thing: my guessed layout is Russian but after reboot I had Kongo!

Dodosi (doruktayfun) wrote :

I have the same problem with my toshiba laptop. 9.10.

tags: added: dapper-beta1
tags: added: edgy-beta1 feisty-beta gutsy hardy-beta karmic
MillenniumBug (millenniumbug) wrote :

Closing this bug report, since it concerns only obsolete versions of Ubuntu.

If a similar problem occurs in 11.04, feel free to open a new bug report or comment on an existing one.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers