Comment 7 for bug 444901

Fred Korz (korz-vendor) wrote :

I've had a similar experience in an independent environment, confirming it's not unique to NoOp's setup, and narrowed down some hypotheses seen in mailing list posts (which led me here).

My test environment is a 1.2GHz Via C3 box, running Debian (squeeze) and virtualbox, used to test Ubuntu and other installations in virtual machines.

Using 384MB and 512MB virtual machines, with virtual disks of 8GB per virtual machine, I tried a series of things.

 * 9.04 OK: A 9.04 graphical desktop install went fine.

 * 9.10 overlay FAIL: Wanting to try 9.10 beta (before upgrading my netbook) I attempted to install over the 9.04 in the virtual machine. I selected the erase and use whole disk. It failed in the way described above.

 * 9.10 clean FAIL: On the chance it was the installing over 9.04, I deleted the virtual disk and provided a new, empty one. Same failure.

 * 9.10 alt installer - OK: Thinking it might be the installer or virtual machines RAM size, I used the alternate installer and raised the VM's RAM to 512MB and with a new, empty virtual disk. Success

 * 9.10 clean moreram FAIL: To check installer vs. RAM, I tried 512MB RAM, regular 9.10 beta installer and a new, empty virtual disk. Failure as above.

So, whether two disks as NoOp wrote or one virtual disk in my case, no difference - regular installer fails with the 0 bytes message, alternate installer succeeds.

Also, the amount of memory which can be a sensitive point for some Linux distributions' installers, no difference in outcome.

For reference I'll attach three pngs from the failure path.