[Jaunty and Karmic] the installer by default proposes a wrong size for the Ubuntu partition (far too small)

Bug #421407 reported by Pjotr12345 on 2009-08-30
84
This bug affects 14 people
Affects Status Importance Assigned to Milestone
partman-partitioning (Ubuntu)
High
Colin Watson
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: ubiquity

For beginners with Linux, the most commonly used installation of Ubuntu, is a dual boot with an existing Windows. When installing from the Live CD, the installer in Jaunty (and Karmic) then proposes a root partition size for Ubuntu, of only 2,5 GB. Even when there's plenty of space on a hard disk.

This is far too small. With only 2,5 GB available, you can't install updates or extra software. No space for that.

Of course it's easy to correct the proposed partition size by hand, using the slider that Ubiquity provides. But a Linux beginner won't know that, and will assume that the installer proposes an adequate partition size....

I suggest the following change to Ubiquity:
When the hard disk has enough space, ubiquity should propose a root partition size of 10 GB. In other words, 10 GB should be the default choice. This is a good workable minimum for most desktop users.

--edit:
I added that this happens when creating a dual boot with Windows.

--edit 2:
I added that this bug affects Karmic as well.

Pjotr12345 (computertip) on 2009-08-30
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Pjotr12345 (computertip) on 2009-08-30
description: updated
Pjotr12345 (computertip) on 2009-08-31
description: updated
tags: added: karmic
summary: - [Jaunty] the installer by default proposes a wrong size for the Ubuntu
- partition (far too small)
+ [Jaunty and Karmic] the installer by default proposes a wrong size for
+ the Ubuntu partition (far too small)
Pjotr12345 (computertip) wrote :

I already suggested a 10 GB default partition size for Ubuntu. Another option would be a *dynamic* partition size, using the same method that the Debian installer uses on the Alternate CD.

And there are still other possible options, of course. At this point I'm not so much interested in exactly which option will be chosen. As long as it produces a considerably larger default root partition size for Ubuntu, than the current 2,5 GB.

lizardmenke (lizardmenke) wrote :

I do agree with you there Pjotr12345.
The 2.5GB may be enough for installing Ubuntu, but as soon as there are updates (and there almost always are right after installing) a new user will immediately be confronted with an error! (not enough disk space)
Not something a first time user would want to see I imagine. ;)

Jaap Woldringh (jjh-woldringh) wrote :

I do agree with Pjotr12345,

In this age of large hard disks it is not advisable to have a /root partition size which is just "a bare minimum". Even on my netbook with only 8 GB I use a /root partition of 4 GB, and consider this a minimum. Want to install some extra thingies such as wxmaxima and so. Everyone wants to install some extras. And if just updating already does not succeed for sheer lack of space, then it's bye bye Ubuntu for new users that are trying out Ubuntu.
Pjotrs12345's suggestion of a dynamic partition size is a valid one, especially if that is already done in Debian, as he says. Please consider it ...

Topsiho

cayennep (mail-cayennep) wrote :

ok, this happened to me - what "slider" to repartion? help doesn't show me how to repartition and I don't know where this is. I'd rather use ubuntu's option than reboot and do it in xp.

I did trust that the auto option would work, where on my other machine where I did this I partitioned it myself. now I know, and yes would suggest it partition correctly as I can't do anything - updates, install eclipse, etc.

thx for tips on how to fix this

drs305 (drs305) wrote :

I have dealt with approximately 10 new users who have had failed installations because the default partition size is too small (2.3-2.5 GB).

As this is often the first experience with Ubuntu, this is a very important failure and should be addressed promptly.

Here are the threads on the Ubuntu forum I created to deal with this subject, and my own bug report which is still listed as New and Undecided despite being posted a month ago.

http://ubuntuforums.org/showthread.php?p=7658271
http://ubuntuforums.org/showthread.php?t=1219270

Bug report:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/404910

Pjotr12345 (computertip) wrote :

@drs305: I've confirmed your previous bug report. Also I've tagged it als a duplicate of this one. Not the other way round, because several other people have already responded in this thread. I hope you don't mind. :-)

@everyone: I've contacted the package maintainers of ubiquity. When they've responded, I'll let you know about it in this thread.

CeesSluis (testcees) wrote :

Right at first login after installing Ubuntu Karmic (alpha 4) without touching the "slider" (so in 2,5GB) there is a warning:

This computer has only 88,5 MB disk space remaining.
You can free up disk space by removing unused programs or files, or by moving files to an external disk.

Isn't it a little bit late to warn a new used he or she *must always* push the "slider" to the left...

Pjotr12345 (computertip) wrote :

It would be helpful if the package maintainers would react in this thread. The dialogue between bug reporters and package maintainers is what makes Launchpad so great. :-)

@cayennep: I suggest you try the manual that drs305 has written: http://ubuntuforums.org/showpost.php?p=7875248&postcount=3
Please seek further help on the ubuntuforum. Launchpad is meant only for bug reporting, not for mutual help... :-)

Colin Watson (cjwatson) on 2009-09-01
affects: ubiquity (Ubuntu) → partman-auto (Ubuntu)
Glennz nl (glenn-de-groot) wrote :

I guess this should be in the one-hundred papercuts for karmic koala :)

Pjotr12345 (computertip) wrote :

@Glennz nl: this bug is far worse than a mere papercut. This is a bug that can cause beginners with Linux, to drop Linux straight away and go back to Windows.

That's why it's urgent to fix it.

Almost any installation bug is that serious. That doesn't mean we don't
need to prioritise among them ...

Anyway, I'm not sure that it's necessary to increase the *minimum* size
(the 2.5GB mentioned), but the *default* for the resize slider is
supposed to be half-way in between the minimum and the maximum. I
thought Ubiquity already did that, but if it doesn't then I agree that
that needs to be fixed.

 importance high

Changed in partman-auto (Ubuntu):
importance: Undecided → High

This isn't in partman but in ubiquity itself, the bug is in the bar code
which figures out the size and then feeds it to partman to do the actual
resizing. I'll find my patch. I thought I attached it here but apparently
not.

--
-- Alex Launi

Colin Watson (cjwatson) wrote :

Ah, I'll send it back to ubiquity then ...

affects: partman-auto (Ubuntu) → ubiquity (Ubuntu)
Alex Launi (alexlauni) wrote :

Sorry that it's a git patch, we imported ubiquity into git for our changes- including this fix.

Pjotr12345 (computertip) wrote :

Sounds great. Can Alex's patch be included in the next alpha release (alpha 6) of Karmic? I would like to test it.

Pjotr12345 (computertip) wrote :

@ Colin Watson: will the next alpha contain a patch? Because I would like to test a patched ubiquity. Please let me know.

Alex Launi (alexlauni) wrote :

since ubiquity is python, you can patch it on the live cd. Just find the
source dir (I forget where it is), apply the patch, then run ubiquity.

--
-- Alex Launi

Pjotr12345 (computertip) wrote :

I'm sorry, Alex, that's above my head... I'll test it in an alpha build of Karmic, or even a daily build, but that's all I can do.

I would really appreciate a reaction from Colin Watson as well. Colin: when will this patch (or another with the same effect) be applied to ubiquity?

drs305 (drs305) wrote :

I'd just like to add a comment although I previously reported the bug. I'm on the Ubuntu Beginners Team and every day or two I am responding to new users who have fallen prey to the way the setup is configured.

I have two concerns. The first is that this is more often than not experienced by new users who are trying Linux and Ubuntu for the first time. To have to tell them they must reinstall or resize their Ubuntu/Windows partitions because the installer chose an inappropriate default is not a good introduction to a great system.

Secondly, the longer this problem takes to be resolved the more CDs are going to be out in circulation, causing problems for even more new users. This is especially true if the iso's for Jaunty are not updated; I am not as concerned for Karmic since I would expect more attention is being devoted to it and can't forsee it being released as is.

Pjotr12345 (computertip) wrote :

I tried the new alpha 6 of Karmic (desktop version) today. I was very disappointed to find, that this bug is still present in Ubiquity.

@ Colin Watson: when will this be fixed? Please reply... I find your silence in this thread, rather disconcerting.

Neil Wilson (neil-aldur) wrote :

Why not propose a fix. Ubiquity is python isn't it?

2009/9/18 Pjotr12345 <email address hidden>:
> I tried the new alpha 6 of Karmic (desktop version) today. I was very
> disappointed to find, that this bug is still present in Ubiquity.
>
> @ Colin Watson: when will this be fixed? Please reply... I find your
> silence in this thread, rather disconcerting.
>
> --
> [Jaunty and Karmic] the installer by default proposes a wrong size for the Ubuntu partition (far too small)
> https://bugs.launchpad.net/bugs/421407
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Neil Wilson

Alex Launi (alexlauni) wrote :

Neil, a working patch has already been posted. We're just waiting for it to
be reviewed/applied.

--
--Alex Launi

Malcolm (malcolm-loadbalancer) wrote :

It sounds like this is being dealt with, but just thought I'd add my own comment.
I've been using Linux for 10 years and hit this bug/feature on a system with a 750-GB HD (350GB used by Vista..)
Update Manager gave disk space error within 5mins of booting the system...
This would really upset a new user...I just re-installed using the full available space...
Ps. Jaunty is still awesome , keep it up.

Pjotr12345 (computertip) wrote :

@ Colin Watson: it's not encouraging that you don't reply here anymore... After all, a lot of people took the trouble to support and investigate this bug. Someone (Alex) even provided a fix...

*Please* tell us what will be done about this bug, and when we can expect a fix in a daily build of Karmic.

Please reply.

Evan (ev) wrote :

This is waiting on Alex signing the contributor agreement. I have been in touch with him on this, and he is working through the paperwork on his end. Please be patient.

drs305 (drs305) wrote :

Well, Karmic Beta is out and the problem apparently remains. I've dealt with half a dozen new users in the past week who had to reinstall because of this bug. This is very discouraging. It doesn't affect me personally but every time I read a forum post by a new user about this issue my spirit sinks.

Colin Watson (cjwatson) wrote :

Alex, thanks, but this isn't quite the right approach - partman-auto already calculates a correct preferred size, we just aren't using it. I have a different fix for this now.

Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Changed in partman-partitioning (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Pjotr12345: I find my occasional silence in this thread indicative of the fact that I have *far too much to do*. ;-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-partitioning - 72ubuntu2

---------------
partman-partitioning (72ubuntu2) karmic; urgency=low

  * Set prefsize in get_*resize_range functions; pass RAWPREFSIZE instead of
    RAWCURSIZE to ubiquity (preferred size instead of current size) and stop
    passing ORISIZE. This allows ubiquity to set sensible preferred sizes
    when resizing partitions (LP: #421407).

 -- Colin Watson <email address hidden> Tue, 06 Oct 2009 18:18:13 +0100

Changed in partman-partitioning (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

Incidentally, I'm sorry, but we aren't going to be able to release updated Jaunty CDs for this. Preparing and QAing point releases of stable releases is a *lot* of work, and I'm afraid we've decided only to do them for LTS releases.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.29

---------------
ubiquity (1.99.29) karmic; urgency=low

  [ Colin Watson ]
  * Use a separate PROGRESS REGION for each install plugin (LP: #438979).
  * GTK frontend:
    - When switching language, translate other top-level widgets (dialogs)
      and their children, as well as the main notebook pages (LP: #441622).
  * Install a dummy initctl similar to the dummy start-stop-daemon while
    doing anything that might install or remove packages in the target
    system, so that attempts to control Upstart jobs won't do anything.
  * Stop Upstart jobs when switching to runlevel 0 or 6, which I think fixes
    repeated respawns on shutdown (LP: #432140).
  * Save /var/log/installer/debug to the target system if it exists.
  * In the auto-resize bar, use the preferred partition size requested by
    partman-auto/partman-partitioning, rather than hardcoding the maximum
    size or making up our own (LP: #421407).
  * Update imported translations from gtk+2.0 2.18.1-1ubuntu1 (adds Asturian
    and Bengali).
  * Update translations from Launchpad.
  * Automatic update of included source packages: apt-setup 1:0.41ubuntu2,
    console-setup 1.34ubuntu4, flash-kernel 2.13ubuntu12, grub-installer
    1.43ubuntu5, partman-partitioning 72ubuntu2, partman-target 64ubuntu2.

  [ Evan Dandrea ]
  * Port fix for return_to_partitioning from the GTK+ frontend to the
    KDE frontend (LP: #439184).
  * Explicitly depend on reiserfsprogs so that we don't have to add it
    to every live seed (LP: #431976).
  * Write /cdrom/.disk/info to /var/log/installer/media-info
    (LP: #364649).

  [ Roman Shtylman ]
  * Limit width of side breadcumbs in kde for long translation text.
    Using elided text where needed (LP: #438918)

 -- Colin Watson <email address hidden> Tue, 06 Oct 2009 18:39:54 +0100

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Pjotr12345 (computertip) wrote :

@ Colin Watson: this sounds great! Thanks for fixing this nasty bug. :-)

Can I already test the fix in a daily build of Karmic?

Pjotr12345 (computertip) wrote :

Hurray, the problem is fixed in the daily build of Karmic, of today! See the attached screenshot.

Thanks everybody, for participating in troubleshooting and fixing this bug. You've all helped to make Ubuntu noticeably better, in an important area!

Greetz, Pjotr. :-)

Colin Watson (cjwatson) wrote :

Thanks for confirming the fix.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers