Installation in pt_BR shows Noronha as the default timezone

Bug #356794 reported by Adilson Oliveira on 2009-04-07
2
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Medium
Colin Watson
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

When Brazilian Portuguese is selected for instalation, the default timezone shown is Noronha (GMT-2). This is not really wrong as this is a valid timezone but very unusual. The usual one is São Paulo (GMT-3). This was the behaviour with Hardy so it's a regression.
How to reproduce the bug:
 - Select Brazilian Portuguese as the instalation language.
 - Follow the steps until the selection of timezone.
 - The default timezone shown is Noronha.
What should the correct behaviour:
 - Select Brazilian Portuguese as the instalation language.
 - Follow the steps until the selection of timezone.
 - The default timezone shown is São Paulo.

ProblemType: Bug
Architecture: amd64
Dependencies:

DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: ubiquity None [modified: /var/lib/dpkg/info/ubiquity.list]
ProcEnviron:
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
Uname: Linux 2.6.28-11-generic x86_64
UnreportableReason: Este não é um pacotes Ubuntu genuíno

Adilson Oliveira (agoliveira) wrote :

Maybe this is a bug on itself? "UnreportableReason: Este não é um pacotes Ubuntu genuíno". Translated: "UnreportableReason: This is not a genuine Ubuntu package"

Colin Watson (cjwatson) wrote :

This only happens in ubiquity, not in d-i.

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Colin Watson (cjwatson) wrote :

Introduced by me in r2959, I think.

Colin Watson (cjwatson) on 2009-04-09
tags: added: regression-potential
removed: amd64
Changed in oem-config (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: New → Triaged
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Changed in oem-config (Ubuntu):
status: Triaged → Fix Committed
summary: - Instalation in pt_BR shows Noronha as the default timezone
+ Installation in pt_BR shows Noronha as the default timezone
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oem-config - 1.54.12

---------------
oem-config (1.54.12) jaunty; urgency=low

  * Sync with console-setup 1.28ubuntu8: treat the Kazakhstan layout (kz) as
    non-Latin (LP: #356816).
  * Work around a debconf bug which broke the default time zone for some
    countries: REGISTER does not appear to give a newly-registered question
    the same default as the question associated with its template, unless we
    also RESET it, so do that (LP: #356794).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup 1.28ubuntu8,
    user-setup 1.23ubuntu18.

 -- Colin Watson <email address hidden> Thu, 09 Apr 2009 10:03:54 +0100

Changed in oem-config (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.12.6

---------------
ubiquity (1.12.6) jaunty; urgency=low

  [ Colin Watson ]
  * GTK frontend:
    - Copy-and-paste gdm-signal from powermanagement-interface, since that
      package is no longer in main and is slated to go away. In future we
      ought to be able to use gnome-session D-BUS calls or similar for this
      work (LP: #357101).
  * Use gksudo --preserve-env / sudo -E so that we can check DESKTOP_SESSION
    from the GTK frontend, and use other desktop environment variables in
    future.
  * Try a couple of different locations for NetworkManager's init script
    (LP: #356813).
  * Sync with console-setup 1.28ubuntu8: treat the Kazakhstan layout (kz) as
    non-Latin (LP: #356816).
  * Work around a debconf bug which broke the default time zone for some
    countries: REGISTER does not appear to give a newly-registered question
    the same default as the question associated with its template, unless we
    also RESET it, so do that (LP: #356794).
  * Update translations from Launchpad.
  * Automatic update of included source packages: base-installer
    1.98ubuntu6, console-setup 1.28ubuntu8, flash-kernel 2.13ubuntu6,
    partman-auto 84ubuntu3, partman-base 129ubuntu7, partman-target
    58ubuntu7, user-setup 1.23ubuntu18.

  [ Evan Dandrea ]
  * Provide translation support for the format warning on the automatic
    partitioning page, and make it less tied to English grammar. Thanks
    Timo Jyrinki (LP: #356333).
  * Only show the migration-assistant page if we have items we can
    import.
  * Don't let the time zone map image grow larger than the original.
  * Automatic update of included source packages: migration-assistant
    0.6.4.

 -- Evan Dandrea <email address hidden> Thu, 09 Apr 2009 14:46:10 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers