Ubuntu

[Jaunty] Scanning partitions is too slow

Reported by Diaa Sami on 2009-03-11
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

On Jaunty Alpha 5, The partition editor step takes too much time to show/load, I'm not sure how much time it took but definitely more than 5 minutes, I had 3 HDDs attached each with a total of 14 partitions or so.
The problem is that 5 minutes is too much to wait in-front of a non-responsing application, I had to leave the computer and do something else then came back later, I see this as a major disappointment for a new user.

Same goes for undoing changes inside the partition editor, it takes too much time to undo, probably re-scans the changed partitions only but still, takes a 2-3 minutes.

Tormod Volden (tormodvolden) wrote :

I can also confirm this on alpha 6 Desktop CD, it takes 153 seconds to scan initially (after selecting keyboard) and then another 80 seconds (after selecting manual partitioning).

The attached partman log has timestamps prepended.

Tormod Volden (tormodvolden) wrote :

Just want to note this for (my) future reference:
tail -f /var/log/partman | perl -pne '$|=1; print scalar(localtime()), " ";' > /var/tmp/partman-timestamped.log

Tormod Volden (tormodvolden) wrote :

The problem is also severed by the fact that there is no progress bar dialog on the initial (and longest scan) like there is on the second scan. There is only the spinning cursor.

Diaa Sami (diaa.sami) wrote :

The delays for me on Alpha 5 were
11 minutes loading the partition manager(moving from step 4 to step 5).
4 minutes after I chose advanced partitioning(manual)
another 4 minutes when pressing the "Undo changes to my partitions" button.

You can find the output of sfdisk -ls -uM attached, which shows my hdds and partitions.

Diaa Sami (diaa.sami) wrote :

I have just tried with a slightly different configuration of harddisks and the latest Jaunty beta and it's the same, The first scan was more than 10 minutes and the second one(after choosing advanced partitioning) was more than 3 minutes.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jarl (jarl-dk) wrote :

These bugs are potential duplicates: bug 89357, bug 164030, bug 282193, bug 341095, bug 288450, bug 480957

Jarl (jarl-dk) wrote :

This has improved a lot in Lucid.

Still I find it a bit slow. But not much slower than the rest of the installer-wizard. Which in general I find a bit slow. So to me I think this bug (regarding editing partitions only) is solved.

What does the rest of you think?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers