"Starting up the partitioner" uses separate window misleadingly

Bug #336751 reported by Matthew Paul Thomas on 2009-03-02
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Evan
Lucid
Low
Evan

Bug Description

Binary package hint: ubiquity

Ubuntu Jaunty alpha 5

1. At the "Keyboard layout" step, click "Forward".

What happens:
* Still on the "Keyboard layout" step, a progress window appears briefly saying "Starting up the partitioner", "Starting up the partitioner" again, and some other text too brief to read.
* The window flies away a couple of seconds later.
* A few seconds after that, the installer finally switches to the "Prepare disk space" step.

Showing progress in a separate window implies that the original window can be closed or used for something else at the same time, but in this case it can't.

What should happen:
* Progress of starting the partitioner and scanning the partitions should be displayed in the installer window. One obvious way of doing this would be centering the progress bar and text inside the otherwise-empty "Prepare disk space" step itself. (To be tasteful, the progress bar should take up only about half the width of the Ubiquity window.) When the scanning has finished, the progress bar and text could disappear and be replaced by the usual partitioning options.

Evan (ev) on 2009-03-02
Changed in ubiquity:
importance: Undecided → Low
status: New → Confirmed
Colin Watson (cjwatson) wrote :

The same progress bar is used at various other points while the partitioner is working, particularly in the advanced partitioning screen; there isn't so much empty space to use there, and I would prefer the progress indicator to have the same appearance in both cases. Perhaps this is a case where a status bar would be appropriate?

Matthew Paul Thomas (mpt) wrote :

A status bar would be quite inappropriate in an assistant-style window such as the installer. And I haven't been able to think of any other way to present a progress indicator so that it would be suitable both when launching the partitioner and when rereading the partition table. However, I think the increase in calmness and visual stability from embedding progress feedback for both those things into the main window outweighs any benefit from consistency in the current progress window looking the same.

So, I suggest that while waiting for the partitioner to launch, the spinner should be centered in the pane. And whenever rereading the partition table, the spinner should be placed immediately below the bottom right corner of the partition table, preceded by brief text something like "Recalculating partitions…". (I'm not sure what the exact text should be, because I don't know why the partitioner needs to reread the partition table so often instead of trusting its internally-remembered state.) The baseline of that text should line up exactly with the baseline of the buttons below the bottom left corner of the partition table.

Colin Watson (cjwatson) on 2010-01-13
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
Evan (ev) wrote :

I'm reassigning this to me as it's covered by the foundations-lucid-installer-design-improvements specification, and I already have a partial implementation that's just waiting on a patch to PyGTK to support GtkSpinner.

Changed in ubiquity (Ubuntu):
assignee: Colin Watson (cjwatson) → Evan Dandrea (ev)
Evan (ev) wrote :

Bug 414912 is related to this.

I would like to solve this by changing the text of the "Forward" button, once clicked, to "Starting Partitioner..." and spinning the mouse cursor.

Okay, as per Colin's suggestion, we will show the partitioner page, but put "Starting partitioner..." in its contents until it is ready.

Colin Watson (cjwatson) wrote :

I think we have a consensus on IRC.

On switching to the automatic partitioning page, we will disable the progress dialog and just use a spinning mouse cursor. This is not particularly slower than other page transitions now, so it doesn't make sense to treat it specially.

On switching to the advanced partitioning page, we can expect a longer delay; I have a test case which is complicated but not actually completely unreasonable, and takes on the order of 15 seconds. For this, we'll display the page furniture ASAP, and while we're trying to fill in the contents by scanning partitions, we will display a spinner and progress message to the bottom right of the partition list box, as we do currently when recalculating partitions after manual partitioner operations.

Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.30

---------------
ubiquity (2.1.30) lucid; urgency=low

  [ Mario Limonciello ]
  * Raise permissions for misc.execute calls in bin/ubiquity.
  * Don't allow oem-user-config and oem-config to both be enabled.

  [ Evan Dandrea ]
  * Move the alpha warning for the GTK+ frontend to the language page.
    It fits better there now that we have the greeter functionality.
  * Push handling the progress bar when on the partitioning page
    properly into ubi-partman.
  * Show the advanced partitioning page immediately, now that its
    progress is displayed in the window contents (LP: #336751).
 -- Mario Limonciello <email address hidden> Wed, 03 Mar 2010 19:40:15 -0600

Changed in ubiquity (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers