Main menu is still in English after installation from LiveCD

Bug #276657 reported by Ara Pulido on 2008-10-01
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Colin Watson
Intrepid
Critical
Colin Watson

Bug Description

Binary package hint: ubiquity

Using Intrepid Beta Desktop i386 (daily build 20080930.4)

I choose to start the Live session in Spanish. The gdm appears in Spanish correctly (Usuario), and the main menu also appears in Spanish.

I choose to install the system in Spanish as well. After reboot, the GDM screen appears in English (User) and the main menu appears in English as well, but its submenu appear correctly in Spanish (see screenshot).

Ara Pulido (ara) wrote :
Ara Pulido (ara) wrote :

ubiquity:
  Instalados: (ninguno)
  Candidato: 1.10.1
  Tabla de versión:
     1.10.1 0
        500 http://es.archive.ubuntu.com intrepid/main Packages

ara@intrepid-beta:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu intrepid (development branch)
Release: 8.10
Codename: intrepid

Colin Watson (cjwatson) wrote :

The screenshot you show just looks like a matter of incomplete translations which isn't anything we can do anything about in the installer, but GDM might be a different matter.

Chris Coulson (chrisccoulson) wrote :

Thanks.

Could you check and make sure that the language packs for Spanish are fully installed (System -> Administration -> Language Support, I think)

Ara Pulido (ara) wrote :

Yes, it is fully installed (see screenshot)

The thing is that the Applications/Places/System menus, and the GDM screen, appear in Spanish in the Live CD.
It is only when installed, that the menus are back to English.

Pedro Villavicencio (pedro) wrote :

Got the same results as Ara with my Spanish installation, as described during the Live CD everything appear in Spanish but when you boot the new installed system the Applications/etc, menus, GDM Options and User/Password text which is near to the text entry appear in English

Colin Watson (cjwatson) wrote :

Meep. Ubiquity has got confused and decided not to copy the language pack files, despite the fact that it ends up keeping that language pack installed!

Changed in ubiquity:
importance: Undecided → Critical
status: New → Triaged
milestone: none → ubuntu-8.10
Colin Watson (cjwatson) wrote :

I think this is beta-critical because there are rather a lot of files from installed packages that are missing, that won't all necessarily be uploaded again before final.

The obvious quick workaround is to back out the DVD performance improvements for beta, and fix them up afterwards.

Changed in ubiquity:
assignee: nobody → kamion
milestone: ubuntu-8.10 → ubuntu-8.10-beta
Henrik Nilsen Omma (henrik) wrote :

I've confirmed that a German install of Ubuntu does the right thing. Checking Spanish next to confirm.

Changed in ubiquity:
status: Triaged → Fix Released
Ara Pulido (ara) wrote :

Ubuntu Desktop i386 (20081001) is working fine in Spanish.

Xubuntu Desktop i386 (20081001) has a problem that I don't know if it is related or not. Steps to reproduce:

* Run Xubuntu Live CD in Spanish - > It is correctly translated.
* Log out -> GDM appears in Spanish but with a wrong layout (see xubuntu1.png)
* Install (I tried entire disk option) in Spanish
* When rebooting GDM appears in English. Only the word "Contraseña" ("Password"), and the date appears in Spanish (see xubuntu2.png)

Ara Pulido (ara) wrote :
Ara Pulido (ara) wrote :

Can anyone answer my last comment, please? Should that be a separate issue?

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers