partition editor in hardy installer does not launch

Bug #220476 reported by Slogger on 2008-04-22
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Hardy Heron release candidate installer partitioning broken.

may be a duplicate of https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/191577

Running the installer permanently hangs while trying to load the partitioning step of install.
However, the system>admin>Partition Editor item works correctly.
It is only the installer's partitioning that has a problem.

syslog output:
[code]
Apr 22 03:07:32 ubuntu localechooser: info: LANGNAME=English
Apr 22 03:07:32 ubuntu localechooser: info: line=English;0;en;US;en_US.UTF-8;UTF-8;;kbd=lat0-sun16(utf8)
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/language = 'en'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/fallbacklocale = 'en_US.UTF-8'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/country = 'US'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/consoledisplay = 'kbd=lat0-sun16(utf8)'
Apr 22 03:07:32 ubuntu localechooser: info: Set debconf/language = 'en'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/country = 'US'
Apr 22 03:07:32 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Apr 22 03:07:32 ubuntu ubiquity[3059]: debconffilter_done: Language (current: Language)
Apr 22 03:07:32 ubuntu ubiquity[3059]: Step_before = stepLanguage
Apr 22 03:07:33 ubuntu ubiquity[3059]: switched to page stepLocation
Apr 22 03:07:38 ubuntu ubiquity: Cannot unlink input FIFO: No such file or directory
Apr 22 03:07:38 ubuntu ubiquity: Cannot unlink output FIFO: No such file or directory
Apr 22 03:07:38 ubuntu ubiquity: Cannot unlink stop FIFO: No such file or directory
Apr 22 03:07:38 ubuntu ubiquity: /lib/partman/automatically_partition/10resize_use_free/choices: 204:
Apr 22 03:07:38 ubuntu ubiquity: cannot create /var/lib/partman/stopfifo: Directory nonexistent
Apr 22 03:07:38 ubuntu ubiquity:
Apr 22 03:07:38 ubuntu ubiquity: /lib/partman/display.d/10initial_auto: 134: cannot create /var/lib/partman/snoop: Dire
ctory nonexistent
Apr 22 03:07:39 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:40 ubuntu last message repeated 38 times
Apr 22 03:07:40 ubuntu localechooser: info: Locale has been preseeded to en_US.UTF-8
Apr 22 03:07:40 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:40 ubuntu last message repeated 2 times
Apr 22 03:07:40 ubuntu localechooser: info: Set languagechooser/language-name-fb = 'English'
Apr 22 03:07:40 ubuntu localechooser: info: Set countrychooser/shortlist-en = 'US'
Apr 22 03:07:40 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Apr 22 03:07:40 ubuntu localechooser: info: Set debconf/language = ''
Apr 22 03:07:40 ubuntu localechooser: info: Set countrychooser/country-name = 'United States'
Apr 22 03:07:40 ubuntu localechooser: info: Set debian-installer/country = 'US'
Apr 22 03:07:40 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:40 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Apr 22 03:07:40 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:40 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:40 ubuntu ubiquity[3059]: debconffilter_done: Timezone (current: Timezone)
Apr 22 03:07:40 ubuntu ubiquity[3059]: Step_before = stepLocation
Apr 22 03:07:40 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:41 ubuntu last message repeated 14 times
Apr 22 03:07:41 ubuntu ubiquity[3059]: log-output -t ubiquity setxkbmap -model pc105 -layout us
Apr 22 03:07:41 ubuntu ubiquity[3059]: switched to page stepKeyboardConf
Apr 22 03:07:41 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:44 ubuntu last message repeated 62 times
Apr 22 03:07:44 ubuntu ubiquity: Your console font configuration will be updated the next time your system
Apr 22 03:07:44 ubuntu ubiquity: boots. If you want to update it now, run 'setupcon' from a virtual console.
Apr 22 03:07:44 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:44 ubuntu last message repeated 2 times
Apr 22 03:07:44 ubuntu ubiquity[3059]: log-output -t ubiquity setxkbmap -model pc105 -layout us -option
Apr 22 03:07:44 ubuntu ubiquity[3059]: debconffilter_done: ConsoleSetup (current: ConsoleSetup)
Apr 22 03:07:44 ubuntu ubiquity[3059]: Step_before = stepKeyboardConf
Apr 22 03:07:44 ubuntu ubiquity: /lib/partman/display.d/80manual_partitioning: 9: cannot create /var/lib/partman/snoop:
 Directory nonexistent
Apr 22 03:07:44 ubuntu last message repeated 8 times
Apr 22 03:07:57 ubuntu kernel: [ 1212.696413] end_request: I/O error, dev fd0, sector 0
Apr 22 03:08:09 ubuntu kernel: [ 1224.870006] end_request: I/O error, dev fd0, sector 0
Apr 22 03:08:09 ubuntu kernel: [ 1224.949189] program parted_devices is using a deprecated SCSI ioctl, please convert i
t to SG_IO
Apr 22 03:08:09 ubuntu ubiquity[3059]: debconffilter_done: Partman (current: Partman)
Apr 22 03:08:09 ubuntu ubiquity[3059]: dbfilter_handle_status: ('Partman', 10)
Apr 22 03:14:52 ubuntu ubiquity[3059]: dbfilter_handle_status: response -7
Apr 22 03:14:52 ubuntu ubiquity: debconf: DbDriver "targetdb": could not open /target/var/cache/debconf/config.dat
Apr 22 03:14:52 ubuntu ubiquity[3059]: log-output -t ubiquity debconf-copydb configdb targetdb -p ^console-setup/ --con
fig=Name:targetdb --config=Driver:File --config=Filename:/target/var/cache/debconf/config.dat
Apr 22 03:14:52 ubuntu ubiquity: debconf: DbDriver "targetdb": could not open /target/var/cache/debconf/config.dat
Apr 22 03:14:52 ubuntu ubiquity[3059]: log-output -t ubiquity debconf-copydb configdb targetdb -p ^xserver-xorg/ --conf
ig=Name:targetdb --config=Driver:File --config=Filename:/target/var/cache/debconf/config.dat
Apr 22 03:17:01 ubuntu /USR/SBIN/CRON[11650]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
[/code]

Slogger (slogger) wrote :

Oh, and just for reference,
I have an ASUS M2N-MX SE Plus mobo
AMD X2 BE 2.1 ghz CPU.
1 gig ddr2 800
SATA DVD Burner
SATA 250 GB internal HD
External USB 250 GB HD
nVidia 8600 gt 256 mb

partitioning is as follows:

Internal HD:
/dev/sda5 ext3 (root)
/dev/sda7 ext3 (/home)
/dev/sda8 ext3 (/media/music)
/dev/sda6 ext3 (unused partition)
/dev/sda9 xfs (/media/vault_VII)

external HD:
/dev/sdf5 vfat (/media/VAULT_VI)
/dev/sdf1 jfs (/media/VAULT_III_plus)

I can't reproduce this, when going directly into installing ubuntu (ie, not the live system first)

Slogger (slogger) wrote :

I've just determined that this problem only occurs when I have the external USB 2.0 hard drive plugged in. If I turn off the external drive, it loads the partitioner no problem.

As previously noted, the external is partitioned accordingly:

external HD:
/dev/sdf5 vfat (/media/VAULT_VI)
/dev/sdf1 jfs (/media/VAULT_III_plus)

Monkey (monkey-libre) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test a current, supported, Ubuntu version. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 220476, and any other logs that are relevant for this particular issue.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Monkey (monkey-libre) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers