gparted doesn't start in hardy after today's update...

Bug #191577 reported by bonsiware on 2008-02-13
24
Affects Status Importance Assigned to Milestone
gparted (Debian)
Fix Released
Unknown
gparted (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gparted

I'm using hardy updated to now...

after today's upgrade of gparted from 0.3.3-6 to 0.3.5-1 the launcher in the System --> Administration has changed...

now it is "su-to-root -X -c /usr/bin/gparted", but I don't have su-to-root (it looks to be part of the "menu" package), and the launcher doesn't work!

if I change the command to "gksu /usr/bin/gparted" it works fine!

thanks!

Pedro Villavicencio (pedro) wrote :

confirming.

Changed in gparted:
importance: Undecided → High
status: New → Confirmed
Didier Eymet (didiereymet) wrote :

The same for me

Gaspard Leon (gaspard.leon) wrote :

Yep, confirmed.

What is su-to-root and why use it instead of gksu??

Is it better?

cheers,
Gaspard

Daniel Hahler (blueyed) wrote :

You are probably missing the "menu" package.
Please verify that after installing this package, the menu entry works again.
FYI: su-to-root is a wrapper around gksu or kdesudo etc..

Changed in gparted:
assignee: nobody → blueyed
status: Confirmed → In Progress
A Kao (ak-ubuntu) wrote :

This problem is also present on the Alpha 5 running live off the CD.

A Kao (ak-ubuntu) wrote :

Also, if su-to-root should be used for gparted, why is it not used consistently for other menu items? For example the Synaptic Package Manager and the Hardware Drivers both use gksu.

Daniel Hahler (blueyed) wrote :

I take it that installing "menu" fixed it for you and am attaching the patch to fix it.
There are some packages using "su-to-root" already, see "grep su-to-root /usr/share/menu/*".

Changed in gparted:
assignee: blueyed → nobody
status: In Progress → Triaged
Daniel Hahler (blueyed) wrote :
Bruce R (bm007a0030) wrote :

Just to confirm that Hardy Alpha-5 Partition Editor neither runs in LiveCD session or After Install re-insatatement via Application, Add Remove etc. Error message as attached image file.

Saivann Carignan (oxmosys) wrote :

Daniel Hahler : Are you sure that gparted should use su-to-root? Previous versions of gparted used gksu including the Gutsy version, unless there is a specific advantage to use su-to-root (I don't know about this part but I doubt that it's the case), I think that it would be a better idea to set back gksu since it will avoid unnecessary dependencies.

Daniel Hahler (blueyed) wrote :

I think the change to su-to-root is a good one, because it allows to use "kdesudo" on KDE.

Daniel Hahler (blueyed) wrote :

Well, I've just noticed that "menu" is in universe and as far as I know, packages in the main archive cannot depend on packages from "universe".
Therefore I've changed the debdiff to use gksu instead.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gparted - 0.3.5-1ubuntu1

---------------
gparted (0.3.5-1ubuntu1) hardy; urgency=low

  * 01_fix-desktop.patch: use gksu instead of su-to-root, because "menu" which
    provides su-to-root is in universe (LP: #191577)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Daniel Hahler <email address hidden> Sun, 24 Feb 2008 17:34:20 +0100

Changed in gparted:
status: Triaged → Fix Released
Changed in gparted:
status: Unknown → New
Splat (mikeh85) wrote :

Still occurs with a fresh install of gparted as of right now.

The change to a universal graphical su utility is a good idea, but then it needs to be present on all systems by default. Otherwise that defeats the purpose.

Daniel Hahler (blueyed) wrote :

Splat, I suppose you weren't using 0.3.5-1ubuntu1 at that time yet?

Yes, packages using su-to-root need to depend on "menu", that's just a bug, which I've forwarded to Debian. For Ubuntu this is no solution either, because "menu" is not in "main" (as said above).

Saivann Carignan (oxmosys) wrote :

Daniel Hahler : Thanks for this fast work. However I found that the desktop file still does not comply with desktop-file-validate and because of this, the icon is absent when the launcher is on the desktop. I describe this issue in bug 195990 and provided tested (and builded) debdiff that fixes this problem.

Dave Neary (dneary) wrote :

I also get this bug straight after dist-upgrading to Hardy.

Dave.

Saivann Carignan (oxmosys) wrote :

Dave Neary : This bug is actually fixed, I have Gparted that starts correctly in Hardy so the bug you have is probably a different one. Can you open a new bug report with more details about your particular bug? (terminal outputs, what gparted does, error messages you get). If Gparted crashes, can you also follow the procedure described here : https://wiki.ubuntu.com/DebuggingProgramCrash to provide a backtrace to developers? If you give us the link of your new bug, we'll be able to subscribe and work on this one too.

Changed in gparted:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.