Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu" due to python changes

Bug #1963697 reported by Leó Kolbeinsson
222
This bug affects 30 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
Critical
Brian Murray
Jammy
Fix Released
Critical
Brian Murray

Bug Description

Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu

Testing Kubuntu Jammy daily iso - 04-03-2022

Test results here :
http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/245126/testcases/1300/results

Tested 2 machines on barebone and one in VirtualBox both crash after starting the install -
returned to desktop and ran ubuntu-bug ubiquity and that crashed as well.

See attached screenshot
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu78
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.465
CurrentDesktop: KDE
DistroRelease: Ubuntu 22.04
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Kubuntu 22.04 LTS "Jammy Jellyfish" - Alpha amd64 (20220305)
Package: ubiquity 22.04.6
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 5.15.0-18.18-generic 5.15.12
Tags: jammy ubiquity-22.04.6 kubuntu
Uname: Linux 5.15.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

Related branches

Revision history for this message
Leó Kolbeinsson (leok) wrote :
description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1963697

tags: added: iso-testing
Revision history for this message
Erich Eickmeyer  (eeickmeyer) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1963697

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Revision history for this message
Leó Kolbeinsson (leok) wrote :

@eeickmeyer - Erich

Thanks - I am very familiar with apport - that crashes as well - will re-run tests again when next ISO is released.

Revision history for this message
Thomas Ward (teward) wrote (last edit ):

I offered to test and assist too, this is the Python TraceBack from the crash I currently see/get:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 668, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 652, in main
    install(args[0], query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 268, in install
    wizard = ui.Wizard(distro)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 246, in __init__
    mod.ui = mod.ui_class(mod.controller)
  File "/usr/lib/ubiquity/plugins/ubi-wireless.py", line 214, in __init__
    self._setup_page()
  File "/usr/lib/ubiquity/plugins/ubi-wireless.py", line 220, in _setup_page
    self.nmwidget = nmwidgets.NetworkManagerWidget()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/nmwidgets.py", line 367, in __init__
    self.view = NetworkManagerTreeView(self._on_state_changed)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/nmwidgets.py", line 224, in __init__
    model = QtNetworkStore(self)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/nmwidgets.py", line 110, in __init__
    self._init_icons()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/nmwidgets.py", line 208, in _init_icons
    secure_pix = secure_icon.pixmap(ICON_SIZE / 2, ICON_SIZE / 2)
TypeError: arguments did not match any overloaded call:
  pixmap(self, QSize, mode: QIcon.Mode = QIcon.Normal, state: QIcon.State = QIcon.Off): argument 1 has unexpected type 'float'
  pixmap(self, int, int, mode: QIcon.Mode = QIcon.Normal, state: QIcon.State = QIcon.Off): argument 1 has unexpected type 'float'
  pixmap(self, int, mode: QIcon.Mode = QIcon.Normal, state: QIcon.State = QIcon.Off): argument 1 has unexpected type 'float'
  pixmap(self, QWindow, QSize, mode: QIcon.Mode = QIcon.Normal, state: QIcon.State = QIcon.Off): argument 1 has unexpected type 'float'

Looks like a TypeError somewhere.

Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
tags: added: apport-collected jammy kubuntu ubiquity-22.04.6
Revision history for this message
Thomas Ward (teward) wrote : apport information

ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu78
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.465
CurrentDesktop: KDE
DistroRelease: Ubuntu 22.04
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Kubuntu 22.04 LTS "Jammy Jellyfish" - Alpha amd64 (20220304)
Package: ubiquity 22.04.6
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 5.15.0-18.18-generic 5.15.12
Tags: jammy ubiquity-22.04.6 kubuntu
Uname: Linux 5.15.0-18-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

Revision history for this message
Thomas Ward (teward) wrote : Casper.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : Dependencies.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : ProcEnviron.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : UbiquityDebug.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : UbiquityDm.txt

apport information

Revision history for this message
Thomas Ward (teward) wrote : UbiquitySyslog.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : Casper.txt

apport information

description: updated
Revision history for this message
Leó Kolbeinsson (leok) wrote : Dependencies.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : ProcEnviron.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquityDebug.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquityDm.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquitySyslog.txt

apport information

Rik Mills (rikmills)
Changed in ubiquity (Ubuntu Jammy):
importance: Undecided → Critical
Revision history for this message
Rik Mills (rikmills) wrote : Re: Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu"

Possibly due to this change in python 3.10?

https://bugs.python.org/issue37999

Revision history for this message
Mark Ginter (markginter31) wrote :

A temporary fix is to remove the ubiquity kubuntu frontend and install the gtk frontend instead.

Changed in ubiquity (Ubuntu Jammy):
milestone: none → ubuntu-22.04-beta
Revision history for this message
Rik Mills (rikmills) wrote :

A bit of experimentation with a fix making sure values are returned as the expected integer type, show that there are at LEAST 2 other places in the code that then cause a crash for the same reason.

Revision history for this message
Bill (franksmcb) (franksmcb) wrote :

Latest re-spin still crashes. Running ubuntu-bug as directed results in a crash and traceback.

Revision history for this message
Brian Murray (brian-murray) wrote :

The apport crash is being tracked in bug 1964405.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing Kubuntu Jammy daily iso - 22-03-2022

http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/245948/testcases/1300/results

The installer still crashes.

Revision history for this message
Rik Mills (rikmills) wrote : Re: [Bug 1963697] Re: Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu"

On 22/03/2022 09:12, Leó Kolbeinsson wrote:
> Testing Kubuntu Jammy daily iso - 22-03-2022
>
> http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/245948/testcases/1300/results
>
> The installer still crashes.

Until a fixed version is uploaded, that is not going to change.

Revision history for this message
Brian Murray (brian-murray) wrote : Re: Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu"

I'll look at integrating the change in the linked pull request this week.

Changed in ubiquity (Ubuntu Jammy):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 22.04.8

---------------
ubiquity (22.04.8) jammy; urgency=medium

  * In partman-auto bump the minimum and maximum sizes for /boot partitions on
    default, x86, and EFI platforms to a minium of 1024Mb and a maximum of
    1848Mb. (LP: #1959971)
  * After copying log files to /var/log/installer set the permissions to 0o640
    and change the group owner to adm.
  * Resolve a crash in the KDE frontend when trying to install Kubuntu which
    was caused by changes to division. Thanks to LP user Cyril for the patch.
    (LP: #1963697)

 -- Brian Murray <email address hidden> Tue, 22 Mar 2022 10:35:07 -0700

Changed in ubiquity (Ubuntu Jammy):
status: In Progress → Fix Released
Revision history for this message
paulneelands (paulnee) wrote :

Installer still crashes with version 2022-03-26 05:41

Revision history for this message
ajgreeny (ajg-charlbury) wrote (last edit ):

Just used zsync to download the iso from the daily/current today, 2022-03-25 07:57 and tried to install in KVM/QEMU as a virtual system.

The live OS runs perfectly, or appears to do so and Ubiquity starts and seems to be installing the OS.

However, the progress marker gets to 33% and the process stalls completely and does not finish installing however long I have left it running.

Revision history for this message
paulneelands (paulnee) wrote :

Yes 33% that is where it stopped for me

Revision history for this message
Thomas Ward (teward) wrote :

Everyone posting 'installation failure' cases, please open separate bugs. The underlying issue that *this* bug was referring to is fixed, and the new failures are due to other problems, so please open different bugs.

summary: - Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu"
+ Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu" due to
+ python changes
Revision history for this message
Brian Murray (brian-murray) wrote :

The 33% crash is tracked in bug https://launchpad.net/bugs/1966204 which was also recently fixed.

Revision history for this message
Thomas Kotzian (thomask321) wrote : Re: [Bug 1963697] Re: Ubiquity crashes Kubuntu Jammy after selecting "install Kubuntu" due to python changes

I can confirm both bugs (installer crash and stop at 33%) have been
fixed. The whole installation ran without any problems.

Am Montag, dem 28.03.2022 um 18:51 +0000 schrieb Brian Murray:
> The 33% crash is tracked in bug https://launchpad.net/bugs/1966204
> which
> was also recently fixed.
>

To post a comment you must log in.