xubuntu bionic daily; error restoring applications ; on a formatted partition?

Bug #1891275 reported by Chris Guiver
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Xubuntu 18.04.5 daily QA-test install on
dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

I removed the sda5 (second) partition, then used the free space to create new partition; installer indicated it'll be sda2 now..

Error appearing during installation

--
Error restoring installed applications
An error occurred while restoring previously-installed applications.
The installation will continue, but you may have to manually reinstall
some applications after the computer reboots.
--

This would fit maybe if I hadn't formatted the partition. I deleted and then re-created the partition that it was installing to, so this issue shouldn't exist I believe.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14.15
ProcVersionSignature: Ubuntu 5.4.0-42.46~18.04.1-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.16
Architecture: amd64
CasperVersion: 1.394.3
Date: Wed Aug 12 17:32:07 2020
InstallCmdLine: file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd quiet splash --- maybe-ubiquity
LiveMediaBuild: Xubuntu 18.04.5 LTS "Bionic Beaver" - Release amd64 (20200806.1)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chris Guiver (guiverc) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1891275

tags: added: iso-testing
Revision history for this message
Chris Guiver (guiverc) wrote :

The install worked perfectly except for this issue, so it's a minor issue.

Revision history for this message
Chris Guiver (guiverc) wrote :

Kubuntu 18.04.5 QA-test install on
hp dx6120mt (mini-tower, pentium 4, 3gb, winfast clone of nvidia 7600gt)

-- following is from iso.qa.ubuntu.com notes (edited)

error has appeared (looks like https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1891275)
--
Error restoring installed application.
An error occurred while restoring previously-installed applications. The installation will continue, but you may have to manually reinstall some applications after the computer reboot.
--
I erased & re-created the single partition on this system, so didn't expect this error. I don't expect any restoration of packages to occur, but even if it did - my install was from the same image with no packages added (unless downloaded & installed during install itself, which could have been done again).

The installer then exited??? no reboot message at all??? !!!
--

I later worked out entering LIVE mode occurs b/c of error.

In the Kubuntu installer, if you delete partition, then create the same EXT4 partition using the same space, it'll default to NO-FORMAT and thus re-use the prior partition. This is why the message occurred.

However the packages present were only ones using a Kubuntu install process as per testcase, nothing extra, so this error I don't believe should occur. Even if installer download & installed extra packages, why can't it download & install them again this time, I've not done any no-internet QA-installs last two days.

tags: added: restore-new-distro
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers