lubuntu install (bionic daily) halts

Bug #1890872 reported by Chris Guiver
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Lubuntu 18.04 bionic daily QA-test install on

hp dx6120mt (mini-tower, pentium 4 dual core, 3gb, winfast clone of nvidia 7600gt)
sda only enabled in bios, contains a entire.disk qa-test install

Install continued till I got to "Where are you?" and map screen (it's rightly showing Melbourne, AU" but an error message appeared on screen

"Failed to create a file system.
The ext4 file system created in partition #5 of SCSI5 (0,0,0) (sdb) failed
OK"

I have hit OK (and ENTER) many times but it doesn't resume installation.

SDB is the thumb-drive? it looks like to me.

** Not the first time this happened

This has happened before, but I only noted in comments on iso.qa.ubuntu.com (occurred last time I did this install). Last time I didn't file as I was worried SDB meant my hdd (sdb) which I know has badblocks; SDB is the thumb-drive though (my 2nd & 3rd HDDs are disabled in BIOS)

It's also not moving past the error this time. I hit OK and nothing changes (either it repeats message instantly, or more likely it's not responding other than visual click.

Install looks stuck ... I switched to terminal & exploration has been there (ubuntu-bug filed from term). Ctrl+Alt+T won't work so everything has been via text terminal, and I can't open firefox etc (this written on my primary box)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14.15
ProcVersionSignature: Ubuntu 5.4.0-42.46~18.04.1-generic 5.4.44
Uname: Linux 5.4.0-42-generic i686
ApportVersion: 2.20.9-0ubuntu7.16
Architecture: i386
CasperVersion: 1.394.3
Date: Sat Aug 8 07:41:31 2020
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd quiet splash ---
LiveMediaBuild: Lubuntu 18.04.5 LTS "Bionic Beaver" - Release i386 (20200806.1)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chris Guiver (guiverc) wrote :
Revision history for this message
Chris Guiver (guiverc) wrote :
Revision history for this message
Chris Guiver (guiverc) wrote :

Since sdb5 i'm convinced is thumb-drive or install media, it was created with

`dus` (or mkusb)

This was the second install from thumb-drive since written, first was entire-disk install, second being install-alongside. Same order as was done last time... (last time was I think day web site issue was discovered by sil2100/Lukasz; though message only appeared during install alongside if I recall correctly; NOT the initial entire disk & NOT later manual.partitioning to confirm sil2100's fix)

---
guiverc@d960-ubu2:/de2900/lubuntu_32$ dus bionic-desktop-i386.iso
 dus 12.3.2
[sudo] password for guiverc:
Sorry, try again.
[sudo] password for guiverc:
live system or temporary superuser permissions
Drive that contains source file: /dev/sda
Live drive, that is booted from: /dev/sda
cands=1
sdb
SanDisk_Cruzer_Facet
 7.5G
usb
USB or memory card
p_target: target=/dev/sdb
live system or temporary superuser permissions
 Clone/extract system from the source
'bionic-desktop-i386.iso'
to the target device (drive) '/dev/sdb'
MODEL NAME FSTYPE LABEL SIZE
Cruzer_Facet sdb iso9660 Lubuntu 18.04.5 LTS i386 7.5G
             ├─sdb1 iso9660 Lubuntu 18.04.5 LTS i386 1.1G
             ├─sdb2 1K
             └─sdb5 6.3G
bionic-desktop-i386.iso
/dev/sdb
-----
live system or temporary superuser permissions
source=bionic-desktop-i386.iso
target=/dev/sdb
source=bionic-desktop-i386.iso
ls -l bionic-desktop-i386.iso
-rw------- 1 guiverc guiverc 1193803776 Aug 6 22:09 bionic-desktop-i386.iso
Making a USB boot drive or memory card ..........................
The iso file SHOULD BE loop mounted on a temporary file READ-ONLY:
mount: /tmp/dus.xBr2orgMXe: WARNING: device write-protected, mounted read-only.
gpt_zap: done

Installing 'bionic-desktop-i386.iso' to '/dev/sdb' ... :

< "bionic-desktop-i386.iso" pv -s 1193803776 | dd bs=4096 of=/dev/sdb
 Please wait for sync until 'Done' is written
 (flushing file system buffers to the device)
1.11GiB 0:04:02 [4.70MiB/s] [============================================================================================>] 100%
291456+0 records in
291456+0 records out
1193803776 bytes (1.2 GB, 1.1 GiB) copied, 279.966 s, 4.3 MB/s
Syncing the device ...
 Done :-)
p_clean:
live system or temporary superuser permissions
clean if necessary and return
guiverc@d960-ubu2:/de2900/lubuntu_32$

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1890872

tags: added: iso-testing
Chris Guiver (guiverc)
summary: - lubuntu install-alongside install (bionic daily) fails & won't continue
+ lubuntu install (bionic daily) halts
Revision history for this message
Chris Guiver (guiverc) wrote :
Download full text (3.5 KiB)

I just had a repeat of this issue,
- identical box
- no 'OK' box, the window is just sitting there
- title isn't even visible in window & install questions haven't started...
- no crash files in /var/crash

I'm suspicious this issue isn't with ubiquity itself (assuming today is the same issue again), but the box itself.
In `dmesg` I see the following

[ 484.289578] EIP: 0xb7f9fbb5
[ 484.289581] Code: Bad RIP value.
[ 484.289583] EAX: ffffffda EBX: ffffff9c ECX: 00610670 EDX: 00008000
[ 484.289585] ESI: 00000000 EDI: b7a20000 EBP: 00000000 ESP: bff5efa0
[ 484.289587] DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 007b EFLAGS: 00000293
[ 484.289620] INFO: task blkid:2066 blocked for more than 362 seconds.
[ 484.289623] Not tainted 5.4.0-42-generic #46~18.04.1-Ubuntu
[ 484.289626] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 484.289628] blkid D 0 2066 2064 0x00000000
[ 484.289631] Call Trace:
[ 484.289636] __schedule+0x292/0x800
[ 484.289640] schedule+0x2e/0xa0
[ 484.289643] schedule_preempt_disabled+0xd/0x10
[ 484.289646] __mutex_lock.isra.9+0x207/0x490
[ 484.289650] __mutex_lock_slowpath+0x12/0x20
[ 484.289653] mutex_lock+0x2f/0x40
[ 484.289655] __blkdev_get+0x70/0x4d0
[ 484.289658] blkdev_get+0xcd/0x110
[ 484.289661] ? bd_acquire+0x85/0xc0
[ 484.289663] blkdev_open+0x7d/0x90
[ 484.289666] do_dentry_open+0x1ca/0x3b0
[ 484.289668] ? blkdev_get_by_dev+0x40/0x40
[ 484.289671] vfs_open+0x25/0x30
[ 484.289674] path_openat+0x29c/0x1290
[ 484.289679] ? ring_buffer_lock_reserve+0x112/0x380
[ 484.289682] do_filp_open+0x6a/0xd0
[ 484.289686] ? __alloc_fd+0x36/0x170
[ 484.289690] do_sys_open+0x1ad/0x2c0
[ 484.289693] sys_openat+0x1b/0x20
[ 484.289696] do_fast_syscall_32+0x7f/0x240
[ 484.289699] entry_SYSENTER_32+0xaf/0x102
[ 484.289701] EIP: 0xb7f99bb5
[ 484.289704] Code: Bad RIP value.
[ 484.289706] EAX: ffffffda EBX: ffffff9c ECX: 0109b490 EDX: 00088000
[ 484.289708] ESI: 00000000 EDI: df30ac11 EBP: 0109ed50 ESP: bfb6db80
[ 484.289710] DS: 007b ES: 007b FS: 0000 GS: 0033 SS: 007b EFLAGS: 00000246
[ 605.122403] INFO: task systemd-udevd:1069 blocked for more than 483 seconds.
[ 605.122412] Not tainted 5.4.0-42-generic #46~18.04.1-Ubuntu
[ 605.122415] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ 605.122418] systemd-udevd D 0 1069 1057 0x00000104
[ 605.122423] Call Trace:
[ 605.122436] __schedule+0x292/0x800
[ 605.122443] ? hrtimer_interrupt+0x12f/0x280
[ 605.122448] schedule+0x2e/0xa0
[ 605.122451] schedule_preempt_disabled+0xd/0x10
[ 605.122455] __mutex_lock.isra.9+0x207/0x490
[ 605.122461] __mutex_lock_slowpath+0x12/0x20
[ 605.122463] mutex_lock+0x2f/0x40
[ 605.122467] __blkdev_get+0x70/0x4d0
[ 605.122470] blkdev_get+0xcd/0x110
[ 605.122473] ? bd_acquire+0x85/0xc0
[ 605.122475] blkdev_open+0x7d/0x90
[ 605.122478] do_dentry_open+0x1ca/0x3b0
[ 605.122481] ? blkdev_get_by_dev+0x40/0x40
[ 605.122483] vfs_open+0x25/0x30
[ 605.122487] path_openat+0x29c/0x1290
[ 605.122492] do_filp_open+0x6a/0xd0
[ 605.122496] ? __alloc_fd+0x36/0x170
[ 605.122500] do_sys_open+0x1ad/0x2c0
[...

Read more...

Revision history for this message
Chris Guiver (guiverc) wrote :

Earlier in `dmesg` is

[ 95.788362] blk_update_request: I/O error, dev sr0, sector 0 op 0x0:(READ) flags 0x80700 phys_seg 1 prio class 0
[ 95.820311] sr 0:0:0:0: [sr0] tag#0 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 95.820317] sr 0:0:0:0: [sr0] tag#0 Sense Key : Illegal Request [current]
[ 95.820321] sr 0:0:0:0: [sr0] tag#0 Add. Sense: Logical block address out of range
[ 95.820326] sr 0:0:0:0: [sr0] tag#0 CDB: Read(10) 28 00 00 00 00 00 00 00 01 00
[ 95.820330] blk_update_request: I/O error, dev sr0, sector 0 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 0
[ 95.820338] Buffer I/O error on dev sr0, logical block 0, async page read

which I think relates to the SDB message mentioned...
No squashfs errors found in `dmesg` & validation (check disc for defects) step was manually performed.

Revision history for this message
Chris Guiver (guiverc) wrote :

This has now occurred (same box as initial report) using the Xubunu 18.04.5 install

hp dx6120mt (mini-tower, pentium 4 dual core, 3gb, winfast clone of nvidia 7600gt)

an error has appeared
--
Failed to create a file system
The ext4 file system creation in partition #5 of SCSI5 (0,0,0) (sdb) failed.

On Lubuntu installs, SDB was the installation media, sda being the hdd. I noted this error on Lubuntu 18.04.5 installs though too (it's mentioned in https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1890872 but the bug was reported about what I considered another issue; will this install now lock up which is what I filed that bug about.....)

it's just stopped still.. ctrl+alt+T opened a terminal and I see the same messages I reported in https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1890872 so it's likely that issue, be it related to this box (identical box to other report) OR something in code this old cpu don't like...

The slideshow hasn't moved in 50 minutes, and no messages have appeared. I `ubuntu-bug ubiquity` and selected this bug again.. in hopes more detail would be added (I considered new bug & marking duplicate).. but I'm getting tired.

Revision history for this message
Chris Guiver (guiverc) wrote :

Xubuntu install-alongside on dx6120 `dmesg`

Revision history for this message
Chris Guiver (guiverc) wrote :

Xubuntu install-alongisde on dx6120 `journalctl`

Revision history for this message
Chris Guiver (guiverc) wrote :

on Xubuntu install, SDA refers to hdd, SDB (and error) refers to install media
--
Failed to create a file system
The ext4 file system creation in partition #5 of SCSI5 (0,0,0) (sdb) failed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers