[kubuntu] "Release notes" link doesn't open

Bug #1890173 reported by Jean-Baptiste Lallement on 2020-08-03
22
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Jean-Baptiste Lallement

Bug Description

On Kubuntu (20200731), the release notes link doesn't open on click.

xdg-open uses the following call: kde-open${KDE_SESSION_VERSION} "$1"
but KDE_SESSION_VERSION is not set when xgd-open is executed and it executes kde-open (which doesn't exist) instead of kde-open5.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubiquity 20.04.15.2
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.445.1
CurrentDesktop: KDE
Date: Mon Aug 3 16:41:55 2020
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed maybe-ubiquity initrd=/casper/initrd quiet splash --- keyboard-configuration/layoutcode=fr keyboard-configuration/variantcode=oss
LiveMediaBuild: Kubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1890173

tags: added: iso-testing
Marco Parillo (marco-parillo) wrote :

This sounds like the root cause of my bug: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1681144

Jean-Baptiste Lallement (jibel) wrote :

@Marco, it's likely the same root cause.

You can check if in /var/log/installer/debug there is an error similar to :
/usr/bin/xdg-open: 604: kde-open: not found

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Chris Guiver (guiverc) wrote :

Just an FYI: My last test with Kubuntu 20.04.1 was with 31-July-2020 ISO and the link didn't work, and was noted in comments on iso.qa.ubuntu.com. I made comment on IRC too asking if bug was wanted but didn't get reply.

Jean-Baptiste Lallement (jibel) wrote :

Actually the KDE_SESSION_VERSION is set to 4 instead of 5 in kde_ui.py. I'll submit a fix.

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
assignee: nobody → Jean-Baptiste Lallement (jibel)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.10

---------------
ubiquity (20.10.10) groovy; urgency=medium

  [ Didier Roche ]
  [ Jean-Baptiste Lallement ]
  * AD integration for GTK UI.
  * bump KDE_SESSION_VERSION to 5 to fix xdg-open on Kubuntu (LP: #1890173)

  [ Brian Murray ]
  * Do not try to keep installed software when reinstalling Ubuntu as the
    process was error prone (LP: 1152399) and did not provide a quailty
    experience. (LP: #1798369)

 -- Jean-Baptiste Lallement <email address hidden> Tue, 15 Sep 2020 17:06:15 +0200

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers