Clicking on URLs in Kubuntu Installer Slideshow does nothing

Bug #1681144 reported by Marco Parillo on 2017-04-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

When I hover over the blue, underlined links, my cursor changes to a finger, but nothing happens.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1681144

tags: added: iso-testing
affects: ubiquity (Ubuntu) → ubiquity-slideshow-ubuntu (Ubuntu)
tags: added: zesty
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → Medium
tags: added: kubuntu

ubiquity-slideshow-ubuntu (124) zesty; urgency=medium

  [ Aaron Honeycutt ]
  * Kubuntu slideshow fixes: (LP: #1681146)
    - KDE SC to KDE Applications
    - changed contribute link to d.k.org
    - Muon Discover renamed to Discover

  [ Mathieu Trudel-Lapierre ]
  * More slideshow grammar / translation fixes for Kubuntu.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Released

Wait, wrong bug. This is still an issue and needs a fix in ubiquity directly to start up a browser when slideshow links are clicked.

affects: ubiquity-slideshow-ubuntu (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: Fix Released → Triaged
Marco Parillo (marco-parillo) wrote :

This bug also applies to Lubuntu Next (LXQt).
Clicking the link to visit our website on both the:
 - Need Help; and
 - Thank you for Choosing Lubuntu Slides
does nothing.

As far as I can tell all the code is there to start a browser when a link is clicked. In this case, I think the issues come from bad config somewhere in the installer environment for QT: XDG or something else is missing to associate clicking a link with the application that should open it.

Just encountered this bug in my test of Kubuntu i386.

Hardware: https://gist.github.com/d47ddbbf07ce1dd74954efe847bd93ce

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers