ubiquity crashed with reuse home and existing encrypted home - 'PageGtk' object has no attribute 'error_dialog'

Bug #1767799 reported by Daniel Rocher on 2018-04-29
36
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

ubiquity crased - Impossible to install ubuntu 18.04. /var/log/installer/debug :

Gtk-Message: 11:32:11.409: GtkDialog mapped without a transient parent. This is discouraged.
Le schéma « com.canonical.indicator.session » n’existe pas
Le schéma « com.canonical.indicator.session » n’existe pas
Le schéma « com.canonical.indicator.session » n’existe pas
Le schéma « com.canonical.indicator.session » n’existe pas
/usr/lib/ubiquity/plugins/ubi-timezone.py:98: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, GObject, GLib, Soup
Ecryptfs is deprecated
Ecryptfs is deprecated
Exception caught in process_line:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 145, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 302, in process_line
    if not widget.error(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-usersetup.py", line 816, in error
    self.ui.error_dialog(
AttributeError: 'PageGtk' object has no attribute 'error_dialog'

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you describe when you hit the issue and after doing what steps/selecting what options?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Daniel Rocher (daniel-rocher) wrote :

in the "who are you?" window, I enter the username, hostname and password. I click on next. The bug occurs at this time. Perhaps because I user ecryptfs ?

mount | grep ecryptfs
/home/username/.Private on /home/username/Private type ecryptfs ...

I tested 3 times and each time I had this bug.

However, the packages are installed. But I had to configure the usernames, hostname and grub manually (I use boot secure on UEFI).

XUbuntu 18.04 is now installed on my laptop.

Changed in ubiquity (Ubuntu):
status: Incomplete → New
Jean-Baptiste Lallement (jibel) wrote :

Thanks but there is not enough information to understand the problem.

Could you please describe the setup of the system before you installed 18.04. You say you use encrypted home but this option has been removed from Ubuntu, is it from an existing installation? Could you please also describe the options you choose for the partitioning.

Finally, you mention Ubuntu in the description and Xubuntu in your last comment, which flavor failed to install?

Ideally attach the logs from /var/log/installer and /var/log/syslog from a failed attempt if you still have them.

Thanks.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Daniel Rocher (daniel-rocher) wrote :

My old installation was a Xubuntu 16.04, with this partitioning :
lsblk --fs
NAME FSTYPE LABEL UUID MOUNTPOINT
sda
├─sda1 ntfs WINRE_DRV
│ 1864A97E64A95EEE
├─sda2 vfat SYSTEM_DRV
│ 24A9-EDFC /boot/efi
├─sda3 vfat LRS_ESP 465D-CC63
├─sda4
├─sda5 ntfs Windows8_OS
│ 7C2EAC202EABD206
├─sda6 ntfs LENOVO 820E87130E870001
├─sda7 ntfs PBR_DRV 843064043063FC14
├─sda8 ext4 b94e6bfe-76fe-4012-b152-da47020b7d2f /
├─sda9 swap 390eb494-8f34-404c-9cfd-85c95f74d69b [SWAP]
└─sda10 ext4 498ef751-86c1-4707-a5eb-fe6ff3ea63d5 /home

 - I downloaded xubuntu-18.04-desktop-amd64.iso, because I like XFCE.
 - Create a bootable USB key with Rufus and this ISO
 - Disabled boot secure on UEFI
 - boot on USB key
 - "Try Xubuntu"
 - I configure network (wireless)
 - run "Install Xubuntu 18.04 TLS"
 - Select language (french), "Continue"
 - Select keyboard layout (french), "Continue"
 - enabled "Download updates while installing Xubuntu" and "Install third party sofware...", "Continue"
 - On"Installation type", I choose "something else" (create or resize yourself), "Continue"
 - I partitioned like this :

sda2 fat32 /boot/efi
sda8 ext4 F /
sda9 swap
sda10 ext4 /home

just sda8 and sda9 are formatted

 - "Install now"
 - Where are you ?", select Paris, "continue"
 - and finally, "who are you ?"

It was every time in this window that I noticed the bug (after submitting)

Perhaps close this ticket, if I am the only victim of this bug ?

Changed in ubiquity (Ubuntu):
status: Incomplete → New
Jean-Baptiste Lallement (jibel) wrote :

Thanks for following up. I cannot reproduce this bug with your instructions but hit several other issues. I keep this report open. Let see if there are other users affected.

Changed in ubiquity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

From the logs of bug #1761377

Apr 13 04:06:25 ubuntu ubiquity: ecryptfs-setup-swap failed.
Apr 13 04:06:25 ubuntu ubiquity[5758]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
Apr 13 04:06:25 ubuntu ubiquity[5758]: dbfilter_handle_status: ('ubi-usersetup', 141)

Changed in ubiquity (Ubuntu):
importance: Low → High
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
tags: added: rls-bb-incoming
summary: - ubiquity crashed - 'PageGtk' object has no attribute 'error_dialog'
+ ubiquity crashed with reuse home and existing encrypted home - 'PageGtk'
+ object has no attribute 'error_dialog'
Alan Gifford (siliconbadger) wrote :

I had Kubuntu 16.04 previously, and encountered a problem doing fresh install of Xubuntu 18.04. Used USB boot drive created from ISO image; chose to install Xubuntu; chose to manually configure; set existing partitions as previously configured, choosing to format / and /boot. All partitions are XFS except /boot and /boot/efi which are ext2 and vfat, respectively.

I was stuck at the "who are you" setup screen repeatedly getting the "ubi-usersetup failed with exit code 141" error. In the logs, I have the "ecryptfs-setup-swap failed" error. I also have the "'PageGtk' object has no attribute 'error_dialog'" error and the message that "Ecryptfs is deprecated".

So, on the command line I checked to see if ecryptfs-setup-swap was installed, and it wasn't. So I used "sudo apt install ecryptfs-utils" to install it and tried completing the user setup step again. Got a wait cursor for a while, popped back to console to check syslog and it shows what appeared to be some success with mounting swap. Back to GUI and system reported that the installer crashed.

Continuing in syslog, I see it can't create the home directory for my new user, with error "xubuntu user-setup: adduser: Could not find program named `ecryptfs-setup-private` in $PATH". This executable, as well as ecryptfs-setup-swap, are in /usr/bin, owned by root:root with 755 permissions. chpasswd for the new user I was trying to create failed, "Authentication token manipulation error".

In the previous (16.04) setup, I'd chosen to encrypt the home directory for one user, with other users having been created without that option. The home partition is mounted on /target/home and I am able to see the contents of the subdirectories for users not using encryption.

I'm hoping someone can provide a workaround that'll let me proceed. I will attach the install debug and syslog files from the affected system.

Alan Gifford (siliconbadger) wrote :
Alan Gifford (siliconbadger) wrote :

I encountered the same problem:

ubuntu ubiquity: ecryptfs-setup-swap failed.
ubuntu ubiquity[5758]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
ubuntu ubiquity[5758]: dbfilter_handle_status: ('ubi-usersetup', 141)

during the 'who are you' dialog.

when I chose manual partition, I assigned /home to my existing /home partition.

The existing /home partition contained an existing ecrypted user account.

As a workaround I moved the whole user account to another location. This allowed the installation process to proceed to completion.

avatar1024 (achat1024) wrote :

I confirm this bug.

-Install kubuntu 18.04 with a separate /home partition
-New username different to old username so no conflict in folder
-No encryption (neither on old or new user folder)
-After entering user info, password and press Next I get "ubi-usersetup failed with exit code 141" as described in bug #1761377

a (rqcv1762) wrote :

This bug still persists: Having installed Xubuntu 18.04.1 on 2 different computers successfully, it occurred when installing a 3rd one as described above:
installation type "something else" with partitions:
 sdaW efi fat32
 sdaX / ext4 (to be formatted)
 sdaY swap
 sdaZ /home ext4 (existing and encrypted from previous installation)
Having typed the indications in the window "who are you" yields an error message "ubi-usersetup failed with exit code 141", a syslog entry "ecryptfs-setup-swap failed" and infinite waiting.
The following workaround helped to get the system running:
 installation type "something else" with partitions:
  sdaW efi fat32
  sdaX / ext4 (to be formatted)
  sdaY /home ext4 (this will later become swap)
 run the rest of the installation with same username and password as in the old installation - this works
 after restart, open terminal (ctrl alt F1):
  log in there
  install sudo apt-get install ecryptfs-utils
  sudo reboot
 then change UUID of /home in /etc/fstab to the one of sdaZ, being the original encrypted /home partition
 install encrypted swap with
  sudo mkswap /dev/sdaY
  new entry in /etc/crypttab: "cryptswap1 UUID=<from the previous mkswap command> /dev/urandom swap,offset=1024,cipher=aes-xts-plain64"
  comment out a possibly automatically created swap file in /etc/fstab
  instead new entry in /etc/fstab: "/dev/mapper/cryptswap1 none swap sw 0 0"
 If everything has worked, after restart, logging in will open the encrypted /home and sudo blkid will display sdaY and /dev/mapper/cryptswap1 as swap type partitions.
Obviously besides fixing the bug it would be helpful if the installer would offer an option how to reasonably deal with an old encrypted /home partition which has been a probably frequently used option installing previous versions of Xubuntu.

Changed in ubiquity (Ubuntu):
assignee: Ubuntu Installer Team (ubuntu-installer) → nobody
tags: added: rls-bb-notfixing
removed: rls-bb-incoming
Niccola (niccolatorres) wrote :

This issue still occurs, only on UEFI installations. Any fix or workaround?

Sebastien Bacher (seb128) wrote :

Could anyone give steps that trigger the problem?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments