on a test of xenial .4 release, selecting "connect to wireless" freezes the process

Bug #1752453 reported by Valorie Zimmerman on 2018-02-28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

The files attached to this bug are worthless, as I'm reporting from another machine.

I tried to connect to wireless while leaving the "show password" button selected, and deselecting it after connection.

In both cases, pressing "continue" freezes the process in http://cdimage.ubuntu.com/kubuntu/xenial/daily-live/20180228/xenial-desktop-i386.iso.

I was unable to drop to a terminal to report this bug from my travel laptop while testing so am unable to attach the files /var/log/syslog and /var/log/partman now.

The only way to get out of the freeze was to hard reboot via the power button.

I will see if I can find /var/log/installer/syslog and /var/log/installer/partman once the install is done.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
Uname: Linux 4.13.0-36-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: KDE
Date: Wed Feb 28 15:43:13 2018
InstallationDate: Installed on 2016-05-07 (662 days ago)
InstallationMedia: Kubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: ubiquity
UpgradeStatus: Upgraded to artful on 2017-06-29 (243 days ago)

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:

tags: added: iso-testing

ok. cat /var/log/installer/syslog > was empty. So was partman.

In any case, I'm unable to get the installer to actually install i386 on this laptop *at all.* It has frozen at start, after connecting to wireless, and after choosing auto-resize. Now it freezes after agreeing that English is fine.

ubiquity is completely broken for i386, and leaves behind no logs of its failure.

Łukasz Zemczak (sil2100) wrote :

I wonder if it's specifically related to Kubuntu only? After checking other archs could you also, by any chance, try installing any other .4 flavours on that system?

Since I'm done testing Kubuntu, I will test Lubuntu .4 i386.

Lubuntu's i386 testcases were all covered, so I tried MATE's instead. It passes with flying colors. In some ways, looks better than ours too!

Tested: http://cdimage.ubuntu.com/ubuntu-mate/xenial/daily-live/20180228/xenial-desktop-i386.iso.zsync

So this seems to be our problem alone.

Łukasz Zemczak (sil2100) wrote :

It'll be really hard to assess this issue without any logs. A few other testers that I asked to check out the i386 Kubuntu images weren't able to reproduce the aforementioned issues. Similarly, even after multiple attempts it was still always successful for me in an i386 kvm. It's very worrying but without it being reproducible for others or easily identifiable, I don't want to consider it a blocker for the release.

Łukasz Zemczak (sil2100) wrote :

@valorie-zimmerman: cyphermox tested on his i386 machine Kubuntu installation and it went fine, so if you don't mind I'd like to include i386 Kubuntu in the release right now.

Yes of course. We can't pull support with no announcement beforehand.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers