Manual Encrypted LVM Broken in Xubuntu 14.04.1 Installer

Bug #1352578 reported by John Ross on 2014-08-04
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I believe the package is Ubiquity, but I could be wrong. Please advise and revise accordingly.

 In any case, the issue at hand is associated with the package that runs directly from the installation media and handles manual partitioning, encrypting, and formatting of the harddrives. It affects Xubuntu 14.04 and 14.04.1 installation media. I have only tested AMD/X64. I would expect it is present in i386 but have not tested and confirmed this to be true. Likewise, I would also presume it may affect other releases of 14.04 such as Ubuntu, Kubuntu, etc. Again, I have not had time to test all these configurations.

The issue is that the installer does NOT allow one to manually configure an encrypted LVM setup. There is of course an automated encrypted LVM setup does appear to work, but the manual "something else" option is broken when it comes to LVM. My tests have shown that it is possible to manually create partitions , encrypted containers, and specify formatting and mount points, but there is (as near as I can determine) NOT any option to configure LVM on top of encrypted containers. This is a serious omission!

Historically, the LVM has been used on top of the encryption containers to enable the swap space to be safely encrypted. I have used the alternate installers to configure manual encrypted LVM installations on Xubuntu 12.04 and previous releases of Ubuntu going back to 7.04. The lack of manual encrypted LVM is a critical omission since the default automatic encrypted LVM solution is often inappropriate for the hardware or otherwise unacceptable to the user's needs.

I have provided a screen shot showing options available for configuring an encrypted container using a VMWare test installation. (Note: I have the same result when testing on real hardware.) Anyway, at this point, in the install process the old 12.04 series alternate installer would give the option to setup LVM. The 14.04 installer lacks this feature and presents the user only with options to format the partition or assign it as swap space. There needs to be an option somewhere to setup LVM but it does not exist?

I apologize in advance if I have missed something here. Please educate me if I am doing something wrong.

If I am correct and there is a workaround to solve the problem please reply as otherwise I am unable to upgrade to 14.04. Thanks!

Lastly, I have indicated that this bug is a security vulnerability because not having an manual encrypted LVM option might lead a potential user to proceed with an unencrypted solution rather than a preferred encrypted solution.

information type: Private Security → Public
John Ross (johnross-johnross) wrote :

It's been a month since I filed this bug report. Is anyone home?

Can someone else please confirm that the bug exists and that I'm not imagining it? Thanks!

John Ross (johnross-johnross) wrote :

I installed Lubuntu 14.04 on a netbook today using the text based i386 alternate installer. The manual configuration of encrypted LVM was just like it was on 12.04 and worked like a charm. Too bad all the other ubuntu distros have abandoned the alternate installer in favor of Ubiquity! Thank you Lubuntu team for giving me an option to run new encrypted LVM installs!

John Ross (johnross-johnross) wrote :

Searching on an unrelaed matter today I stumbled upon this:

http://askubuntu.com/questions/502876/ubuntu-14-04-install-with-custom-swap-size-using-lvm

It seems to confirm the issue of this bug report and offers a work around to the installer bug.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Corasol (corasol) on 2015-01-24
information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Public
Curt Sampson (cjs-cynic) wrote :

Just encountered it myself. Seriously, a year later it's still present?

John Ross (johnross-johnross) wrote :

Thanks for confirming! I'm also amazed that there has been no action on this since I reported it last year. One would think this is likely an easy fix since the functionality was available in earlier releases?

Peder Stray (pstray) wrote :

Still present in 16.04 plain Ubuntu desktop install.

N. W. (nw9165-3201) wrote :

Any update?

John Ross (johnross-johnross) wrote :

I haven't tested for this in quite a while, but I have no reason to believe it has been fixed. If someone has evidence to the contrary please advise.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers