Ubuntu

does not install language packs for the target language

Reported by Martin Pitt on 2007-08-09
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan Dandrea

Bug Description

Binary package hint: ubiquity

When installing the Tribe 4 amd64 Ubuntu desktop CD, I do not have any German language-pack/language-support installed.

In previous tribes, ubiquity downloaded the missing bits (language-support-de) from the network and used the shipped language-pack-*-de from the CD.

This is the first Tribe which does not ship the German langpacks on the CD due to space constraints, I guess this is the important change for this bug.

Martin Pitt (pitti) wrote :
Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → High
Patrice Vetsel (vetsel-patrice) wrote :

Almost the same here. Language-support-fr is not asked to be downloaded during installation.

It _never_ worked correctly for the dutch language support.
Eventhough the alternative installer worked fine.

What happens:
  - application translations are installed
  - dictionaries are NOT installed, nor downloaded

This is happening at least since Edgy.

Changed in ubiquity:
status: New → Confirmed

Even when enabling dutch language support, through language support menu, I need to install myspell-nl package manually.

Why is this not installed with the language support?

Timo Jyrinki (timo-jyrinki) wrote :

This has worked in dapper, edgy, feisty, but indeed does not seem to work in gutsy. I think this bug should be made critical.

This an installer syslog as requested by seb128, from a feisty installation, a daily live build from just a two, three days ago. The installer indeed does not pull in the required language pack or dictionaries. Polish in this case.

@timo ..

Did it really for you in Feisty and Edgy? For other languages than English?
Or did you go to administration -> language-support ?
That program asks if you want to download the additional language packs and dictionaries.

I would like to correct my earlier comment, this is a log from a gutsy installation of course, not feisty. And it wasn't seb128 who requested the log, it was cjwatson :]

Timo Jyrinki (timo-jyrinki) wrote :

@Ralf:

Yes, naturally, otherwise we wouldn't have had localized (without manual language support tool usage) Finnish and other language installations when installing from the CD at all. And even when the language packs have been included, eg. on Edgy CD Finnish language packs were included and in Feisty not, language-support-XX and its dependencies are always needed to be downloaded, and have been automatically downloaded during the installation before. Ubuntu hasn't been English-only (or language-packs-included-on-the-CD only) installable before :)

Timo Jyrinki (timo-jyrinki) wrote :

@Ralf: As an additional comment, one needs to have a working network connection enabled before starting the installation for the language support download to work in dapper/edgy/feisty, something I'd like to be automatically guided to be done in the installation like I described in my recent post to ubuntu-devel-discuss: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2007-August/001533.html

Evan Dandrea (ev) on 2007-09-06
Changed in ubiquity:
status: Confirmed → In Progress
Evan Dandrea (ev) wrote :

I've committed a temporary fix for this while I track down the root cause of the problem.

Changed in ubiquity:
status: In Progress → Fix Committed

Also, when it downloads language support, can it please also download the dictionaries?

The myspell-{country-code} and the aspell-{country-code} packages?

Ralf Nieuwenhuijsen [2007-09-07 7:50 -0000]:
> Also, when it downloads language support, can it please also download
> the dictionaries?

This is indirectly done by installing language-support-<lang>.

Colin Watson (cjwatson) wrote :

ubiquity (1.5.13) gutsy; urgency=low

  [ Mario Limonciello ]
  * Correct typo in HDHomerun application.
  * Make sure that backend_configured happens for right user.
  * Re-order installer so Mythbuntu steps appear at a different time.
  * Make sure errno errors can be reported properly in mythbuntu_install.py
    (LP: #130771)

  [ Evan Dandrea ]
  * The migration-assistant page will now be skipped if there are no
    partitions able to be imported from.
  * Initialize self.errors in migration-assistant (LP: #134254).
  * Add a progress bar for automatic mode.
  * Update noninteractive frontend to work with recent changes.
  * Temporary fix for the language packs no longer installing bug (LP:
    #131294)

  [ Colin Watson ]
  * If 'automatic-ubiquity' is on the kernel command line, start Ubiquity in
    its own X session. Thanks to Agostino Russo for the prototype of this.
  * Just call 'reboot' rather than gdm/kdm-specific reboot methods if
    DESKTOP_SESSION isn't set in the environment.
  * Automatic update of included source packages: apt-setup 1:0.21ubuntu3,
    base-installer 1.81ubuntu2, grub-installer 1.24ubuntu3,
    partman-auto-loop 0ubuntu5, partman-efi 13ubuntu2, partman-target
    50ubuntu4.

 -- Colin Watson <email address hidden> Fri, 07 Sep 2007 18:24:17 +0100

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers