Ubuntu

Ubiquity freezes in Install Alongside screen

Reported by Jeremy Bicha on 2013-04-04
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

This is with the Ubuntu GNOME 13.04 Beta 2 candidate image.

This fails the Live Image testcase.

Ubiquity freezes in the Install Alongside screen.

This is with an already existing Ubuntu GNOME 13.04 Beta 2 full-disk install. /dev/sdb is the USB stick I was using for the installer image.

$ sudo fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d4f1e

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 484487167 242242560 83 Linux
/dev/sda2 484489214 488396799 1953793 5 Extended
/dev/sda5 484489216 488396799 1953792 82 Linux swap / Solaris

Disk /dev/sdb: 4026 MB, 4026531840 bytes
64 heads, 32 sectors/track, 3840 cylinders, total 7864320 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7e07750b

   Device Boot Start End Blocks Id System
/dev/sdb1 * 64 1970175 985056 17 Hidden HPFS/NTFS

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubiquity 2.14.1 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.8.0-16.26-generic 3.8.5
Uname: Linux 3.8.0-16-generic i686
ApportVersion: 2.9.2-0ubuntu5
Architecture: i386
CasperVersion: 1.330
Date: Thu Apr 4 15:42:30 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu-gnome.seed boot=casper initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha i386 (20130402.1)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1164592

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I just did some quick cross-testing with Lubuntu RR i386 20130403 on a quite simple drive arrangement (same arrangement where this failed with Ubuntu GNOME RR i386 20130402.1), bare metal, one previous Ubuntu GNOME install, and no free space. The Lubuntu image proceeded as expected so this is going to require more investigation to be certain if it was a change between 20130402.1 and 20130403.

But I think we should be able to release these Beta images with an appropriate mention of this bug in the release notes.

Erick Brunzell (lbsolost) wrote :

Also effects Ubunu GNOME amd64 20130402.1.

And, since haste makes waste, where I said, "this is going to require more investigation to be certain if it was a change between 20130402.1 and 20130403", I should have said;

This is going to require more investigation to be certain if it was a change between 20130402.1 and 20130403, or if it effects only our flavor.

Erick Brunzell (lbsolost) wrote :

Come to find out I followed that last Ubuntu GNOME auto-resize test with a manual partitioning test, and the resize actually had taken place (at least partially) but the installation apparently "froze" after the resize ........... or maybe the resize was occurring so slowly that I got impatient????

So, just thinking out loud here, I need to look at the behavior among other flavors. Maybe we're just failing to notify of the resize taking place ............ and possibly taking a long time.

I'm just a bit hamstrung ATM because I'm down one test box :^(

I need a few days to regroup and get a box rebuilt.

codeslinger (codeslinger) wrote :

was your swap partition (auto) mounted when you attempted the install?

if so, then this is most likely a dup of https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1080701

Erick Brunzell (lbsolost) wrote :

@ codeslinger,

I'm reasonably certain that this is not a duplicate of bug #1080701.

Erick Brunzell (lbsolost) wrote :

Since this is a bit difficult to explain I posted some screenshots at the forums so you can see a comparison of what Lubuntu does (the expected behavior) and what Ubuntu GNOME does (the borked behavior):

http://ubuntuforums.org/showthread.php?t=2132504

No need to reply there, I just needed to use some pics to properly explain the issue ;^)

Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Erick Brunzell (lbsolost) wrote :

I disagree with the importance of this bug being "Medium". Any bug that interferes with installation should be high priority.

Erick Brunzell (lbsolost) wrote :

OK, I'm now testing 20130423.2 amd64 and I still get a freeze at this point although bug #1080701 appears to me to be fixed.

To be clear; it's not possible to "drag" to resize and only the quit button appears to be active (although it doesn't work), even clicking on the highlighted "advanced partitioning tool" does nothing so install alongside is borked in Ubuntu GNOME.

It does work OK in Lubuntu so I think this is purely an Ubuntu GNOME problem, but I've not had time to test Ubuntu itself.

Erick Brunzell (lbsolost) wrote :

Probably not at all helpful, but I'm doing some retesting this AM with 20130423.2 i386, and this appears to be the only function that's broken. Even alongside installs work as they should if sufficient free space is available.

That is, the Continue button changes to Install now as expected and the installation runs as it should. So it's only the "resize" window that's borked.

gary jacks (gazoboy) wrote :

also on ubuntugnome 13.04 using install option something else and installing to sd3 mount point / produced grub rescue error. fixed by boot repair/reinstalling grub... this error never occured during ubuntu 13.04 beta so related to installer.

Tim (darkxst) wrote :

Tested this on alpha2 candidate image and auto-resize completed and then installed successfully, without any sign of freezing.

Tim (darkxst) wrote :

^ubuntu GNOME alpha2

Jeremy Bicha (jbicha) wrote :

I'm going to mark this fixed since the Install Alongside button magically started working again for 13.10 and there will be no more 13.04 images.

More specifically, it looks like Install Alongside is still broken in the standalone mode but it works in the live session. See bug 1204765 for that issue.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers