After 'Preparing to install Ubuntu' screen, raring installation hangs

Bug #1080701 reported by Para Siva on 2012-11-19
474
This bug affects 100 people
Affects Status Importance Assigned to Milestone
ubiquity
Fix Released
Undecided
Unassigned
partman-auto (Ubuntu)
Critical
Colin Watson
Raring
Critical
Colin Watson
ubiquity (Ubuntu)
Critical
Colin Watson
Raring
Critical
Colin Watson

Bug Description

Test steps:
1. Boot the machine with usb
2. Enter the wireless password to enable the wifi connection
3. Wait to hear the drums and select 'Install Ubuntu' with English being the language selection
4. Click 'Continue' with the default selections on the 'Preparing to install ubuntu' screen( where it shows the power, available disk space and internet connectivity statu)
5. The installation does not proceed from this point

Workarounds:
It has been reported within this bug that deleting extended partitions, or disabling swap, or mounting partitions "helps" to bypass the problem.

Why is this not fixed yet:
Well, at the moment the cause of hangs has not been determined. The best way to aid Ubuntu Installer team at fixing this bug is to provide a reproducible test case of this hang, that is is steps that one needs to perform to setup a VM / real machine that will exhibit such hang. At the moment we don't know how to trigger this bug and thus diagnose & fix it.

Para Siva (psivaa) wrote :
summary: - Raring i386 desktop installation hangs with 'ubuntu ubiquity: umount:
- /tmp/tmp.vF1xKWu5Pp: not mounted'
+ Raring i386 desktop installation hangs with 'ubuntu partman: No matching
+ physical volumes found'
description: updated

Just to be clear, this occurred in a hardware installation of raring -i386-desktop using usb stick created and the image was created using dd on a quantal -amd64 installed-machine. Raring-desktop-amd64 installation did not have this issue.

tags: added: ubi-partman
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Robert Walters (rjwalters55) wrote :

I have this same problem - but it is when I attempt to install a raring-amd64-desktop. Ubuntu 12.10 amd64 will install ok on the same PC.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Robert Walters (rjwalters55) wrote :

More information about my hardware setup -

My system board is a ASUS M4A89GTD-PRO/USB3 , CPU is Phenom II 1100T x6 , 16GB Memory, drive SDA is 120GD SSD for Windows 7, drive SDB is 240GB SSD for Ubuntu 12.04.1 LTS, drive SDC is 115GB SSD for Ubuntu 13.04, video is ATI Radeon HD 4290. Ubuntu 12.10 installs fine on drive SDC - but Ubuntu 13.04 install always with 'ubuntu partman: No matching physical volumes found'. This is with the amd64 Ubuntu 13.04.

Brian Winstone (kangaba) wrote :

Same problem. My hw specs attached (sudo lshw >> hw.txt)

Robert Walters (rjwalters55) wrote :

My hw specs attached (sudo lshw >> rjw1678-hw.txt)

Irene Grammatika (irenegr92) wrote :

Same problem when I attempt to install a raring-amd64-desktop. Ubiquity version 2.13.6

Linux lubuntu 3.7.0-4-generic #12-Ubuntu SMP Tue Nov 27 23:13:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Bryce Harrington (bryce) on 2012-12-04
summary: - Raring i386 desktop installation hangs with 'ubuntu partman: No matching
- physical volumes found'
+ Raring installation hangs with 'ubuntu partman: No matching physical
+ volumes found'
summary: - Raring installation hangs with 'ubuntu partman: No matching physical
- volumes found'
+ After 'Preparing to install Ubuntu' screen, raring installation hangs
+ with 'ubuntu partman: No matching physical volumes found'

I suspect bugs #1081245, #1082909, #1084627, and #1085991 are all related to this, and perhaps dupes (at least, all have hangs at the same point). I didn't compare syslogs to see if they are indeed dupes.

From the comments it sounds like this can occur when there are existing partitions set up on the disk that somehow confuse ubiquity. A number of users report working around the problem by deleting all partitions and trying again, however in situations where you want multiple ubuntu's installed side-by-side, that obviously won't work.

There is an askubuntu post here:
http://askubuntu.com/questions/204771/ubuntu-12-10-installation-hangs-at-preparing-to-install-ubuntu

I've been able to reproduce this bug on two out of three systems (two desktops failed; one laptop worked fine). I've tried both with and without checking "download updates while installing" and "include third-party software", which didn't change the behavior. Tried both going directly into the installer, vs. booting into the live environment and then loading the installer.

Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
Bryce Harrington (bryce) wrote :
  • dm Edit (4.5 KiB, text/plain)
Bryce Harrington (bryce) wrote :
Download full text (3.5 KiB)

Snippet from my syslog:

Dec 4 15:38:33 ubuntu ubiquity[21690]: Ubiquity 2.13.3
Dec 4 15:38:34 ubuntu ubiquity[21690]: log-output -t ubiquity laptop-detect
Dec 4 15:38:34 ubuntu ubiquity[21690]: log-output -t ubiquity laptop-detect
Dec 4 15:38:37 ubuntu ubiquity[21690]: switched to page language
Dec 4 15:38:38 ubuntu localechooser: info: debian-installer/language preseeded to 'en' (seen: false)
Dec 4 15:38:38 ubuntu localechooser: info: debian-installer/country preseeded to 'US' (seen: false)
Dec 4 15:38:38 ubuntu localechooser: info: debian-installer/locale preseeded to 'en_US.UTF-8' (seen: false)
Dec 4 15:38:38 ubuntu localechooser: info: Preseeded language ignored: unknown language code
Dec 4 15:38:38 ubuntu ubiquity[21690]: switched to page language
Dec 4 15:38:45 ubuntu localechooser: info: Language = 'en'
Dec 4 15:38:45 ubuntu localechooser: info: line=en;0;US;UTF-8;en_US.UTF-8;;console-setup
Dec 4 15:38:45 ubuntu localechooser: info: Set debian-installer/language = 'en'
Dec 4 15:38:45 ubuntu localechooser: info: Default country = 'US'
Dec 4 15:38:45 ubuntu localechooser: info: Default locale = 'en_US.UTF-8'
Dec 4 15:38:45 ubuntu localechooser: info: Set debian-installer/consoledisplay = 'console-setup'
Dec 4 15:38:45 ubuntu localechooser: info: Set debian-installer/country = 'US'
Dec 4 15:38:46 ubuntu localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Dec 4 15:38:46 ubuntu localechooser: info: System locale (debian-installer/locale) = 'en_US.UTF-8'
Dec 4 15:38:53 ubuntu ubiquity[21690]: debconffilter_done: ubi-language (current: ubi-language)
Dec 4 15:38:53 ubuntu ubiquity[21690]: Step_before = stepLanguage
Dec 4 15:38:54 ubuntu ubiquity[21690]: switched to page prepare
Dec 4 15:39:03 ubuntu ubiquity: No drivers found for automatic installation.
Dec 4 15:39:03 ubuntu ubiquity[21690]: debconffilter_done: ubi-prepare (current: ubi-prepare)
Dec 4 15:39:03 ubuntu ubiquity[21690]: Step_before = stepPrepare
Dec 4 15:39:03 ubuntu ubiquity[21690]: Step_before = stepPrepare
Dec 4 15:39:04 ubuntu activate-dmraid: No Serial ATA RAID disks detected
Dec 4 15:39:04 ubuntu partman: No matching physical volumes found
Dec 4 15:39:04 ubuntu partman: Reading all physical volumes. This may take a while...
Dec 4 15:39:04 ubuntu partman: No volume groups found
Dec 4 15:39:04 ubuntu partman-lvm:
Dec 4 15:39:04 ubuntu partman-lvm: No volume groups found
Dec 4 15:39:04 ubuntu partman-lvm:
Dec 4 15:39:06 ubuntu ubiquity: umount: /tmp/tmp.F3t8j3goRS: not mounted
Dec 4 15:39:07 ubuntu ubiquity: umount: /tmp/tmp.6oHQ2mgMPc: not mounted
Dec 4 15:39:07 ubuntu ubiquity: umount: /tmp/tmp.hWjhpwkJYI: not mounted
Dec 4 15:39:08 ubuntu ubiquity: umount: /tmp/tmp.p8kAzQ4KM2: not mounted
Dec 4 15:40:07 ubuntu ubiquity: Use of uninitialized value in concatenation (.) or string at /usr/share/perl5/Debconf/DbDriver/File.pm line 44.
Dec 4 15:40:07 ubuntu ubiquity: Use of uninitialized value in -e at /usr/share/perl5/Debconf/DbDriver/File.pm line 46.
Dec 4 15:40:07 ubuntu ubiquity: Use of uninitialized value in pattern match (m//) at /usr/share/perl5/Debconf/DbDriver/File.pm line 47.
Dec 4 15:40:07 ubuntu ubiquity: Us...

Read more...

Bryce Harrington (bryce) wrote :

On the system with the logs provided above, I deleted partitions 3, 5, and 6, restarted the installer, and it proceeded into partman properly.

Bryce Harrington (bryce) wrote :

Further experimentation, I reinstalled the system from scratch.

0. Insert precise Live USB stick and boot either directly or via live session
1. Install 12.04, using "Something Else" and partitioning as follows:
    /dev/sda1 20G /
    /dev/sda2 20G swap
    /dev/sda3 100G /var/cache/foobar
    /dev/sda4 EXTENDED
    /dev/sda5 20G [formatted, but no mount point]
    (The system has a 320G hard drive, so this leaves ample remaining unpartitioned space.)
2. Reboot into precise 12.04.
    * Verify partition /dev/sda3 mounted

3. Insert raring Live USB stick, and reboot
4. Go to Live session
5. Launch ubiquity to begin installation
6. Hangs after selecting Continue from 'Preparing to install Ubuntu'
7. Quit ubiquity

8. Run `df /dev/sda` or your favorite partition manager, and delete partitions 3, 4, and 5. (I tried deleting only partitions 4 and 5, but it'd still hang.) Then run partprobe as suggested.
9. Launch ubiquity again
10. This time it allows progressing to the partition manager.

Colin Watson (cjwatson) wrote :

I can't see any errors in the syslog here, nor really much I can get hold of in general. Please could somebody with this bug make sure they have ubiquity 2.13.7, start the installer with 'ubiquity --debug', and attach logs from that?

summary: After 'Preparing to install Ubuntu' screen, raring installation hangs
- with 'ubuntu partman: No matching physical volumes found'
Changed in ubiquity (Ubuntu Raring):
status: Confirmed → Incomplete
Para Siva (psivaa) wrote :
Para Siva (psivaa) wrote :

The logs are attached above obtained with ubiquity 2.13.7 running on the debug mode
The hang was observed at the same place after the same steps as described in the original description. i.e.
1. Boot to live session
2. Install latest version of ubiquity which is 2.13.7
3. On the terminal run 'ubiquity --debug'
4. Select language -> continue
5. Click 'Continue' at the 'Preparing to install Ubuntu' dialog where the power,network and drive space status will be shown. The hang would be observed at this point.

Changed in ubiquity (Ubuntu Raring):
status: Incomplete → Confirmed

when I removed extended partition, installer works

Para Siva (psivaa) on 2012-12-07
tags: added: qa-daily-testing
tags: added: iso-testing
Xavier Guillot (valeryan-24) wrote :

I confirm the bug with daily images from 9 and 10th December of Raring AMD64 desktop version on a home computer.

On this computer Ubuntu 12.10 is the only system installed, there are 3 hard disks, on the "boot" one there is a primary partition with "/" and an extended one with "swap", "/home" and other logical partitions. The 2 other disks have only one primary partition (datas), all are Ext4.

Booting on Live CD and using Raring works fine, but if I try to install, same problem : I select french languauge, it detects that I have enough space and am connected to Internet, I check the "Flash and MP3" installation, click on "Continue", and then it keeps hanging over without processing...

Xavier Guillot (valeryan-24) wrote :

Ubiquity 2.13.7 logs from /var/log/installer

Simplehuman (simplehuman) wrote :

The same problem here. I marked my bug report as a dublicate of this.

Joel Almeida (joelalmeidaptg) wrote :

The same here. I have a dual-boot with Windows 8 and Ubuntu 12.10 currently installed, and it hangs if I try to install raring (64-bits).

Ty Maja (tymaja) wrote :

More than a month later, this bug still persists. I am writing this update on Raring (daily release of 31st October 2012) from the live USB I made. I have a nice 8-partition GUID drive setup; I would do the delete-all-partitions workaround but this deleting Mac OS X from my MacBook Pro would be a bad idea! (it is the only thing that let me make this live USB after all).

The problem is with the Ubiquity partitioner. Installing the Quantal Ubiquity doesn't work. Also, downloading the raring alternate install CD also doesn't work. It goes along in text mode then hangs when starting the partitioner, giving the same 'no volume groups found' error (this error occurs on both the alternate ubuntu raring debian-installer system as well as the ubiquity system (in the logs).

I don't know enough about the ubiquity code to know where the 'partman' is or how it links in. It certainly isn't a partman package nor gparted.

Would be grateful to get this sorted but for now going back to Mint 14 as I can install it (I know raring is testing but it would be cool if someone could revert the partman 'upgrade' that has stopped us being able to install it) :(

System Specs are MacBook Pro 9,1 with 8GB ram and a standard HDD. I can't remove Mac OS X as an experiment as I then couldn't reinstall it.

Dimitri John Ledkov (xnox) wrote :

I did manage to reproduce a hang with a windows7/ntfs install while booting into raring i386 desktop cd.
Needs further debugging to understand why it hangs in reuse recipe at the close_dialog call.

Changed in ubiquity (Ubuntu Raring):
assignee: nobody → Dmitrijs Ledkovs (xnox)
H. van de Kolk (rikolk-f) wrote :

still no progress ....

Kaj Ailomaa (zequence) wrote :

Was preparing a machine for testing and installed several releases of Debian, Ubuntu and Ubuntu Studio on various partitions, but it seems I've come to a limit. Unable to install another release of Ubuntu Studio.
Below is the partition table, and existing installs. 1 Debian install. 1 Ubuntu install. 5 Ubuntu Studio installs.

sda6 Debian Wheezy
sda7 Ubuntu Quantal 12.10
sda8 (ext4 - empty)
sda9 Ubuntu Studio 12.04.1 32bit
sda10 Ubuntu Studio 12.04.1 64bit
sda11 Ubuntu Studio 12.10 32bit
sda12 Ubuntu Studio 12.10 64bit
sda13 Ubuntu Studio 13.04 32bit
sda14 (ext4 - empty)
sda5 SWAP
sda2 ext4 - data partition

This is the syslog from trying to install:

Jan 20 00:05:41 ubuntu-studio ubiquity[8544]: Ubiquity 2.13.9
Jan 20 00:05:42 ubuntu-studio ubiquity[8544]: log-output -t ubiquity laptop-detect
Jan 20 00:05:44 ubuntu-studio ubiquity[8544]: switched to page language
Jan 20 00:05:45 ubuntu-studio localechooser: info: debian-installer/language preseeded to 'en' (seen: false)
Jan 20 00:05:45 ubuntu-studio localechooser: info: debian-installer/country preseeded to 'US' (seen: false)
Jan 20 00:05:45 ubuntu-studio localechooser: info: debian-installer/locale preseeded to 'en_US.UTF-8' (seen: false)
Jan 20 00:05:45 ubuntu-studio localechooser: info: Preseeded language ignored: unknown language code
Jan 20 00:05:45 ubuntu-studio ubiquity[8544]: switched to page language
Jan 20 00:05:48 ubuntu-studio localechooser: info: Language = 'en'
Jan 20 00:05:48 ubuntu-studio localechooser: info: line=en;0;US;UTF-8;en_US.UTF-8;;console-setup
Jan 20 00:05:48 ubuntu-studio localechooser: info: Set debian-installer/language = 'en'
Jan 20 00:05:48 ubuntu-studio localechooser: info: Default country = 'US'
Jan 20 00:05:48 ubuntu-studio localechooser: info: Default locale = 'en_US.UTF-8'
Jan 20 00:05:48 ubuntu-studio localechooser: info: Set debian-installer/consoledisplay = 'console-setup'
Jan 20 00:05:48 ubuntu-studio localechooser: info: Set debian-installer/country = 'US'
Jan 20 00:05:48 ubuntu-studio localechooser: info: Set debian-installer/locale = 'en_US.UTF-8'
Jan 20 00:05:48 ubuntu-studio localechooser: info: System locale (debian-installer/locale) = 'en_US.UTF-8'
Jan 20 00:05:50 ubuntu-studio ubiquity[8544]: debconffilter_done: ubi-language (current: ubi-language)
Jan 20 00:05:50 ubuntu-studio ubiquity[8544]: Step_before = stepLanguage
Jan 20 00:05:50 ubuntu-studio ubiquity[8544]: switched to page prepare
Jan 20 00:05:56 ubuntu-studio ubiquity[8544]: debconffilter_done: ubi-prepare (current: ubi-prepare)
Jan 20 00:05:56 ubuntu-studio ubiquity[8544]: Step_before = stepPrepare
Jan 20 00:05:56 ubuntu-studio ubiquity[8544]: Step_before = stepPrepare
Jan 20 00:05:56 ubuntu-studio activate-dmraid: No Serial ATA RAID disks detected
Jan 20 00:05:56 ubuntu-studio partman: No matching physical volumes found
Jan 20 00:05:56 ubuntu-studio partman: Reading all physical volumes. This may take a while...
Jan 20 00:05:56 ubuntu-studio partman: No volume groups found
Jan 20 00:05:56 ubuntu-studio partman-lvm: No volume groups found

Kaj Ailomaa (zequence) wrote :

/var/log/installer/debug

3 comments hidden view all 150 comments
Kaj Ailomaa (zequence) wrote :

Argh. I was able to get ubiquity to work once, and then retried with --debug, but couldn't get it to work again. So, no debug on that. Seems like it might not fail every time.

Kaj Ailomaa (zequence) wrote :

Posting this partman log from a unsuccesful netinstall (in case it is related)

Kaj Ailomaa (zequence) wrote :

The syslog from the same unsuccesful netinstall

Kaj Ailomaa (zequence) wrote :

This partman is from a successful netinstall

Kaj Ailomaa (zequence) wrote :

and the syslog for the successful netinstall

1 comments hidden view all 150 comments
Simplehuman (simplehuman) wrote :

@Shan Anand, your workaround didn't work for me :(

What I did:

1. boot from USB to Live image
2. Open Terminal
3. run command 'ps -ela'
4. find rsyslogd
5. run command: 'sudo kill ####' (PID of rsyslogd)

But rsyslogd starting again in a moment with another PID.

If I run 'sudo rsyslogd -c5 -i -d' there will be 2 processes of rsyslogd and killing the system one starts it again.

And installer hangs again...

What I did wrong?

Bryce Harrington (bryce) on 2013-03-06
Changed in ubiquity (Ubuntu Raring):
milestone: none → ubuntu-13.04
no longer affects: ubiquity
Jonathan Riddell (jr) on 2013-04-03
tags: added: kubuntu
description: updated
70 comments hidden view all 150 comments

On 19 April 2013 15:28, minnigaliev-r <email address hidden> wrote:
> Have this issue on one of my PCs.
> PC with issue in difference to PC without issue have 2 disks SSD + HDD.
>
> parted -l and fdisk -l see in attachment.
>

Are those GPT or MS-BIOS / regular mbr partition tables?

Regards,

Dmitrijs.

Dimitri John Ledkov (xnox) wrote :

On 19 April 2013 15:49, Erick Brunzell <email address hidden> wrote:
> Here's a screenshot of the new "System" column in ubiquity. It did not
> exist prior to Raring.
>
> I truly suspect that we're just used to having things proceed within
> seconds rather than many, many minutes :^)
>

That system column is cached, the fact that you can get to seeing item
"Something else" means that this bug has already been dodged.
Please note that system column was added in:
https://launchpad.net/ubuntu/+source/ubiquity/2.13.13

Almost 4 months after this bug was first reported.

Regards,

Dmitrijs.

Erick Brunzell (lbsolost) wrote :

@ Dmitrijs,

I think I did a bad job of explaining that, I did try my best.

My point is that whatever was added to ubiguity to display System info may have just slowed the installation process in complex muti-boots and multiple disc installs to a point where users think it's frozen, when in fact it's still "reading" info.

And I first encountered this months ago:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1107541

Erick Brunzell (lbsolost) wrote :

Oops, "muti-boots" should obviously be "multi-boots". I forget that after every Firefox update I must again fiddle with spell-check languages :^(

Dimitri John Ledkov (xnox) wrote :

On 19 April 2013 17:03, Erick Brunzell <email address hidden> wrote:
> @ Dmitrijs,
>
> I think I did a bad job of explaining that, I did try my best.
>
> My point is that whatever was added to ubiguity to display System info
> may have just slowed the installation process in complex muti-boots and
> multiple disc installs to a point where users think it's frozen, when in
> fact it's still "reading" info.
>

Yes, there could be a fine line between "takes to long" and it is
actually hanging.
I remember receiving reports of machines hanging, with ps outputs send
to me of "stuck" processes.

System info column, is irrelevant, we always did that OS scan and
displayed that info the into drop-down for "target device to install
bootloader", we simply added a column to also display it in the table
view.
It did not any extra, processing at all.

Regards,

Dmitrijs.

Kent Baxley (kentb) wrote :

Here's what seems to reproduce it for me on Ubuntu Server:

13.04 Server Variant, 64-bit
PowerEdge R620 with a 840GB Hardware RAID 5

I'm trying to do a clean install of 13.04 Server on a system that currently has Fedora 18 installed.
The disk layout on the Fedora system is as follows:

/dev/sda1 /boot 500M
/dev/sda2 lvm-physical volume, 836GB
1 Volume group created from the pv above
3 Logical Volumes (50GB, 780GB, 4GB for /, /home, and swap respectively)

The server installation works fine until we get to the partitioning stage. At that point, I see the progress bar that says "Starting up the Partitioner". That finishes just fine. What I expect to see next, however, is the partitioning screen asking me how I want to partition my disk.

Instead, all I see is a blank, purple screen that seems to sit there indefinitely. The only way I've been able to get around this is if I wipe the disks out before installing OR if the system has a simple partitioning scheme (i.e. no LVM, etc.) things work as expected.

I'm attaching the partman log and the syslog from a system that is currently reproducing my problem. Hopefully it helps. The last thing in the syslog before the installer gets stuck is this:

Apr 19 17:25:57 kernel: [ 319.912392] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
Apr 19 17:25:58 md-devices: mdadm: No arrays found in config file or automatically
Apr 19 17:25:58 partman: PV /dev/sda2 VG fedora_dhcp-163-166 lvm2 [836.11 GiB / 0 free]
Apr 19 17:25:58 partman: Total: 1 [836.11 GiB] / in use: 1 [836.11 GiB] / in no VG: 0 [0 ]
Apr 19 17:25:58 partman: Reading all physical volumes. This may take a while...
Apr 19 17:25:58 partman: Found volume group "fedora_dhcp-163-166" using metadata type lvm2
Apr 19 17:25:58 partman-lvm: 3 logical volume(s) in volume group "fedora_dhcp-163-166" now active

Kent Baxley (kentb) wrote :

partman log

Kent Baxley (kentb) wrote :

The disks, by the way, are not using GPT, just msdos style partition tables.

Erick Brunzell (lbsolost) wrote :

"there could be a fine line between "takes to long" and it is
actually hanging."

That's what I was trying to explain in my case :^)

I think I've been effected by "takes too long" rather than an actual hang. But "too long" is how long?

I'm guessing anything over 1 minute is too long unless we display a "please wait" or "this may take a long time" message, but I also know we want to avoid pop-out type messages.

Regardless the Quantal images work as expected but the Raring images have this "hang" or "delay".

thunderamur (thunderamur) wrote :

>> Are those GPT or MS-BIOS / regular mbr partition tables?

Regular mbr partition tables on both disks.

I installed it now!
I tried to delete partition with old 12.04 system. After this installation progress. But I breaked installation to do some changes in home partition. After installation do not continue again and delete system partition not help. I tried to reboot and start installation without "Try Ubuntu" and get profit.

It's very bad to system for human beings. I hope we can fix this bug!

Paul Cook (narkosen) wrote :

Confirming this bug still exists when using the daily build 64 bit desktop live install downloaded 2013-04-21.

i7 PC with intel Ivybridge chipset.
1 x SDD ; 1 x HDD - both aligned to sector 2048 (1MB boundary partition alignment).

Output of sudo parted -l
Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 42.1GB 42.1GB primary ext4 boot
 2 42.1GB 128GB 85.9GB primary ext4

Model: ATA ST1000DM003-9YN1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 474GB 474GB primary ext4
 2 474GB 949GB 474GB primary ext4
 3 949GB 1000GB 51.5GB extended
 5 949GB 970GB 21.5GB logical ext4
 6 970GB 992GB 21.5GB logical ext4
 7 992GB 1000GB 8582MB logical linux-swap(v1)

The only way I could get install to proceed without hanging was to:
a. Boot live session - selecting 'Try Ubuntu' option.
b. Open nautilus and mount a partition (happened to be /home)
c. Start install Ubuntu.

Previous workarounds did not seem to help e.g. CLI ubiquity --debug, starting gparted then closing.
I hope it gets fixed before release as having an OS not able to install from its media is not a great selling point for new users :-(

Dan Kegel (dank) wrote :

Happens for me with both beta 2 and today's daily, on 2 out of 3 machines tested.
All three systems are dual-boot and have plain old pc style extended partition tables.

comment 88 suggested that turning off swap might work around the problem, but it didn't seem to for me :-(

comments 88 and 121 suggested that mounting a partition might work around the problem. I can confirm this;
on the first machine I tried, doing ctl-alt-f1 and 'sudo mkdir /media/foo; sudo mount /dev/sda5 /media/foo',
then clicking Continue brought up a warning box
  "Unmount partitions that are in use?"
Clicking 'No' on that dialog let me get to the Installation type dialog, and installation worked fine from there. Yay!

Given that this affected 2 out of my 3 machines, this seems like a release blocker; not fixing it before release
will probably result in widespread knowledge of this workaround and a few hits to Ubuntu's reputation.

I'm happy to retest if there's progress.

askuhn (askuhn) wrote :

I can confirm Dan Kegel's experience in comment #122 was the same as I had on my machine. Mounting a partition I would not be using with nautilus and answering no to the in the installer's prompt allowed me to continue. This definitely needs to be a blocker for 13.04, in my (admittedly novice) opinion.

Thomas Dreibholz (dreibh) wrote :

I have the same problem on a ThinkPad W500, booting the 64-bit Raring Beta 2 from USB. The installer always hangs before getting to the partitioner. However, "sudo swapoff -a" seems to solve the problem. At least, I got the partitioner now.

Krash (krash1220) wrote :

I have this same problem but I can't seem to figure out how to open a terminal during install. I've tried ctrl alt f1 but nothing happens. If I drop to a shell I can't run sudo swapoff -a. What am I doing wrong?

Colin Watson (cjwatson) on 2013-04-22
Changed in ubiquity (Ubuntu Raring):
importance: High → Critical
Dan Kegel (dank) wrote :

#121 also mentioned ubuiquity --debug, which one can do by adding debug-ubiquity to the kernel commandline when booting the install disc.
( see https://wiki.ubuntu.com/DesktopCDOptions )
This shouldn't do anything but turn on more logging in /var/log, but the one time I tried it, the install didn't hang for me.

Dieter Baum (dieterbaum) wrote :

With my motherboard I can manage disks with MBR and GPT disks in UEFI mode. If I install Ubuntu with MBR disks, the installation hangs on the choice of the partitions. If I install Ubuntu on hard drives with GPT and UEFI mode, there are no problems with the installation!

Dimitri John Ledkov (xnox) wrote :

Apr 22 22:50:44 <jtaylor> xnox: syslog http://paste.ubuntu.com/5593912/
Apr 22 22:51:00 <jtaylor> xnox: partman http://paste.ubuntu.com/5593917
Apr 22 22:51:25 <jtaylor> xnox: installer/debug http://paste.ubuntu.com/5593919
Apr 22 22:57:55 <jtaylor> xnox: syslog relevant part http://paste.ubuntu.com/5593942

http://paste.ubuntu.com/5593942/ is probably the most interesting paste so far.

Dimitri John Ledkov (xnox) wrote :

<retoaded> xnox, plars said you may be looking for a test subject on the 1080701 bug; I have run into a similar set of circumstances installing raring server-amd64 on my lenovo M91p; dual boot box with precise and quantal; trying to install raring (it will eventually overwrite quantal) but installer (from USB stick) hangs after the "reading the disks" blurb.

Dan Kegel (dank) wrote :

Another possible workaround: add nosmp to the kernel commandline (e.g. press F6, escape, then type nosmp and press enter).
That worked for me two out of two times.

Dan Kegel (dank) wrote :

Hey, I found a deadlock.
In my current hang, strace shows that parted_server is blocking on
  open("/var/lib/partman/outfifo", O_RDONLY)
and /lib/partman/automatically_partition/15reuse/choices is blocking on
  open("/var/lib/partman/stopfifo", O_WRONLY|O_CREAT|O_TRUNC, 0666

Methinks the "protocol" is a little racy...

Dan Kegel (dank) wrote :

The script is hanging in close_dialog(); adding set -x shows

+ close_dialog
+ close_outfifo
+ exec
+ close_infifo
+ exec
+ exec
+ exec
+ exec
+ exec
+ exec
+ exec
+ exec
+ cat
+ exec

That function and its peer in parted_server could use a good code review.

Colin Watson (cjwatson) wrote :

Those functions themselves are well-reviewed, but they are a bit fragile against external programs breaking their protocol. My guess is that closing fds 6 and 7 for grub-mount the same way we do for mount (and also fd 3, i.e. debconf) will fix this: http://paste.ubuntu.com/5594654/

Colin Watson (cjwatson) on 2013-04-23
Changed in partman-auto (Ubuntu Raring):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-13.04
Changed in ubiquity (Ubuntu Raring):
assignee: Dmitrijs Ledkovs (xnox) → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 105ubuntu3

---------------
partman-auto (105ubuntu3) raring; urgency=low

  * Adjust reuse and replace scripts to redirect grub-mount in the same way
    we redirect mount, to avoid interference with debconf and parted_server
    (LP: #1080701). Thanks to Dmitrijs Ledkovs, Dan Kegel, Larry Works, and
    others for tireless debugging.
 -- Colin Watson <email address hidden> Tue, 23 Apr 2013 13:20:15 +0100

Changed in partman-auto (Ubuntu Raring):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.14.6

---------------
ubiquity (2.14.6) raring; urgency=low

  * Automatic update of included source packages: partman-auto 105ubuntu3
    (LP: #1080701).
 -- Colin Watson <email address hidden> Tue, 23 Apr 2013 13:23:23 +0100

Changed in ubiquity (Ubuntu Raring):
status: Confirmed → Fix Released
George Lynch (georgel) wrote :

I am running two systems -

Main PC has Asus F1A75-V Pro with:
 A6-3760 processor
 16G DDR3 memory
 OS on SSD

Test unit with Asus P5KPL-C1600:
 Intel Core2-Duo
 4G DDR2 memory
 OS on HDD

Ubuntu 1304 loaded and performs beautifully well on my P5KPL-C1600. Awesome responsiveness. It loaded whilst 12.10 was already installed. Whereas on the F1A75-V Pro machine, Ubuntu 1304 hangs on "preparing to install ubuntu", despite turning off swap.
I do not know if this will help.

Fabio Marconi (fabiomarconi) wrote :

It works fine on vbox
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Pjotr12345 (computertip) wrote :

The fix works fine on my box, which at first was hit by this bug. Thanks, developers!

Hugh Kernohan (hugh-kernohan) wrote :

I suffered this problem when shifting from 12.04 to a clean install of 13.04 with twin hard disks and a dual-boot to Windows. The 'Disk Setup' stage refused to recognise existing partitions or free space. Partman usually exited with error code 141 but sometimes crashed. I lost three days days of my life and became intimately acquainted with testdisk.

Eventually I tracked the fault to the existence of dmraid metadata on the two hard drives. It was not shown up by testdisk but was listed by dmraid. Using **dmraid -rE** to erase the unnecessary metadata meant that the ubiquity install routine functioned normally.

Erick Brunzell (lbsolost) wrote :

@ Hugh Kernohan,

While the symptoms may seem similar I believe your's is a different bug, so I recommend filing a new bug report.

ev (evtux) wrote :

In re. posts #134 & #135

Is there a 13.04 image built with these fixes out there?

Would be great if there is, and someone points to it. (This has been a true showstopper so far, btw).

Thanks all.

gcd0318 (gcd0318) wrote :

It still happens if ubuntu 13.04 is installed on a partitioned hdd
My machine:
cpu intel i5 3470
8G ram (single piece)
3T dist (single hdd)
boot via uefi usb disk

gcd0318 (gcd0318) wrote :

But sometimes it may go on after an extremely long waiting, maybe over 1 hour

Erick Brunzell (lbsolost) wrote :

I'll repeat again, since this bug is marked Fix Released, those encountering trouble since Raring was released should open new bug reports using the image that's failing using the command:

ubuntu-bug ubiquity

That will allow apport to collect info, and if you feel it's a regression to this bug you can say so in the new bug report.

Changed in ubiquity:
status: New → Fix Released
dozer (matthew-pocock) wrote :

I'm seeing essentially this with today's CD iso of 15.04, booting from USB.

Dan Kegel (dank) wrote :

I can't reproduce this with 15.04 booting from USB on a laptop with win8 and a big unpartitioned area;
it did seem to hang for a minute or two, but then went on to the next screen. So still fixed for me.

Lee Marshall (g5pk-lee-tvlf) wrote :

For my machine, I checked dmesg and saw the raid6_pq module had crashed, and its modprobe process was hanging unkillable (presumably what locks up the installer).

I'd guess that ubiquity is loading this module, and it crashes when it encounters something in the partitions it doesn't like, probably involving block sizes or alignment - I wasn't using RAID, but I was using a USB-SATA adaptor with a GPT disk label.

My successful workaround was to, in the live filesystem, delete/move the raid6_pq.ko module file and then run the installer.

I'll add more details later, when I have access to the machine.

Tomás Arjovsky (arkenan) wrote :

Had to deal with this problem installing Xubuntu 16.04. It happened on a specific machine, but it was replicated with different USB sticks, with different ISOs.

Previously, there was a 250 GB failing Xubuntu extended partition with a root mount point and Swap, and a 10GB NTFS partition with backups.

What DID work for me:
What Codeslinger (#88) suggested and Dan Kegel (#122) confirmed: mounting another (not related at all) partition. In my case, I mounted the NTFS partition in /media/foo. When I reached "Preparing to install Ubuntu", a dialog appeared asking if I wanted to unmount it. I replied "No", and for the first time the installation dialog didn't freeze loading the next step. The rest of the installation was completely normal.

What did NOT work for me:
- Deleting the previously failing Xubuntu extended partition.
- Unselecting the "install updates" option.
- Unselecting the "install third party software" option.
- Changing language (I was installing it in spanish and thought maybe it was that, but it wasn't).

Kirsch (6-ubuntu-com) wrote :

I want to reinstall Ubuntu (17.04) and have a complex partition layout.
After over 60 minutes where installer freeze, it shows me the new pre-calculated partition layout.

But I do not want to change the layout. I wond install on the exiting partitions. So I choose Manual.

Can not this be queried first, whether Manual or not? So you do not have to wait so long each time?

It is not the first time that i reinstall Ubuntu. So i know installer is not crash and i must only wait for a couple of times.

humble.life (lyreman) wrote :

I'm having the same problem over 6 years later. They still haven't sorted it.

Displaying first 40 and last 40 comments. View all 150 comments or add a comment.