Orca announces status of each steps' progress dot

Bug #1154345 reported by Paul Larson on 2013-03-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

During an install of raring daily (20130312) with orca enabled. There are several points where it starts reading the status of progress bars that I can't seem to see. Example:
"progress bar 4 75%... progress bar 4 100%... progress bar 6 100%..."
In particular, the screen where you can select whether to install 3rd party plugins and whether to pull updates while installing seems to trigger a lot of these. I don't remember this previously being the case in quantal.

The impact of this is that there is so much extraneous noise about these things that it's confusing and takes a long time to get through this extra information. At one point I just clicked through it and kept going, and it took several screens before the screen reader was able to catch up, I suppose due to the backlog of events it was still trying to read to me.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubiquity 2.13.13.1
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic x86_64
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
CasperVersion: 1.330
Date: Tue Mar 12 17:24:10 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130312)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Paul Larson (pwlars) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1154345

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

There are many progress bars now, each progress "dot" is a progress bar, as well as the long-running progress bar is running in the background. Hence orca is becoming more chatty when we change those.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
summary: - Orca gives status of lots of non-visible progress bars during install
+ Orca announces status of each steps' progress dot
tags: added: a11y
Alan Bell (alanbell) wrote :

can we get the priority of this bumped up a bit, the installer is basically completely unusable at the moment because it spends all its time talking about each of the dots

Nicholas Skaggs (nskaggs) wrote :

IMHO, This will need to be addressed before 14.04.

Adolfo Jayme (fitojb) on 2013-10-18
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Low → High
Dimitri John Ledkov (xnox) wrote :

A few times I've tried to find documentation of ATK objects and a11y framework. Even to the point of idling and discussing this on #a11y.

In essence, there doesn't appear to be any API to pragmatically control a11y in particular:
- emit custom events / announcements
- suppress events

Ideally I'd like to announce "Switching to step Prepare", but that is not currently possible.

If anybody knows / can point me to API or samples of custom ATK events I'd be glad to implement this. For the time being, it's not possible to do so.

Changed in ubiquity (Ubuntu):
status: Triaged → Confirmed
importance: High → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.17.0

---------------
ubiquity (2.17.0) trusty; urgency=low

  [ Aurélien Gâteau ]
  * Fix going back through skipped steps in kde_ui frontend.

  [ Dmitrijs Ledkovs ]
  * Switch "wireless" and "prepare" steps around (LP: #955232)
  * Don't read proc_cmdline twice (LP: #1213748)
  * Set wallpaper for 'feh' only, for others just assume gsettings schemes
    are correct.
  * Silence progress dots with invalid a11y (LP: #1154345)

  [ Colin Watson ]
  * Automatic update of included source packages: choose-mirror 2.50ubuntu1,
    debian-installer-utils 1.100ubuntu1, netcfg 1.111ubuntu1,
    partman-auto-lvm 51ubuntu1, partman-crypto 63ubuntu1, preseed
    1.62ubuntu1.
 -- Colin Watson <email address hidden> Tue, 29 Oct 2013 07:46:26 -0700

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers