Support for WPA Enterprise wireless networks

Bug #1107935 reported by Mathieu Trudel-Lapierre on 2013-01-28
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Status tracked in Xenial
Xenial
Critical
Cyrus Lien
network-manager-applet (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
ubiquity (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre
Xenial
Undecided
Unassigned

Bug Description

[Impact]
In some installations, WPA2 Enterprise support is required to have access to the network to complete the installation.

[Test cases]
1) Start installer from ubuntu-desktop image.
2) Follow the prompts to connect to the wireless network
3) Validate that a new dialog appears asking for the network password or credentials.

[Regression potential]
This impacts all wireless connections and so the type of regression to look for in general failure to connect to a secured wireless network when the authentication settings are correct (pre-shared key is correct), or in cases of connecting to an unsecured network.

For network-manager-applet:
- ubiquity uses nma gir to implement above
- the nma gir is missbuilt in xenial, and does not have correct dependencies, thus is not usable in the same process when both NM and NMA are in use. This was fixed in zesty. I have cherrypicked a fix for misscompiled gir. There is minimal regression potential (just a rebuild) because there are no reverse dependencies of the nma gir in xenial. And there are unlikely to be any external users of nma gir on xenial, since it is broken / has wrong dependencies.

---

Ubiquity doesn't appear to support WPA-Enterprise wifi networks -- there's just a single textbox shown to enter a passphrase, but most WPA-Enterprise will require at least a specific username and password, and possibly certificates.

NM should already export this information on DBus, it should be a matter of using libnm-gtk to query the user for the connection information rather than prompting for it directly from the installer.

<http://goo.gl/2iqv6j>: "If the selected network does require authentication, Network Manager’s standard dialog should open for you to enter those authentication details as soon as you choose “Connect…”."

(Not to be confused with bug 1018160, about WEP networks.)

Related branches

Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Jeremy Soller (jackpot51) wrote :

I have patches to add WPA-2 enterprise support using libnm-gtk. Patches are also required in libnm-gtk in order to work around issues with pygobject (not able to set ssid for NMSettingWireless)

I also fixed bugs in the current WiFi selection page.

Jeremy Soller (jackpot51) wrote :
Jeremy Soller (jackpot51) wrote :

I have updated the patch to remove a TODO in nm.py

I'll review this; but from a quick look, it seems like it should be more efficient to get NM to prompt the user for the right credentials in a separate window (ie. as it would already be done if you were to click on the network from the indicator), instead of requiring password entry from the ubiquity dialog. It would make Ubiquity less complex that way since we already have NM available in both live and ubiquity-dm sessions.

Changed in ubiquity (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
milestone: none → ubuntu-17.02
Jeremy Soller (jackpot51) wrote :

cyphermox: Thanks for the feedback! I will work that into the patch, I think it would remove about 100 lines of code from ubiquity. I would leave some things in nm.py until a similar change is made to kde_components/nmwidgets.py

Jeremy Soller (jackpot51) wrote :

Here is a new patch, removing the password box entirely and using libnm-gtk to supply the password dialog.

Note that you must have the libnm-gtk patch described above to test this.

tags: added: patch
Jeremy Soller (jackpot51) wrote :

I have added a merge request here, with the required changes rebased on the bazaar trunk: https://code.launchpad.net/~system76-dev/ubiquity/trunk/+merge/319142

Changed in ubiquity (Ubuntu):
milestone: ubuntu-17.02 → ubuntu-17.03

@Jeremy,

I really like the fact that you've spent time to get this together, and I like the added feature (and it looks like I had reported the bug initially...); but it was already late in the cycle by the time we got it to a decent point, and I dropped the ball getting it landed sooner and testing it, busy.

Days from release is definitely not the moment to land something like this -- it's a new feature, and one for which there is already a viable workaround (in using nm-applet directly to connect).

*However* I think that we should land this as soon as the Z+1 release is open, this seems like a very good improvement.

Moving to ubuntu-17.05; so that it shows up in my to-do list still for May and I can go back to this bug and do the merge.

Changed in ubiquity (Ubuntu):
milestone: ubuntu-17.03 → ubuntu-17.05
Jeremy Soller (jackpot51) wrote :

@cyphermox No problem, we have been carrying a patched ubiquity for the time being. Just glad to see it will be looked at soon!

Changed in oem-priority:
importance: Undecided → Critical
status: New → Confirmed
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
tags: added: risk
Yuan-Chen Cheng (ycheng-twn) wrote :

Test by Cyrus on Artful installation, enterprise wap works very well during
installation. version of ubiquity tested is 17.10.7.

Jeremy Soller (jackpot51) wrote :

We really need the patch on Xenial is all. I have tested it there, with an updated network-manager-applet, and it works well.

WPA2 Enterprise support is landed in artful already:

ubiquity (17.10.1) artful

[...]
  [ Jeremy Soller ]
  * Add support for WPA2 Enterprise.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Changed in ubiquity (Ubuntu Xenial):
status: New → In Progress
description: updated
Changed in network-manager-applet (Ubuntu):
status: New → Fix Released
Dimitri John Ledkov (xnox) wrote :

Test packages for this fix in xenial are now available from this ppa
https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3014

It is possible to enable and upgrade packages from this ppa in place, clear the network manager status (i.e. disconnect network, edit connections and delete it). Clear ubiquity / oem-config state and rerun the installer.

I will push these packages to proposed, to get a proposed desktop image out with these changes in.

Please let me know if any other images are required for this.

description: updated
Changed in network-manager-applet (Ubuntu Xenial):
status: New → In Progress

Hello Mathieu, or anyone else affected,

Accepted ubiquity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/2.21.63.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Mathieu, or anyone else affected,

Accepted network-manager-applet into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/1.2.6-0ubuntu0.16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager-applet (Ubuntu Xenial):
status: In Progress → Fix Committed
Dimitri John Ledkov (xnox) wrote :

Desktop images at http://cdimage.ubuntu.com/xenial/daily-live/pending/ contain all the relevant packages and are good to go to be tested.

These images have serial 20171101 or any later.

Please test these images and confirm if the proposed updates resolve this issue.

Cyrus Lien (cyruslien) wrote :

Verified image (serial 20171101), the issue was fixed.

The package name and version in the image are:
network-manager-gnome 1.2.6-0ubuntu0.16.04.4
ubiquity 2.21.63.5

tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: added: verification-done
removed: verification-needed
Changed in oem-priority:
status: Confirmed → Fix Committed
tags: added: sru
removed: risk
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.63.5

---------------
ubiquity (2.21.63.5) xenial; urgency=medium

  * Cherry-pick support for WPA2 Enterprise. LP: #1107935
  * Automatic update of included source packages: console-setup
    1.108ubuntu15.4.

 -- Dimitri John Ledkov <email address hidden> Tue, 31 Oct 2017 17:45:29 +0000

Changed in ubiquity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.2.6-0ubuntu0.16.04.4

---------------
network-manager-applet (1.2.6-0ubuntu0.16.04.4) xenial; urgency=medium

  * debian/patches/git_fix_wrong_status_for_wireless_toggle.patch:
    * Fix failing to load / use nma gir bindings. LP: #1107935

 -- Dimitri John Ledkov <email address hidden> Tue, 31 Oct 2017 15:04:49 +0000

Changed in network-manager-applet (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers