Python cannot create NMGtkWifiDialog

Bug #1667129 reported by Jeremy Soller on 2017-02-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Network Manager Applet
Fix Released
Medium
network-manager-applet (Ubuntu)
Medium
Unassigned

Bug Description

Python, using pygobject, is unable to spawn an NMGtkWifiDialog using the new function, due to the SSID setting not being settable (GArray<guchar> is not supported by pygobject). If the SSID is not set, the dialog will not display correctly, and will not function.

A potential fix is to copy the SSID from the AP information if present.

Jeremy Soller (jackpot51) wrote :

Here is a patch, python_wifi_dialog.patch

Jeremy Soller (jackpot51) wrote :

Here is a test script. Edit IFACE and AP_NAME to be what you can connect to.

Jeremy Soller (jackpot51) wrote :

Sorry, I attached an incorrect patch, showing usage in ubiquity.

Here is the correct patch.

Jeremy Soller (jackpot51) wrote :

This is required for a patch to ubiquity: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1107935

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Could you forward this upstream as a git formatted patch?

https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager&component=nm-applet

Jeremy Soller (jackpot51) wrote :

Sure thing.

Jeremy Soller (jackpot51) wrote :
Jeremy Bicha (jbicha) on 2017-02-25
Changed in network-manager-applet (Ubuntu):
status: Confirmed → Triaged
Changed in network-manager-applet:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in network-manager-applet (Ubuntu):
importance: Undecided → Medium
no longer affects: ubiquity (Ubuntu)
tags: added: patch patch-forwarded-upstream
Jeremy Soller (jackpot51) wrote :

If we update `network-manager-applet` to include this commit: https://git.gnome.org/browse/network-manager-applet/commit/?id=7a59d41e5f6666d0da51f1f7aae7518befdb1182, then `libnma` can be used, and this bug can be fixed without further code changes.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 1.4.2-1ubuntu4

---------------
network-manager-applet (1.4.2-1ubuntu4) zesty; urgency=medium

  * debian/patches/git_fix_libnma_pygobject_symbols.patch: fix symbol linking
    for libnma, so as to not mix libnm-util/libnm-glib and libnm code.
    (LP: #1667129)

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 08 Mar 2017 14:41:33 -0500

Changed in network-manager-applet (Ubuntu):
status: Triaged → Fix Released
Changed in network-manager-applet:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.