Ubuntu 13.04 Live-CD Installer hangs

Bug #1081245 reported by Simplehuman on 2012-11-20
90
This bug affects 20 people
Affects Status Importance Assigned to Milestone
ubiquity
New
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 13.04 Live-CD Installer hangs after second step. I chose "Download updates while installing" and "Install this third-party software"and then clicked "Continue" button. And nothing happens for 10 minutes.
I tried not to choose "Download updates while installing" or "Install this third-party software" but the issue is still there.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubiquity 2.13.3
ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
Uname: Linux 3.7.0-2-generic x86_64
ApportVersion: 2.6.2-0ubuntu5
Architecture: amd64
CasperVersion: 1.329
Date: Tue Nov 20 18:27:20 2012
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- nomodeset debian-installer/language=ru keyboard-configuration/layoutcode?=ru
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121120)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Simplehuman (simplehuman) wrote :
Simplehuman (simplehuman) wrote :

For 29-Nov-2012 build the problem is actual .

Omer Sakarya (aquan) wrote :

For 06-Dec-2012 build the problem is still actual.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Simplehuman (simplehuman) wrote :

For 15-Dec-2012 build the problem is still actual.

Xavier Guillot (valeryan-24) wrote :

Do you have an extended partition ? Could it be the same bug as :

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1080701

I also can not install Raring daily image, this never happened with same disk partitioning and previous versions.

Simplehuman (simplehuman) wrote :

Yes, I think it is the same bug as #1080701

Martin Wolf (mwolf-adiumentum) wrote :

i also have this problem, but i want to mention that my hardware configuration does not include an extended partition.

oshunluvr (stuartksmith) wrote :

This bug still present as of daily build 21-Jan. I have no extended partitions on any drive as all my drives are btrfs single filesystems except sda which has a single swap partition. Using nodmraid at boot did not bypass this bug.

Lek (k-lek) wrote :

Sad to say the installer still hangs in daily build 1-feb. Only one ext4 partition no swap.

atarixle (atarixle) wrote :

Feb 08 2013 ... still the same problem.

I got the feeling that the devs just don't care about this problem.

atarixle (atarixle) wrote :

Ok, this might solve the problem:

After I tried to start the installer from the test-run several time, I took a look at the syslog (just like mentioned in the upper posts here). We see, that the partman made the last logs.

So I killed the partman process (don't ask me which one of them, but it was none of the services).

After that I restarted the installer and it worked ... now I'm writing these lines on my freshly installed 13.04.

Simplehuman (simplehuman) wrote :

I did another workaround
Install 12.10, and run in the terminal "update-manager -d" . Than I have updated to 13.04 :)

Wanted to add a me too. System is Core I-7 with 128gb SSD and 12GB Ram. Trying to install to a single hard drive on a machine with 5 HDDs present.

Found a solution. If I mount all of the HDD and the SSD manually via Unity or Disk application, and select to proceed with all partitions mounted, then installer proceeds as normal.

na5m (forth4) wrote :

atarixle has a working solution. When the installer "hangs", open a root term and kill all process that come up with the command

#ps aux | grep part

The installer will then through up an error dialog. Click on the "Retry" button and prepare for joy.

Kudos to you, atarixle.

na5m

gothicknight (gothicknight) wrote :

I had this bug with the daily image of Raring (22th or 23th of this month).

I've tried to kill all processes beginning with "part" unsucessfully. So, as someone already had mentioned, having a BTRFS partition, I re-formated my BTRFS partition to EXT4 and the installer went without any problems.

If that is a possibility to anyone trying to install Raring, please give it a try.

jesse van dam (jesse-vandam) wrote :

I fixed the problem by doing the following. Solution works only if you want to complete override a disk. Please fill in the proper device of the harddisk to which you want to install ubuntu

sudo parted /dev/sda
mktable
#fill in gpt
#say yes
mkpart ext2 0 10
#ignore any performce warning since will overwritten anyhow
mkpart ext4 10 100%
set 1 bios_grub on
quit

and now start the installer and it should install.

Another note. If you get an error message like "partition table is incorrect" after reboot you have to go into your bios and select/create a/the uefi boot option.

Galvatron (megatron) wrote :

I recently had this issue with Kubuntu 13.04, Epox P4X400D motherboard (VIA P4X400 chipset) and Seagate Barracuda 7 120GB.

Glenn (g-mason) wrote :

I have an i7 with UEFI and 2 quad cord. Both the Daily build and the Bata 2 install work find on the i7 but stall on the quad cores. I have tried this from USB and DVD.

The only way from me to install 13.04 on the Quad core was install 12.04 upgrade to 12.10 then upgrade to 13.04.

Fraser McLean (voltboyee) wrote :

Yeah I am having this issue too trying to install Ubuntu 13.04 beta 2. I have 2 drives in my laptop with mixed NTFS and EXT4 partitions. Tried killing all the partman processes and the error came up. I retried and the hanging happened again.

Emmanuel Ch. (eruyome) wrote :

I am having the same problem with the 13.04 release (amd64).
Installation will freeze at "Preparing to Install Ubuntu" with the spinner.

albert fishnets (mateolingerhaus) wrote:
> Found a solution. If I mount all of the HDD and the SSD manually via Unity or Disk application,
> and select to proceed with all partitions mounted, then installer proceeds as normal.

Har har har. My solution was the exact opposite, unmount all mounted drives.

Bitbucket (donald-r-pierce) wrote :

If I delete the swap partition then the install will go through. It always hangs when there is a swap partition.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers