Ubiquity failed to proceed to partman, fails at replace recipe now...

Bug #1065502 reported by Jean-Baptiste Lallement on 2012-10-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Unassigned
Quantal
Medium
Unassigned
partman-auto (Ubuntu)
High
Dimitri John Ledkov
Quantal
High
Dimitri John Ledkov
ubiquity (Ubuntu)
High
Dimitri John Ledkov
Quantal
High
Dimitri John Ledkov

Bug Description

Quantal Desktop 20121011 and later running on VBox

TEST CASE
1. Boot from ISO
2. In ubiquity-dm press 'Install Ubuntu'
3. In step Prepare press 'Continue'

ACTUAL RESULT:
Installation hangs.

It occurs only on this VM, so it could be due to the existing partition.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.10 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu3
Architecture: i386
CasperVersion: 1.327
Date: Thu Oct 11 12:42:52 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Beta i386 (20121011)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
summary: - Ubiquity failed to proceed to partman in French
+ Ubiquity failed to proceed to partman
description: updated
description: updated
tags: added: testcase
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Paul Larson (pwlars) on 2012-10-12
tags: added: rls-q-incoming
Jean-Baptiste Lallement (jibel) wrote :

I am not sure it is a duplicate because in this case, I don't even see the partman screen and cannot choose any partitioning scheme.

description: updated
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1065502

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Here are the logs from my latest test.

The steps I followed:
1. Install Quantal once
2. reboot
3. Boot from the ISO
4. In ubiquity-dm select 'Install Ubuntu'
5. Keep the default and continue

Ubiquity hangs in step 'prepare' and never switches to the partitioner.

ps shows the following processes running:
parted_server
/bin/sh /lib/partman/display.d/10initial_auto
/bin/sh /lib/partman/display.d/10initial_auto
/bin/sh /lib/partman/automatically_partition/25replace/choices

Jean-Baptiste Lallement (jibel) wrote :
Dimitri John Ledkov (xnox) wrote :

/me did not want to fix replace method.

Thanks jibel, will look into this.

summary: - Ubiquity failed to proceed to partman
+ Ubiquity failed to proceed to partman, fails at replace recipe now...
Changed in ubiquity (Ubuntu Quantal):
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Fabio Marconi (fabiomarconi) wrote :

same for me even in Vbox

Fabio Marconi (fabiomarconi) wrote :

Not reproducible in real hardware

description: updated
description: updated
description: updated
Fabio Marconi (fabiomarconi) wrote :

I confirm that this bug is not reporducible in real hardware with one or more already installed systems, it works well proposing tio install alongside or erasing or something else

Steve Langasek (vorlon) wrote :

11:38 < xnox> slangasek: the root cause is unclean unmounting of the /target resulting with "journal replay required" on first mount.
11:39 < xnox> slangasek: which is cleared if you at least boot your system once, but not fine if you don't.
11:39 < slangasek> xnox: ah; so this is only a problem for people who are serial installers?
11:39 < xnox> yes.
11:40 < xnox> or force power-cycle shutdowners.
11:40 < slangasek> xnox: then that shouldn't justify a respin on its own if that's the worst of the symptoms. Unclean unmounting is obviously not good though, so please chase it up

So this doesn't appear to be a stop-ship bug. We can take the fix if we need a ubiquity upload for something else, but as long as the journal is replaying cleanly when users are doing a normal install, this seems to be a bug that's primarily relevant to testers and is therefore release-notable.

tags: added: rls-q-notfixing
removed: rls-q-incoming
Steve Langasek (vorlon) wrote :

(rls-q-notfixing tag set. If we determine this bug has an impact on actual installs, please clear the tag.)

Steve Langasek (vorlon) on 2012-10-14
Changed in ubuntu-release-notes:
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-release-notes:
status: Triaged → Invalid
Dimitri John Ledkov (xnox) wrote :

I have tried to reproduce this scenario in kvm and I cannot so far. I will try a couple more times.

Dimitri John Ledkov (xnox) wrote :

Is Virtualbox required to reproduce this bug?

summary: - Ubiquity failed to proceed to partman, fails at replace recipe now...
+ [VirtualBox] Ubiquity failed to proceed to partman, fails at replace
+ recipe now...

Reproduced with identical procedure in kvm. I gave VNC access to Dmitrijs for debugging.

summary: - [VirtualBox] Ubiquity failed to proceed to partman, fails at replace
- recipe now...
+ Ubiquity failed to proceed to partman, fails at replace recipe now...
Changed in partman-auto (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Colin Watson (cjwatson) on 2012-10-16
Changed in partman-auto (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 103ubuntu4

---------------
partman-auto (103ubuntu4) quantal; urgency=low

  * Carefully clean up tmp mountpoints, which can be unmounted yet still
    present. (LP: #1065502)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 16 Oct 2012 16:17:50 +0100

Changed in partman-auto (Ubuntu Quantal):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

Included in ubiquity 2.12.13.

Changed in ubiquity (Ubuntu Quantal):
status: Triaged → Fix Released
Alin Andrei (nilarimogard) wrote :

It's not fixed for me using the latest daily ISOs (tried Ubuntu and Xubuntu). For instance, Xubuntu Quantal has ubiquity 2.12.16 but still no go...

Dimitri John Ledkov (xnox) wrote :

@ Alin Andrei

Please file a new bug with `ubuntu-bug ubiquity` after reproducing your crash / hang. You can do so from TTY1 by pressing Ctrl-Alt-F1 Such that all the logs are attached. Without logs, it's impossible to investigate and your crash could be different to this bug.

Alin Andrei (nilarimogard) wrote :

@Dmitrijs Ledkovs: well, this is weird, after asking me if I want to include the log file, it says that Ubiquity is not an official Ubuntu package. See screenshot: http://i.imgur.com/CJEje.png

This is the daily Ubuntu Quantal ISO for October 17.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers