'ubuntu ubiquity: umount: /tmp/tmp.h3NCLhoxSh: not mounted' during a Reinstall attempt on a previously manually partioned vm installation

Bug #1065034 reported by Para Siva on 2012-10-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
High
Dimitri John Ledkov
Quantal
High
Dimitri John Ledkov
ubiquity (Ubuntu)
High
Dimitri John Ledkov
Quantal
High
Dimitri John Ledkov

Bug Description

When 'Reinstall Ubuntu 12.10' option is attempted on a vm with previously manually partitioned quantal installation the installation does not proceed and the following logs are present in syslog

Oct 10 13:14:09 ubuntu ubiquity: umount: /tmp/tmp.bR1Ar9vndu: not mounted
Oct 10 13:14:09 ubuntu ubiquity:
Oct 10 13:14:09 ubuntu ubiquity: mount: wrong fs type, bad option, bad superblock on /dev/vda1,
Oct 10 13:14:09 ubuntu ubiquity: missing codepage or helper program, or other error
Oct 10 13:14:09 ubuntu ubiquity:
Oct 10 13:14:09 ubuntu ubiquity: In some cases useful info is found in syslog - try
Oct 10 13:14:09 ubuntu kernel: [ 83.275403] EXT4-fs (vda1): INFO: recovery required on readonly filesystem
Oct 10 13:14:09 ubuntu kernel: [ 83.275407] EXT4-fs (vda1): write access unavailable, cannot proceed
Oct 10 13:14:09 ubuntu ubiquity: dmesg | tail or so
Oct 10 13:14:09 ubuntu ubiquity:
Oct 10 13:14:09 ubuntu ubiquity: mount: wrong fs type, bad option, bad superblock on /dev/vda6,
Oct 10 13:14:09 ubuntu ubiquity: missing codepage or helper program, or other error
Oct 10 13:14:09 ubuntu ubiquity:
Oct 10 13:14:09 ubuntu ubiquity: In some cases useful info is found in syslog - try
Oct 10 13:14:09 ubuntu ubiquity: dmesg | tail or so
Oct 10 13:14:09 ubuntu ubiquity:

There were 4 partitions
ext4- with mount point /
ext4 with mount point /boot
ext4 with mount point /home
swap

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity 2.12.9 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.5.0-17.27-generic 3.5.5
Uname: Linux 3.5.0-17-generic i686
ApportVersion: 2.6.1-0ubuntu2
Architecture: i386
Casper:
 Generating locales...
   en_US.UTF-8... done
 Generation complete.
 pwconv: failed to change the mode of /etc/passwd- to 0600
 Adding 'diversion of /usr/bin/bluetooth-applet to /usr/bin/bluetooth-applet.orig by casper'
CasperVersion: 1.327
Date: Wed Oct 10 13:17:52 2012
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Beta i386 (20121010)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Para Siva (psivaa) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1065034

tags: added: iso-testing
Paul Larson (pwlars) on 2012-10-10
tags: added: rls-q-incoming
Changed in ubiquity (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

first bug : it appears that /target is not unmounted cleanly as log replay is required on the first boot.
second bug : if that happens, we struggle to reinstall

workaround : boot once from the disk & run fsck and we can reinstall.

I believe there was already a similar bug open about unclean unmounting.

Colin Watson (cjwatson) on 2012-10-12
Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Changed in partman-auto (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Dmitrijs Ledkovs (xnox)
Changed in partman-auto (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 103ubuntu3

---------------
partman-auto (103ubuntu3) quantal; urgency=low

  * Also prefer grub-mount in reuse-do_option & replace-choices. (LP: #1065034)
 -- Dmitrijs Ledkovs <email address hidden> Fri, 12 Oct 2012 18:47:47 +0100

Changed in partman-auto (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.11

---------------
ubiquity (2.12.11) quantal; urgency=low

  [ Dmitrijs Ledkovs ]
  * Reveal grub combo box, only when setting grub options. (LP: #1064391)
    And use a frontend callback to do so. Thanks Colin for idea & patch.
  * Automatic update of included source packages: partman-auto
    103ubuntu3. (LP: #1065034)

  [ Colin Watson ]
  * Update translations from Launchpad.

  [ Jonathan Riddell ]
  * Remove formatting from recently added strings to ubiquity.template
    LP: #1065989
 -- Dmitrijs Ledkovs <email address hidden> Fri, 12 Oct 2012 20:39:26 +0100

Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers