[l10n] Indicator menus of "Accessibility" should be localized for installer

Bug #1040438 reported by Elsa Wang
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Fix Released
High
Unassigned
ubiquity (Ubuntu)
Fix Released
High
Colin Watson
Quantal
Fix Released
High
Colin Watson

Bug Description

Summary:

Install quantal or precise image (current) and during installation check installer localization, drop down menus for indicator "Accessibility" are not localized.

Steps to reproduce:

1. Install quantal or precise image

2. Check localization for installer

Expected results:

Full localization.

Actual results:

Drop down menus for "Accessibility" are still in English not translated.

Related branches

Revision history for this message
Elsa Wang (elsawang) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Revision history for this message
Samantha Jian-Pielak (samantha-jian) wrote :

The same with 12.10.1 (quantal-desktop-amd64.iso 05-Sep-2012 02:37)

Revision history for this message
Hendrik Knackstedt (hennekn) wrote :

This affects all languages.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
summary: - [l10n][zh_CN] Indicator menus of "Accessibility" should be localized for
+ [l10n] Indicator menus of "Accessibility" should be localized for
installer
tags: added: precise quantal
tags: removed: qin
description: updated
David Planella (dpm)
tags: added: qin
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
tags: added: l10n
David Planella (dpm)
tags: added: rls-q-incoming
Revision history for this message
Colin Watson (cjwatson) wrote :

I suspect we need to close and restart the accessibility indicator after setting the language, unless it can be told to change language over D-Bus or similar (probably not since this is generally a difficult thing for GTK+-based programs to do).

tags: removed: rls-q-incoming
Revision history for this message
Colin Watson (cjwatson) wrote :

Oh, in fact the indicator is implemented internally in ubiquity. That should actually be relatively easy then.

Changed in ubiquity (Ubuntu Quantal):
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → In Progress
Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu Quantal):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.6

---------------
ubiquity (2.12.6) quantal; urgency=low

  * Make the accessibility indicator menu items translatable (LP: #1040438).
    Note that this just adds the necessary infrastructure; we still need
    actual translations for this to be useful.
  * Drop dependency on realpath, not needed since hw-detect 1.89 (ubiquity
    2.11.14).
  * Bind-mount /run while installing packages in the target chroot, so that
    name resolution works (LP: #1055326).
  * Update translations from Launchpad (LP: #1056029).
  * Upgrade to Automake 1.11.6.
  * Automatic update of included source packages: debian-installer-utils
    1.91ubuntu5, flash-kernel 3.0~rc.4ubuntu26.
 -- Colin Watson <email address hidden> Fri, 28 Sep 2012 00:41:00 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Revision history for this message
Samantha Jian-Pielak (samantha-jian) wrote :

Those texts are still not localized.
ISO: quantal-desktop-amd64.iso 26-Sep-2012 07:52 downloaded from http://china-images.ubuntu.com/quantal/daily-live/current/

Reopening this bug (marking it confirmed)

Revision history for this message
Samantha Jian-Pielak (samantha-jian) wrote :

I can't change the status.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

@samantha-jian
This is fixed release in ubiquity, as those strings are now translatable.
The translation task is still open.
The translators should translate those strings.

Revision history for this message
Hendrik Knackstedt (hennekn) wrote :

The strings aren't available for translation yet. At least they are not in Launchpad nor the pot-file.

Revision history for this message
Colin Watson (cjwatson) wrote : Re: [Bug 1040438] Re: [l10n] Indicator menus of "Accessibility" should be localized for installer

They are certainly in the POT file. I was quite careful.

  #. Type: text
  #. Description
  #. An indicator menu item. The underscore goes before an accelerator key.
  #: ../ubiquity.templates:81001
  msgid "_High Contrast"
  msgstr ""

  #. Type: text
  #. Description
  #. An indicator menu item. The underscore goes before an accelerator key.
  #: ../ubiquity.templates:82001
  msgid "_Screen Reader"
  msgstr ""

  #. Type: text
  #. Description
  #. An indicator menu item. The underscore goes before an accelerator key.
  #: ../ubiquity.templates:83001
  msgid "_Keyboard Modifiers"
  msgstr ""

  #. Type: text
  #. Description
  #. An indicator menu item. The underscore goes before an accelerator key.
  #: ../ubiquity.templates:84001
  msgid "_On-screen Keyboard"
  msgstr ""

However, as you can see at
https://translations.launchpad.net/ubuntu/quantal/+source/ubiquity/+imports,
the new templates are still awaiting processing by Launchpad.

Revision history for this message
Colin Watson (cjwatson) wrote :
Changed in ubuntu-translations:
status: Triaged → Fix Released
Revision history for this message
Samantha Jian-Pielak (samantha-jian) wrote :

They are still not translated with 02-Oct image.
china ubuntu amd64 02-Oct-2012 22:55

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

The strings have been translated [1] when the next ubiquity upload with translation refresh is done and the images are build, you will be able to see them. Thank you for your patience.

[1] https://translations.launchpad.net/ubuntu/quantal/+source/ubiquity/+pots/ubiquity-debconf/

Revision history for this message
Colin Watson (cjwatson) wrote :

ubiquity 2.12.8 incorporates the Chinese translations (and others) for these strings, so this should work in tomorrow's daily build.

Revision history for this message
Samantha Jian-Pielak (samantha-jian) wrote :

The strings are shown translated with the Oct-07 China Ubuntu amd64 image (07-Oct-2012 22:55)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments