Chinese, Brazilian Portuguese, and English variant translations aren't shown during Karmic and Lucid installation

Bug #476269 reported by Aron Xu on 2009-11-06
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
ubiquity (Ubuntu)
Medium
Dylan McCall
ubiquity-slideshow-ubuntu (Ubuntu)
Medium
Colin Watson

Bug Description

In Karmic release's Live CD (and all other CDs during development, including beta, rc and other daily-lives), when users choose zh_CN ,aka Chinese (simplified), the translations of slides aren't shown up, original English content is shown instead.
I have checked the trunk branch and can make sure our translations were exported from Launchpad and committed before freeze, so this should be a bug but not a mistake in translations or missing the time.

Related branches

Aron Xu (happyaron) wrote :
Aron Xu (happyaron) wrote :
Adi Roiban (adiroiban) wrote :

I can confirm this problem.

The files are on the live-CD and they are translated.

also it looks like the javascript part is working and can use the zh_CN locales
http://l10n.ubuntu.tla.ro/ubuntu-karmic-ubiquity-slideshow/index.html#locale=zh_CN#controls

Also the locale is set for the environment and for the main ubiquity window

Changed in ubuntu-translations:
status: New → Triaged
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
importance: Undecided → Medium
Adi Roiban (adiroiban) wrote :

Same problem with pt_BR , instead of Brazilian portuguese translations the installer is displaying the portuguese translations.

My guest is that instead of passing the entire locale to ubiquity-slideshow, the locales is truncated.

summary: - Chinese translations aren't shown during Karmic installation
+ Chinese, Brazilian Portuguese, and English variant translations aren't
+ shown during Karmic installation
Adi Roiban (adiroiban) on 2009-11-07
Changed in ubuntu-translations:
status: Triaged → Confirmed

That would be my guess, too. If you open file:///usr/share/ubiquity-slideshow/slides/index.html#locale=zh_CN or file:///usr/share/ubiquity-slideshow/slides/index.html#locale=pt_BR in a web browser, the slideshow appears properly translated. Marking as affecting Ubiquity...

Changed in ubiquity-slideshow-ubuntu:
status: New → Invalid
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Invalid
Aron Xu (happyaron) wrote :

Since Adi has confirmed it in several other locales, I prefer raise the importance from Medium to High.

Changed in ubuntu-translations:
assignee: nobody → Aron Xu (happyaron)
importance: Medium → High
Aron Xu (happyaron) wrote :

@ubuntu-installer:
Could you have a look at this bug? I guess there must be more languages affected and it will evidently abase user experience.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Dylan McCall (dylanmccall) wrote :

Okay, I just linked a branch with a possible fix :)

It hasn't been tested, though, since I don't really know how. Still, it _should_ work.

Colin Watson (cjwatson) wrote :

Merged with some tweaks, thanks!

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.12

---------------
ubiquity (2.1.12) lucid; urgency=low

  [ Colin Watson ]
  * Add osextras.unlink_force, equivalent to 'rm -f', to save on tedious
    exception handling.
  * Only restart debconf-communicator when changing language, not every time
    we switch page. This speeds up page transitions quite a bit, and should
    incidentally fix LP: #508725 as well.
  * GTK frontend:
    - Check plugin builders as well when adding widgets (setting their
      names, making them callable by the toplevel, etc.). This fixes
      translations of the language, timezone, and keyboard pages.
  * Fix immediate retranslation when changing language.
  * Add a semaphore to misc.regain_privileges and misc.drop_privileges, so
    that a drop/regain pair always returns to the previous state.
    misc.drop_all_privileges is now more clearly one-way, enforced by an
    assertion.
  * Add a context manager (raised_privileges) and a function decorator
    (raise_privileges) that are equivalent to a
    regain_privileges/drop_privileges pair, but that wrap up the required
    try/finally logic to make it less likely that we'll end up at the wrong
    privilege level by mistake.
  * When attempting to upgrade the installer, only stop debconf-communicator
    once we've determined that we actually have something to upgrade
    (LP: #495175).
  * Require Python 2.6, for the 'with' statement.
  * Move default GRUB target calculation to ubiquity.misc, which is a better
    location for common code than ubiquity.components.summary. Try to avoid
    using (hd0) as the target (prefer the first device from grub-mkdevicemap
    output if possible), and, when installing from a non-CD medium, only
    reset the default boot device if we would otherwise end up installing
    GRUB to the installation medium.
  * Initialise FilteredCommand.ui_loop_level earlier, just in case
    (LP: #484452).

  [ Evan Dandrea ]
  * Allow the user to set a hostname in oem-config.
  * Finally, finally, finally successfully work around GTK+ not
    supporting height-for-width in labels.
  * Remove labels created by plugins from the focus chain.
  * Don't try to generate an apparmor cache in oem-config.
  * Slightly better exception printing in scripts/install.py
  * GNOME Bug #56070 (can't click button twice) has long since been
    closed. Remove hack.
  * Automatic update of included source packages: localechooser
    2.12ubuntu3, user-setup 1.28ubuntu3.

  [ Mario Limonciello ]
  * Drop old hack for reconfiguring mythbuntu-default-settings since
    this is fixed in user-setup now.
  * Drop old hack for copying ^xserver-xorg onto the target system. No
    longer necessary as thse variables don't exist in current installs.

  [ Dylan McCall ]
  * Use slideshow for language variants if available (LP: #476269).

  [ Michael Terry ]
  * Reset contents of timezone combo boxes every time the timezone page is
    entered (LP: #461104).
 -- Evan Dandrea <email address hidden> Wed, 20 Jan 2010 15:35:08 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
David Planella (dpm) on 2010-01-30
Changed in ubuntu-translations:
status: Confirmed → Fix Released
Aron Xu (happyaron) wrote :

This bug is not fixed in lucid daily-live 2010-02-03.

Changed in ubuntu-translations:
assignee: Aron Xu (happyaron) → nobody
status: Fix Released → Confirmed
Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Aron Xu (happyaron) wrote :

Also confirmed in lucid-desktop-amd64.iso of 2010-02-06.

summary: Chinese, Brazilian Portuguese, and English variant translations aren't
- shown during Karmic installation
+ shown during Karmic and Lucid installation
Aron Xu (happyaron) wrote :

In 2010-02-10 and 2010-02-17's Live CDs, the problem is there.

Changed in ubiquity (Ubuntu):
assignee: nobody → Dylan McCall (dylanmccall)
Dylan McCall (dylanmccall) wrote :

Forgot to mention, there is a new version of the patch waiting to be merged. I moved a bunch of work into the slideshow's own script, where it makes more sense. Ubiquity is back to just requesting the locale, but using the full string now instead of what comes before the _ (which was the original source of this problem).

David Planella (dpm) on 2010-03-23
Changed in ubuntu-translations:
status: Confirmed → Triaged
André Gondim (andregondim) wrote :

All translations in https://translations.launchpad.net/ubuntu/lucid/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-ubuntu/pt_BR/+translate?start=10 are correct, but in installation is pt isteand pt_BR, like show in attach

Aron Xu (happyaron) wrote :

Still persist in 23rd March's daily live.

Xhacker Liu (xhacker) wrote :

Confirmed in 22rd's daily, i386.

I don't know if this is related, but I'm running Lucid (as of march 28th) and ubiquity is still showing the slideshow in pt_PT instead of pt_BR (as I selected from the beginning).

But the interesting thing is that even if I install the language pack (pt_BR) after the instalation, Firefox and computer-janitor continues to be in pt_PT (and not in pt_BR).
I also remembered running Kubuntu Lucid some days ago and some programs were also in pt_PT.

Could it be a more complex problem?

Thanks.

El dg 28 de 03 de 2010 a les 22:19 +0000, en/na Rainer Oliveira va
escriure:
> I don't know if this is related, but I'm running Lucid (as of march
> 28th) and ubiquity is still showing the slideshow in pt_PT instead of
> pt_BR (as I selected from the beginning).
>
> But the interesting thing is that even if I install the language pack (pt_BR) after the instalation, Firefox and computer-janitor continues to be in pt_PT (and not in pt_BR).
> I also remembered running Kubuntu Lucid some days ago and some programs were also in pt_PT.
>
> Could it be a more complex problem?
>
> Thanks.
>

Rainer,

Thanks for your comment. I've got a few questions for you:

      * Did you have to manually install the pt_BR language pack after
        the installation?
      * If so, how did you do it?
      * After the installation on the system you're experiencing the
        problem, what's the output of the 'locale' command on the
        terminal? (in case you are not used to work with the terminal,
        you might find this useful:
        https://help.ubuntu.com/community/UsingTheTerminal)

This will help in determining whether we need to open a separate bug for
your problem.

Hi David.

* I manually installed the language pack after the instalation through System -> Administration -> Language Support (i guess this is the aplication's name in english). Another interesting thing is that the Language Support installs the pt_BR language pack as well as pt and pt_PT. In Language Support i see three languages installed: Portuguese (Brazilian), Portuguese and Portuguese (Portugal), which is, in my opinion, completally unecessary. I cant even uninstall one of them (they seem to be dependent on each other).
* My locale output is this:

LANG=pt_BR.utf8
LANGUAGE=pt_BR:pt:en
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
LC_ALL=

I dont understand this very well, but i think the problem might be in the 2nd line. Am I right?

Just for record, I never modify any of these files. I just do what Ubuntu tells me to do, ok?

Hope it helps.
Thanks.

Colin Watson (cjwatson) wrote :

Rainer, this looks like a separate problem (and I don't think it's particularly related to ubiquity, either). Please file it separately.

Dylan, I hope it's OK with you, but I'm going to go with a slightly different fix - there's a more fundamental bug in ubiquity's handling of the locale attribute on frontends that I think is what's really at fault here. I've tested my fix to that and it solves this bug. The slideshow's own handling of locales seems to be wrong - as far as I can see, it doesn't fall back from (e.g.) de_DE to de the way it should. As such I think I'd like to keep the locale selection code where it is at the moment. Hop onto #ubuntu-installer for a chat if you think this is wrong?

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Colin Watson (cjwatson) on 2010-04-01
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Invalid → In Progress
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 20

---------------
ubiquity-slideshow-ubuntu (20) lucid; urgency=low

  * Fall back from language variants (e.g. de_DE) to languages (e.g. de)
    (LP: #476269).
 -- Colin Watson <email address hidden> Thu, 01 Apr 2010 01:17:17 +0100

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.12

---------------
ubiquity (2.2.12) lucid; urgency=low

  [ Evan Dandrea ]
  * Accept and discard arguments to the KDE frontend's
    on_keyboard_layout_selected function (LP: #552399).

  [ Colin Watson ]
  * Fix pkgsel/ignore-incomplete-language-support check (LP: #527623).
  * KDE frontend:
    - Ensure that entries in extra_bar_frames are never None (LP: #536912).
    - Lock out manual partitioning operations while the partitioning backend
      is running (LP: #540203).
  * Don't lower-case the locale attribute on frontends. This was added a
    long time ago; since then, it's become unnecessary since i18n.get_string
    lower-cases the locale itself, and it prevented us from finding
    slideshow files for language variants (LP: #476269).
  * Automatic update of included source packages: partman-auto 89ubuntu4,
    partman-ext3 58ubuntu2.

  [ Jonathan Riddell ]
  * Move oem-config-prepare-kde.desktop install directory to
    /usr/share/applications/kde4/, else it is labelled as a KDE 3
    application
 -- Colin Watson <email address hidden> Thu, 01 Apr 2010 01:27:27 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
David Planella (dpm) wrote :

Marking as Fix Released for the Ubuntu Translations task as well. If this is not fixed for any of the affected teams, please feel free to reopen the translations task.

Changed in ubuntu-translations:
status: Triaged → Fix Released
André Gondim (andregondim) wrote :

I see some untranslated strings. As you can see in attach.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → New
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Fix Released
Changed in ubuntu-translations:
status: Fix Released → New
Dylan McCall (dylanmccall) wrote :

Hi André. I investigated that and it looks like the issue is, thankfully, just that the release you are seeing is out of date.
You can find out when the latest release of ubiquity-slideshow-ubuntu was made over here: https://edge.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu

The current one was made 6 days ago, and translations weren't actually updated for it. (I think they were last updated on March 24). That's why the experience on the daily ISO is lagging behind. (On that topic, it appears to be 100% there now. Nice work, people!).

You can see the current state of translations at https://translations.edge.launchpad.net/ubuntu/lucid/+source/ubiquity-slideshow-ubuntu

In short: nothing wrong here, just a matter of time and everything will work neatly.

Don't hesitate to open a new bug report if you encounter more issues. It scares me every time I see this one reappear, though, so please don't revive this particular bug report unless the issue you have is as described in the bug summary and description (at the top). The more bug numbers the merrier! It makes us look important ;)

André Gondim (andregondim) wrote :

Sorry my fault Dylan!

Cheers! ;)

tags: added: iso-testing
David Planella (dpm) on 2010-04-07
Changed in ubuntu-translations:
status: New → Fix Released
no longer affects: ubiquity-slideshow-ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers